<!doctype html ><html lang="en-US"><head><meta charset="UTF-8" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-cssad32bca34d57b213196048593c7c7c36c636ca3c3e046e1b36bdee1f77bee.css" as="style" media="all" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-css75093bc971a6ccb96e17e1a15ef7bd3566c140aa725c94e60899351443f6a.css" as="style" media="all" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-cssc5f12b3ac3828285c771d4f14b4cd0f549ad16c030d5b33982d646920c743.css" as="style" media="all" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-css24f5c078654f1ec7f1eb4d64bcfe4a5d56709bdd4cb130377c6433bb55ea2.css" as="style" media="all" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-css1e4853312cdbc09ea47a72cd9c24c91b5b771f9f46316a6faa9941db23225.css" as="style" media="all" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-css8a3a4e4b91024a2eca3dc6dfdc87528dae5fa42f257679ceca8d2d49185b2.css" as="style" media="all" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-cssa53b18fab1503dd95f227b426e763a1718e736a25dffb523882afac1a11e8.css" as="style" media="only screen and (max-width: 768px)" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-css6d2f1ae4a1899f8b7926e2337de0f8dccd0e8a2395185dc5e29cab29a8676.css" as="style" media="all" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-css9d43086becc17bed9a9b5cde9547da376cfdf7024bf75ed8655b3c5017736.css" as="style" media="all" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-css0d8813713ec4587e3dc3afa94d040ac398a8b7a9da9268c83fb3affff4100.css" as="style" media="all" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-css0a86a7d47b707c58d819c4aad1947ecf5fb7b4d5e4e29c1cc76a3d6776149.css" as="style" media="all" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-css8f3089371b7d2a5c5d7612fd625bef656d7ffa242480e11c019acc3d87022.css" as="style" media="all" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-cssd2a029c684347775a5a4c56c5c8a5fa9575eed477e502c965aadcb8d05367.css" as="style" media="all" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-csse4f78c2c80a74fdb29b34f312c9a2d5e0a60a2c8fd25857e9528db504613b.css" as="style" media="all" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-css07087d58c7bd2e9f6b4bd4519c287371f78c5e5d53d04dfaef20131fadf65.css" as="style" media="all" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-css7f204d4f1cce0b0d04ffb231e781a20a5e3143bc176caf0cec3f855898893.css" as="style" media="all" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-css404d6086b9c978048ff90f09f43eb5a7c70cbdf6bbe318fb55ebf8ba35540.css" as="style" media="all" /> <script data-cfasync="false">function fvmuag(){var e=navigator.userAgent;if(e.match(/x11.*ox\/54|id\s4.*us.*ome\/62|oobo|ight|tmet|eadl|ngdo|PTST/i))return!1;if(e.match(/x11.*me\/86\.0/i)){var r=screen.width;if("number"==typeof r&&1367==r)return!1}return!0}</script> <title>Sacramento Naturopathic Doctor Walks Across America for Health Equity and a Healthy America - Roseville Today</title><meta name="viewport" content="width=device-width, initial-scale=1.0"><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /><meta name="description" content="Sacramento, Calif. -To focus the national spotlight on health equity and emphasize the importance of preventing and reversing disease" /><link rel="canonical" href="https://www.rosevilletoday.com/news/sacramento/naturopathic-doctor-walks-across-america/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Sacramento Naturopathic Doctor Walks Across America for Health Equity and a Healthy America" /><meta property="og:description" content="Sacramento, Calif. -To focus the national spotlight on health equity and emphasize the importance of preventing and reversing disease, and optimizing health, I will be walking across the USA starting on September 12." /><meta property="og:url" content="https://www.rosevilletoday.com/news/sacramento/naturopathic-doctor-walks-across-america/" /><meta property="og:site_name" content="Roseville Today" /><meta property="article:publisher" content="https://www.facebook.com/RosevilleToday" /><meta property="article:published_time" content="2022-07-05T14:49:59+00:00" /><meta property="article:modified_time" content="2022-07-05T14:50:35+00:00" /><meta property="og:image" content="https://www.rosevilletoday.com/wp-content/uploads/2022/07/walk-usa.jpg" /><meta property="og:image:width" content="675" /><meta property="og:image:height" content="260" /><meta property="og:image:type" content="image/jpeg" /><meta name="author" content="Sacramento Naturopathic Medical Center" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@rrtoday" /><meta name="twitter:site" content="@rrtoday" /><meta name="twitter:label1" content="Written by" /><meta name="twitter:data1" content="Sacramento Naturopathic Medical Center" /><meta name="twitter:label2" content="Est. reading time" /><meta name="twitter:data2" content="4 minutes" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.rosevilletoday.com/#organization","name":"Roseville Today","url":"https://www.rosevilletoday.com/","sameAs":["https://www.instagram.com/rosevilletoday/","https://www.facebook.com/RosevilleToday","https://twitter.com/rrtoday"],"logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.rosevilletoday.com/#/schema/logo/image/","url":"https://www.rosevilletoday.com/wp-content/uploads/2021/04/rt-logo.png","contentUrl":"https://www.rosevilletoday.com/wp-content/uploads/2021/04/rt-logo.png","width":544,"height":180,"caption":"Roseville Today"},"image":{"@id":"https://www.rosevilletoday.com/#/schema/logo/image/"}},{"@type":"WebSite","@id":"https://www.rosevilletoday.com/#website","url":"https://www.rosevilletoday.com/","name":"Roseville Today","description":"Business, Travel and Entertainment","publisher":{"@id":"https://www.rosevilletoday.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.rosevilletoday.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.rosevilletoday.com/news/sacramento/naturopathic-doctor-walks-across-america/#primaryimage","url":"https://www.rosevilletoday.com/wp-content/uploads/2022/07/walk-usa.jpg","contentUrl":"https://www.rosevilletoday.com/wp-content/uploads/2022/07/walk-usa.jpg","width":675,"height":260,"caption":"Walk USA for Health Equity"},{"@type":"WebPage","@id":"https://www.rosevilletoday.com/news/sacramento/naturopathic-doctor-walks-across-america/#webpage","url":"https://www.rosevilletoday.com/news/sacramento/naturopathic-doctor-walks-across-america/","name":"Sacramento Naturopathic Doctor Walks Across America for Health Equity and a Healthy America - Roseville Today","isPartOf":{"@id":"https://www.rosevilletoday.com/#website"},"primaryImageOfPage":{"@id":"https://www.rosevilletoday.com/news/sacramento/naturopathic-doctor-walks-across-america/#primaryimage"},"datePublished":"2022-07-05T14:49:59+00:00","dateModified":"2022-07-05T14:50:35+00:00","description":"Sacramento, Calif. -To focus the national spotlight on health equity and emphasize the importance of preventing and reversing disease","breadcrumb":{"@id":"https://www.rosevilletoday.com/news/sacramento/naturopathic-doctor-walks-across-america/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.rosevilletoday.com/news/sacramento/naturopathic-doctor-walks-across-america/"]}]},{"@type":"BreadcrumbList","@id":"https://www.rosevilletoday.com/news/sacramento/naturopathic-doctor-walks-across-america/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.rosevilletoday.com/"},{"@type":"ListItem","position":2,"name":"News","item":"https://www.rosevilletoday.com/news/"},{"@type":"ListItem","position":3,"name":"Sacramento","item":"https://www.rosevilletoday.com/news/sacramento/"},{"@type":"ListItem","position":4,"name":"Sacramento Naturopathic Doctor Walks Across America for Health Equity and a Healthy America"}]},{"@type":"Article","@id":"https://www.rosevilletoday.com/news/sacramento/naturopathic-doctor-walks-across-america/#article","isPartOf":{"@id":"https://www.rosevilletoday.com/news/sacramento/naturopathic-doctor-walks-across-america/#webpage"},"author":{"name":"Sacramento Naturopathic Medical Center","@id":"https://www.rosevilletoday.com/#/schema/person/e8e2d6c44f816ceaac725aeb2d45f285"},"headline":"Sacramento Naturopathic Doctor Walks Across America for Health Equity and a Healthy America","datePublished":"2022-07-05T14:49:59+00:00","dateModified":"2022-07-05T14:50:35+00:00","mainEntityOfPage":{"@id":"https://www.rosevilletoday.com/news/sacramento/naturopathic-doctor-walks-across-america/#webpage"},"wordCount":697,"publisher":{"@id":"https://www.rosevilletoday.com/#organization"},"image":{"@id":"https://www.rosevilletoday.com/news/sacramento/naturopathic-doctor-walks-across-america/#primaryimage"},"thumbnailUrl":"https://www.rosevilletoday.com/wp-content/uploads/2022/07/walk-usa.jpg","articleSection":["Natural Wellness","Sacramento"],"inLanguage":"en-US"},{"@type":"Person","@id":"https://www.rosevilletoday.com/#/schema/person/e8e2d6c44f816ceaac725aeb2d45f285","name":"Sacramento Naturopathic Medical Center","description":"Dr. Dennis Godby, BS, MA, ND - A California licensed primary care provider. I can do what I love – helping people to not only optimize their health and energy, but to also improve the overall quality of their life. Education and Training: Doctor of Naturopathy, Sutter Medical Foundation; Board of Directors, Institute for Natural Medicine.","url":"https://www.rosevilletoday.com/author/dr-dennis-godby-nd/"}]}</script> <link rel="alternate" type="application/rss+xml" title="Roseville Today &raquo; Feed" href="https://www.rosevilletoday.com/feed/" /><link rel="alternate" type="text/calendar" title="Roseville Today &raquo; iCal Feed" href="https://www.rosevilletoday.com/events/?ical=1" /><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://www.rosevilletoday.com"> <script type="application/ld+json">{
"@context": "http://schema.org",
"@type": "BreadcrumbList",
"itemListElement": [
{
"@type": "ListItem",
"position": 1,
"item": {
"@type": "WebSite",
"@id": "https://www.rosevilletoday.com/",
"name": "Home"
}
},
{
"@type": "ListItem",
"position": 2,
"item": {
"@type": "WebPage",
"@id": "https://www.rosevilletoday.com/columns/",
"name": "Columns"
}
}
,{
"@type": "ListItem",
"position": 3,
"item": {
"@type": "WebPage",
"@id": "https://www.rosevilletoday.com/columns/natural-wellness/",
"name": "Natural Wellness"                                
}
}
,{
"@type": "ListItem",
"position": 4,
"item": {
"@type": "WebPage",
"@id": "https://www.rosevilletoday.com/news/sacramento/naturopathic-doctor-walks-across-america/",
"name": "Sacramento Naturopathic Doctor Walks Across America for Health Equity and a Healthy..."                                
}
}    
]
}</script> <link rel="icon" type="image/png" href="https://www.rosevilletoday.com/wp-content/uploads/2021/12/favicon.jpg"> <script id="rosev-ready">window.advanced_ads_ready=function(e,a){a=a||"complete";var d=function(e){return"interactive"===a?"loading"!==e:"complete"===e};d(document.readyState)?e():document.addEventListener("readystatechange",(function(a){d(a.target.readyState)&&e()}),{once:"interactive"===a})},window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[];</script> <link rel='stylesheet' id='formidable-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-cssad32bca34d57b213196048593c7c7c36c636ca3c3e046e1b36bdee1f77bee.css' type='text/css' media='all' /><link rel='stylesheet' id='tribe-events-pro-mini-calendar-block-styles-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-css75093bc971a6ccb96e17e1a15ef7bd3566c140aa725c94e60899351443f6a.css' type='text/css' media='all' /><link rel='stylesheet' id='wp-block-library-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-cssc5f12b3ac3828285c771d4f14b4cd0f549ad16c030d5b33982d646920c743.css' type='text/css' media='all' /><link rel='stylesheet' id='wc-blocks-vendors-style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-css24f5c078654f1ec7f1eb4d64bcfe4a5d56709bdd4cb130377c6433bb55ea2.css' type='text/css' media='all' /><link rel='stylesheet' id='wc-blocks-style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-css1e4853312cdbc09ea47a72cd9c24c91b5b771f9f46316a6faa9941db23225.css' type='text/css' media='all' /><style id='global-styles-inline-css' type='text/css' media="all">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</style><link rel='stylesheet' id='woocommerce-layout-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-css8a3a4e4b91024a2eca3dc6dfdc87528dae5fa42f257679ceca8d2d49185b2.css' type='text/css' media='all' /><link rel='stylesheet' id='woocommerce-smallscreen-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-cssa53b18fab1503dd95f227b426e763a1718e736a25dffb523882afac1a11e8.css' type='text/css' media='only screen and (max-width: 768px)' /><link rel='stylesheet' id='woocommerce-general-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-css6d2f1ae4a1899f8b7926e2337de0f8dccd0e8a2395185dc5e29cab29a8676.css' type='text/css' media='all' /><style id='woocommerce-inline-inline-css' type='text/css' media="all">.woocommerce form .form-row .required{visibility:visible}</style><link rel='stylesheet' id='wp_automatic_gallery_style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-css9d43086becc17bed9a9b5cde9547da376cfdf7024bf75ed8655b3c5017736.css' type='text/css' media='all' /><link rel='stylesheet' id='td-plugin-multi-purpose-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-css0d8813713ec4587e3dc3afa94d040ac398a8b7a9da9268c83fb3affff4100.css' type='text/css' media='all' /><link crossorigin="anonymous" rel='stylesheet' id='google-fonts-style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-css0a86a7d47b707c58d819c4aad1947ecf5fb7b4d5e4e29c1cc76a3d6776149.css' type='text/css' media='all' /><link rel='stylesheet' id='td-theme-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-css8f3089371b7d2a5c5d7612fd625bef656d7ffa242480e11c019acc3d87022.css' type='text/css' media='all' /><style id='td-theme-inline-css' type='text/css' media="all">@media (max-width:767px){.td-header-desktop-wrap{display:none}}@media (min-width:767px){.td-header-mobile-wrap{display:none}}</style><link rel='stylesheet' id='td-theme-woo-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-cssd2a029c684347775a5a4c56c5c8a5fa9575eed477e502c965aadcb8d05367.css' type='text/css' media='all' /><link rel='stylesheet' id='td-legacy-framework-front-style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-csse4f78c2c80a74fdb29b34f312c9a2d5e0a60a2c8fd25857e9528db504613b.css' type='text/css' media='all' /><link rel='stylesheet' id='td-legacy-framework-woo-style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-css07087d58c7bd2e9f6b4bd4519c287371f78c5e5d53d04dfaef20131fadf65.css' type='text/css' media='all' /><link rel='stylesheet' id='td-standard-pack-framework-front-style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-css7f204d4f1cce0b0d04ffb231e781a20a5e3143bc176caf0cec3f855898893.css' type='text/css' media='all' /><link rel='stylesheet' id='td-theme-demo-style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1657006430-css404d6086b9c978048ff90f09f43eb5a7c70cbdf6bbe318fb55ebf8ba35540.css' type='text/css' media='all' /> <script async='async' src='https://www.rosevilletoday.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script> <script async='async' src='https://www.rosevilletoday.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script> <script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/wp-automatic/js/main-front.js?ver=6.0' id='wp_automatic_gallery-js'></script> <script>window.tdb_globals = {"wpRestNonce":"a641fa8830","wpRestUrl":"https:\/\/www.rosevilletoday.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/","globalSettings":{"tdcSavingHistory":false},"isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};</script> <style id="tdb-global-colors" media="all">:root{--accent-color:#fff}</style> <script>window.tdwGlobal = {"adminUrl":"https:\/\/www.rosevilletoday.com\/wp-admin\/","wpRestNonce":"a641fa8830","wpRestUrl":"https:\/\/www.rosevilletoday.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/"};</script> <script>window.tdaGlobal = {"adminUrl":"https:\/\/www.rosevilletoday.com\/wp-admin\/","wpRestNonce":"a641fa8830","wpRestUrl":"https:\/\/www.rosevilletoday.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/","postId":77079};</script> <noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript><link rel="amphtml" href="https://www.rosevilletoday.com/news/sacramento/naturopathic-doctor-walks-across-america/?amp"> <script  src='https://www.googletagservices.com/tag/js/gpt.js' async></script> <script>var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];</script> <script>googletag.cmd.push(function() {
googletag.defineSlot('/1027827/300x250', [[300, 250], [336, 280]], 'div-gpt-ad-1526924072370-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});</script> <script>var tdBlocksArray = []; //here we store all the items for the current page
//td_block class - each ajax block uses a object of this class for requests
function tdBlock() {
this.id = '';
this.block_type = 1; //block type id (1-234 etc)
this.atts = '';
this.td_column_number = '';
this.td_current_page = 1; //
this.post_count = 0; //from wp
this.found_posts = 0; //from wp
this.max_num_pages = 0; //from wp
this.td_filter_value = ''; //current live filter value
this.is_ajax_running = false;
this.td_user_action = ''; // load more or infinite loader (used by the animation)
this.header_color = '';
this.ajax_pagination_infinite_stop = ''; //show load more at page x
}
// td_js_generator - mini detector
(function(){
var htmlTag = document.getElementsByTagName("html")[0];
if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
htmlTag.className += ' ie10';
}
if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
htmlTag.className += ' ie11';
}
if ( navigator.userAgent.indexOf("Edge") > -1 ) {
htmlTag.className += ' ieEdge';
}
if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
htmlTag.className += ' td-md-is-ios';
}
var user_agent = navigator.userAgent.toLowerCase();
if ( user_agent.indexOf("android") > -1 ) {
htmlTag.className += ' td-md-is-android';
}
if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
htmlTag.className += ' td-md-is-os-x';
}
if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
htmlTag.className += ' td-md-is-chrome';
}
if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
htmlTag.className += ' td-md-is-firefox';
}
if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
htmlTag.className += ' td-md-is-safari';
}
if( -1 !== navigator.userAgent.indexOf('IEMobile') ){
htmlTag.className += ' td-md-is-iemobile';
}
})();
var tdLocalCache = {};
( function () {
"use strict";
tdLocalCache = {
data: {},
remove: function (resource_id) {
delete tdLocalCache.data[resource_id];
},
exist: function (resource_id) {
return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
},
get: function (resource_id) {
return tdLocalCache.data[resource_id];
},
set: function (resource_id, cachedData) {
tdLocalCache.remove(resource_id);
tdLocalCache.data[resource_id] = cachedData;
}
};
})();
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var tdc_is_installed="yes";
var td_ajax_url="https:\/\/www.rosevilletoday.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=11.5.1";
var td_get_template_directory_uri="https:\/\/www.rosevilletoday.com\/wp-content\/plugins\/td-composer\/legacy\/common";
var tds_snap_menu="smart_snap_always";
var tds_logo_on_sticky="show";
var tds_header_style="3";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var td_user_incorrect="Username incorrect!";
var td_email_user_empty="Email or username empty!";
var td_pass_empty="Pass empty!";
var td_pass_pattern_incorrect="Invalid Pass Pattern!";
var td_retype_pass_incorrect="Retyped Pass incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#02355a";
var tds_smart_sidebar="";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var tdBlockNonce="94c1c82f41";
var tdDateNamesI18n={"month_names":["January","February","March","April","May","June","July","August","September","October","November","December"],"month_names_short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"day_names":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"day_names_short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]};
var td_ad_background_click_link="";
var td_ad_background_click_target="";</script> <script data-ad-client="ca-pub-5649489283520750" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script async src="https://www.googletagmanager.com/gtag/js?id=G-1069ECQ8NK"></script> <script>window.dataLayer = window.dataLayer || [];
function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'G-1069ECQ8NK');</script> <style type="text/css" id="wp-custom-css" media="all">div.tribe-events-single-event-recurrence-description{visibility:hidden;display:none}.td-author-counters{display:none}td{vertical-align:top!important}#yplink li a{color:#0f4c81}.tribe-events-widget-events-list{font-size:12px;border-radius:12px;background-color:#fafaf7;background-color:#bce5ff}.td-visible-desktop{background-color:#fff}.td-visible-tablet-landscape{background-color:#fff}.td-visible-tablet-portrait{background-color:#fff}.td-visible-phone{background-color:#b5d2f6;border-radius:6px}.sponsor-ad{padding:12px}h2.tribe-events-widget-events-list__header-title{font-weight:700;font-size:1.8em;color:#004e7e;position:relative;left:75px;left:100px}h3.tribe-events-widget-events-list__event-title{font-size:1.5em}a.yps{color:#1b2880;font-size:15px;color:#333}a.tribe-events-widget-events-list__view-more-link{padding-left:60px;font-weight:700;font-size:1.1em;position:relative;left:75px;position:relative;left:50px}.tribe-events-widget-events-list__event-datetime-wrapper{display:none}.tribe-events-widget-events-list__event-date-tag{font-weight:700;color:#343f47}.rss-widget-icon{display:none}a.rsswidget{color:#ffa128;font-weight:700;font-size:.9em;font-family:sans-serif,Arial}.rsswidget:link{color:#012e81;color:#333}.rsswidget:visited{color:#00276e}.tribe-events-notices{background-color:#ffc780;color:#000;font-weight:700;font-size:1.4em}.imgpad{padding-right:15px}#showcase{width:345px;height:auto}.tribe-events-calendar-list__event-row--featured{background-color:#e7e7e5;border-radius:8px}h2{padding-right:50px}</style><style media="all">.tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,.tds-button2 .tdm-btn-text,.tds-button2 i,.tds-button5:hover .tdm-btn-text,.tds-button5:hover i,.tds-button6 .tdm-btn-text,.tds-button6 i,.tdm_block_list .tdm-list-item i,.tdm_block_pricing .tdm-pricing-feature i,body .tdm-social-item i{color:#02355a}.tds-button1,.tds-button6:after,.tds-title2 .tdm-title-line:after,.tds-title3 .tdm-title-line:after,.tdm_block_pricing.tdm-pricing-featured:before,.tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,.tds-progress-bar1 .tdm-progress-bar:after,.tds-progress-bar2 .tdm-progress-bar:after,.tds-social3 .tdm-social-item{background-color:#02355a}.tds-button2:before,.tds-button6:before,.tds-progress-bar3 .tdm-progress-bar:after{border-color:#02355a}.tdm-btn-style1{background-color:#02355a}.tdm-btn-style2:before{border-color:#02355a}.tdm-btn-style2{color:#02355a}.tdm-btn-style3{-webkit-box-shadow:0 2px 16px #02355a;-moz-box-shadow:0 2px 16px #02355a;box-shadow:0 2px 16px #02355a}.tdm-btn-style3:hover{-webkit-box-shadow:0 4px 26px #02355a;-moz-box-shadow:0 4px 26px #02355a;box-shadow:0 4px 26px #02355a}</style></head><body class="post-template-default single single-post postid-77079 single-format-standard theme-Newspaper td-standard-pack woocommerce-no-js tribe-no-js page-template-www-rrtoday_609-public-wp-content-themes-newspaper-page-php tribe-theme-Newspaper naturopathic-doctor-walks-across-america global-block-template-11 td-local-news single_template_2 aa-prefix-rosev- td-boxed-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="td-scroll-up td-hide-scroll-up-on-mob" style="display:none;"><i class="td-icon-menu-up"></i></div><div class="td-menu-background" style="visibility:hidden"></div><div id="td-mobile-nav" style="visibility:hidden"><div class="td-mobile-container"><div class="td-menu-socials-wrap"><div class="td-menu-socials"> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/RosevilleToday" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.instagram.com/rosevilletoday/" title="Instagram"> <i class="td-icon-font td-icon-instagram"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.rosevilletoday.com/news/feed/" title="RSS"> <i class="td-icon-font td-icon-rss"></i> </a> </span></div><div class="td-mobile-close"> <a href="#" aria-label="Close"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-mobile-content"><div class="menu-td-demo-header-menu-container"><ul id="menu-td-demo-header-menu" class="td-mobile-main-menu"><li id="menu-item-168" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first menu-item-168"><a href="https://www.rosevilletoday.com/">Home</a></li><li id="menu-item-173" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-173"><a href="/news/">Local news<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-175" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-175"><a href="/news/roseville/">🌹 Roseville</a></li><li id="menu-item-174" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-174"><a href="/news/rocklin/">Rocklin</a></li><li id="menu-item-46156" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-46156"><a href="https://www.rosevilletoday.com/news/lincoln/">Lincoln</a></li><li id="menu-item-33550" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33550"><a href="https://www.rosevilletoday.com/news/auburn/">Auburn</a></li><li id="menu-item-50887" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50887"><a href="https://www.rosevilletoday.com/news/folsom/">Folsom</a></li><li id="menu-item-176" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-176"><a href="/news/sacramento/">Sacramento</a></li><li id="menu-item-48015" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48015"><a href="https://www.rosevilletoday.com/press-releases/">California News</a></li><li id="menu-item-57252" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57252"><a href="https://www.rosevilletoday.com/news/roseville/californias-10-largest-reservoirs-drought-status/">Reservoir Levels</a></li><li id="menu-item-69957" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-69957"><a href="https://www.rosevilletoday.com/news/roseville/california-snowpack-levels/">California Snowpack</a></li></ul></li><li id="menu-item-17466" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-17466"><a href="https://www.rosevilletoday.com/yp/">Yellow Pages<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-54119" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54119"><a href="https://www.rosevilletoday.com/yp/business/">Business</a></li><li id="menu-item-54120" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54120"><a href="https://www.rosevilletoday.com/yp/community/">Community</a></li><li id="menu-item-54121" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54121"><a href="https://www.rosevilletoday.com/yp/health-fitness/">Health &#038; Fitness</a></li><li id="menu-item-54122" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54122"><a href="https://www.rosevilletoday.com/yp/home-improvement/">Home Improvement</a></li><li id="menu-item-54123" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54123"><a href="https://www.rosevilletoday.com/yp/real-estate/">Real Estate</a></li><li id="menu-item-54124" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54124"><a href="https://www.rosevilletoday.com/yp/restaurants/">Restaurants</a></li></ul></li><li id="menu-item-233" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-233"><a href="/travel/">Travel<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-30808" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30808"><a href="https://www.rosevilletoday.com/author/todd-schofield/">🧳Travel Reviews</a></li><li id="menu-item-28186" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28186"><a href="https://www.rosevilletoday.com/travel/bay-area/">Bay Area</a></li><li id="menu-item-26018" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26018"><a href="https://www.rosevilletoday.com/travel/lake-tahoe/">Lake Tahoe &#8211; Reno</a></li><li id="menu-item-26019" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26019"><a href="https://www.rosevilletoday.com/travel/monterey-carmel/">Monterey and Carmel</a></li><li id="menu-item-26020" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26020"><a href="https://www.rosevilletoday.com/travel/napa-valley/">Napa Valley</a></li><li id="menu-item-26021" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26021"><a href="https://www.rosevilletoday.com/travel/sonoma/">Sonoma County</a></li><li id="menu-item-26022" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26022"><a href="https://www.rosevilletoday.com/travel/palm-springs/">Palm Springs Area</a></li><li id="menu-item-230" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-230"><a href="/travel/local-travel/">Placer / El Dorado / Sacramento</a></li></ul></li><li id="menu-item-234" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-234"><a href="/columns/">Columns<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-69530" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-69530"><a href="#">🌹 Why Roseville?<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-69894" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-69894"><a href="https://www.rosevilletoday.com/news/roseville/placer-county-ranks-1-in-quality-of-life-second-healthiest/">🌹 Quality of Life</a></li><li id="menu-item-69531" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-69531"><a href="https://www.rosevilletoday.com/news/roseville/roseville-only-california-city-among-moneys-best-places-to-live/">🌹 Places to Live</a></li><li id="menu-item-69534" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-69534"><a href="https://www.rosevilletoday.com/news/roseville/roseville-ranks-14th-nationally-for-younger-homebuyers/">🌹 Young Homebuyers</a></li><li id="menu-item-69533" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-69533"><a href="https://www.rosevilletoday.com/news/roseville/roseville-ranked-5th-in-nation-to-work-at-home/">🌹 Work from Home</a></li><li id="menu-item-75172" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-75172"><a href="https://www.rosevilletoday.com/news/roseville/venture-lab-roseville/">🌹 Entrepreneurs</a></li><li id="menu-item-69532" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-69532"><a href="https://www.rosevilletoday.com/news/roseville/roseville-9th-best-city-to-retire-in-united-states/">🌹 Retirement</a></li><li id="menu-item-69535" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-69535"><a href="https://www.rosevilletoday.com/travel/local-travel/top-5-reasons-we-love-roseville/">❤️ Our Favorites</a></li></ul></li><li id="menu-item-235" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-235"><a href="/columns/real-estate/">🏠 Real Estate</a></li><li id="menu-item-236" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-236"><a href="/columns/natural-wellness/">🍎 Natural Medicine</a></li><li id="menu-item-3876" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3876"><a href="/columns/car-reviews/">🚗 Weidel on Wheels</a></li><li id="menu-item-30989" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30989"><a href="https://www.rosevilletoday.com/author/todd-schofield/">✈️ Travel &#038; Music</a></li><li id="menu-item-47565" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47565"><a href="https://www.rosevilletoday.com/tag/roseville-city-school-district/">🏫 Roseville City School District</a></li><li id="menu-item-47564" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47564"><a href="https://www.rosevilletoday.com/tag/roseville-joint-union-high-school-district/">🏫 Roseville Joint Union HSD</a></li><li id="menu-item-48314" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48314"><a href="https://www.rosevilletoday.com/tag/roseville-safety-first/">👮 Roseville Safety Tips</a></li><li id="menu-item-48238" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48238"><a href="https://www.rosevilletoday.com/tag/hiking/">🚶🏾Hiking</a></li><li id="menu-item-48207" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48207"><a href="https://www.rosevilletoday.com/tag/rocklin-history-tour/">📜 Rocklin History Tour</a></li><li id="menu-item-29512" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29512"><a href="https://www.rosevilletoday.com/news/sacramento/laws/">⚖️ New Laws 2022</a></li><li id="menu-item-6022" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6022"><a href="/columns/disabilities">🐕‍🦺 Disabilities</a></li></ul></li><li id="menu-item-232" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-232"><a href="/music/">🎷 Music<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-76975" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76975"><a href="https://www.rosevilletoday.com/travel/lake-tahoe/lake-tahoe-bluegrass-beyond-festival/">July 22: Bluegrass &#038; Beyond</a></li><li id="menu-item-76690" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76690"><a href="https://www.rosevilletoday.com/music/music-articles/10-classic-summer-songs/">🎶 10 Classic Summer Songs</a></li><li id="menu-item-238" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-238"><a href="/music/concert-venues/">🎷 Concert Schedules</a></li><li id="menu-item-29889" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29889"><a href="https://www.rosevilletoday.com/music/festivals/">🎸 Music Festivals</a></li><li id="menu-item-240" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-240"><a href="/music/music-reviews/">🎶 Music Reviews</a></li><li id="menu-item-68750" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-68750"><a href="https://www.rosevilletoday.com/news/roseville/pandora-spotify-youtube-music-compared/">📻 Streaming Compared</a></li><li id="menu-item-11101" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11101"><a href="/music/grateful-dead-50/">⚡Grateful Dead</a></li></ul></li><li id="menu-item-13241" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-13241"><a href="/events/">Events<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-76976" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76976"><a href="https://www.rosevilletoday.com/travel/lake-tahoe/lake-tahoe-bluegrass-beyond-festival/">July 22: Bluegrass &#038; Beyond</a></li><li id="menu-item-26702" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26702"><a href="/events/">🎟️ View All Events</a></li><li id="menu-item-26703" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26703"><a href="https://www.rosevilletoday.com/product/single-event-listing-highlight/">🎉+ ADD Your Event</a></li></ul></li></ul></div></div></div></div><div class="td-search-background" style="visibility:hidden"></div><div class="td-search-wrap-mob" style="visibility:hidden"><div class="td-drop-down-search"><form method="get" class="td-search-form" action="https://www.rosevilletoday.com/"><div class="td-search-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div><div role="search" class="td-search-input"> <span>Search</span> <input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" /></div></form><div id="td-aj-search-mob" class="td-ajax-search-flex"></div></div></div><div id="td-outer-wrap" class="td-theme-wrap"><div class="tdc-header-wrap"><div class="td-header-wrap td-header-style-3"><div class="td-header-top-menu-full td-container-wrap"><div class="td-container td-header-row td-header-top-menu"><div class="top-bar-style-2"><div class="td-header-sp-top-widget"> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/RosevilleToday" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.instagram.com/rosevilletoday/" title="Instagram"> <i class="td-icon-font td-icon-instagram"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.rosevilletoday.com/news/feed/" title="RSS"> <i class="td-icon-font td-icon-rss"></i> </a> </span></div><div class="td-header-sp-top-menu"><div class="td_data_time"><div > Tuesday, July 5, 2022</div></div></div></div><div id="login-form" class="white-popup-block mfp-hide mfp-with-anim td-login-modal-wrap"><div class="td-login-wrap"> <a href="#" aria-label="Back" class="td-back-button"><i class="td-icon-modal-back"></i></a><div id="td-login-div" class="td-login-form-div td-display-block"><div class="td-login-panel-title">Sign in</div><div class="td-login-panel-descr">Welcome! Log into your account</div><div class="td_display_err"></div><form id="loginForm" action="#" method="post"><div class="td-login-inputs"><input class="td-login-input" autocomplete="username" type="text" name="login_email" id="login_email" value="" required><label for="login_email">your username</label></div><div class="td-login-inputs"><input class="td-login-input" autocomplete="current-password" type="password" name="login_pass" id="login_pass" value="" required><label for="login_pass">your password</label></div> <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login"></form><div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div><div class="td-login-info-text"><a class="privacy-policy-link" href="https://www.rosevilletoday.com/privacy-policy/">Privacy Policy</a></div></div><div id="td-forgot-pass-div" class="td-login-form-div td-display-none"><div class="td-login-panel-title">Password recovery</div><div class="td-login-panel-descr">Recover your password</div><div class="td_display_err"></div><form id="forgotpassForm" action="#" method="post"><div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label for="forgot_email">your email</label></div> <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password"></form><div class="td-login-info-text">A password will be e-mailed to you.</div></div></div></div></div></div><div class="td-banner-wrap-full td-container-wrap"><div class="td-container td-header-row td-header-header"><div class="td-header-sp-logo"> <a class="td-main-logo" href="https://www.rosevilletoday.com/"> <img class="td-retina-data" data-retina="https://www.rosevilletoday.com/wp-content/uploads/2022/05/rt-544-300x99.jpg" src="https://www.rosevilletoday.com/wp-content/uploads/2022/05/rt-272.jpg" alt="Rocklin & Roseville Today" width="272" height="90"/> <span class="td-visual-hidden">Roseville Today</span> </a></div><div class="td-header-sp-recs"><div class="td-header-rec-wrap"><div class="td-a-rec td-a-rec-id-header td-rec-hide-on-p tdi_1 td_block_template_11"><style media="all">.tdi_1.td-a-rec{text-align:center}.tdi_1 .td-element-style{z-index:-1}.tdi_1.td-a-rec-img{text-align:left}.tdi_1.td-a-rec-img img{margin:0 auto 0 0}@media (max-width:767px){.tdi_1.td-a-rec-img{text-align:center}}</style><div class="td-all-devices"><a href="https://www.rosevilletoday.com/advertise/"><img width="728" height="90" alt="Roseville Today" src="https://www.rosevilletoday.com/_img/roseville-leaderboard.jpg"/></a></div></div></div></div></div></div><div class="td-header-menu-wrap-full td-container-wrap"><div class="td-header-menu-wrap"><div class="td-container td-header-row td-header-main-menu black-menu"><div id="td-header-menu" role="navigation"><div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div><div class="td-main-menu-logo td-logo-in-header"> <a class="td-main-logo" href="https://www.rosevilletoday.com/"> <img class="td-retina-data" data-retina="https://www.rosevilletoday.com/wp-content/uploads/2022/05/rt-544-300x99.jpg" src="https://www.rosevilletoday.com/wp-content/uploads/2022/05/rt-272.jpg" alt="Rocklin & Roseville Today" width="272" height="90"/> </a></div><div class="menu-td-demo-header-menu-container"><ul id="menu-td-demo-header-menu-1" class="sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-168"><a href="https://www.rosevilletoday.com/">Home</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-173"><a href="/news/">Local news</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-175"><a href="/news/roseville/">🌹 Roseville</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-174"><a href="/news/rocklin/">Rocklin</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-46156"><a href="https://www.rosevilletoday.com/news/lincoln/">Lincoln</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-33550"><a href="https://www.rosevilletoday.com/news/auburn/">Auburn</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-50887"><a href="https://www.rosevilletoday.com/news/folsom/">Folsom</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-176"><a href="/news/sacramento/">Sacramento</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-48015"><a href="https://www.rosevilletoday.com/press-releases/">California News</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-57252"><a href="https://www.rosevilletoday.com/news/roseville/californias-10-largest-reservoirs-drought-status/">Reservoir Levels</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-69957"><a href="https://www.rosevilletoday.com/news/roseville/california-snowpack-levels/">California Snowpack</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-17466"><a href="https://www.rosevilletoday.com/yp/">Yellow Pages</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-54119"><a href="https://www.rosevilletoday.com/yp/business/">Business</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-54120"><a href="https://www.rosevilletoday.com/yp/community/">Community</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-54121"><a href="https://www.rosevilletoday.com/yp/health-fitness/">Health &#038; Fitness</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-54122"><a href="https://www.rosevilletoday.com/yp/home-improvement/">Home Improvement</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-54123"><a href="https://www.rosevilletoday.com/yp/real-estate/">Real Estate</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-54124"><a href="https://www.rosevilletoday.com/yp/restaurants/">Restaurants</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-233"><a href="/travel/">Travel</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-30808"><a href="https://www.rosevilletoday.com/author/todd-schofield/">🧳Travel Reviews</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-28186"><a href="https://www.rosevilletoday.com/travel/bay-area/">Bay Area</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-26018"><a href="https://www.rosevilletoday.com/travel/lake-tahoe/">Lake Tahoe &#8211; Reno</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-26019"><a href="https://www.rosevilletoday.com/travel/monterey-carmel/">Monterey and Carmel</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-26020"><a href="https://www.rosevilletoday.com/travel/napa-valley/">Napa Valley</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-26021"><a href="https://www.rosevilletoday.com/travel/sonoma/">Sonoma County</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-26022"><a href="https://www.rosevilletoday.com/travel/palm-springs/">Palm Springs Area</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-230"><a href="/travel/local-travel/">Placer / El Dorado / Sacramento</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-234"><a href="/columns/">Columns</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-69530"><a href="#">🌹 Why Roseville?</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-69894"><a href="https://www.rosevilletoday.com/news/roseville/placer-county-ranks-1-in-quality-of-life-second-healthiest/">🌹 Quality of Life</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-69531"><a href="https://www.rosevilletoday.com/news/roseville/roseville-only-california-city-among-moneys-best-places-to-live/">🌹 Places to Live</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-69534"><a href="https://www.rosevilletoday.com/news/roseville/roseville-ranks-14th-nationally-for-younger-homebuyers/">🌹 Young Homebuyers</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-69533"><a href="https://www.rosevilletoday.com/news/roseville/roseville-ranked-5th-in-nation-to-work-at-home/">🌹 Work from Home</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-75172"><a href="https://www.rosevilletoday.com/news/roseville/venture-lab-roseville/">🌹 Entrepreneurs</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-69532"><a href="https://www.rosevilletoday.com/news/roseville/roseville-9th-best-city-to-retire-in-united-states/">🌹 Retirement</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-69535"><a href="https://www.rosevilletoday.com/travel/local-travel/top-5-reasons-we-love-roseville/">❤️ Our Favorites</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-235"><a href="/columns/real-estate/">🏠 Real Estate</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-236"><a href="/columns/natural-wellness/">🍎 Natural Medicine</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3876"><a href="/columns/car-reviews/">🚗 Weidel on Wheels</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-30989"><a href="https://www.rosevilletoday.com/author/todd-schofield/">✈️ Travel &#038; Music</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-47565"><a href="https://www.rosevilletoday.com/tag/roseville-city-school-district/">🏫 Roseville City School District</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-47564"><a href="https://www.rosevilletoday.com/tag/roseville-joint-union-high-school-district/">🏫 Roseville Joint Union HSD</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-48314"><a href="https://www.rosevilletoday.com/tag/roseville-safety-first/">👮 Roseville Safety Tips</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-48238"><a href="https://www.rosevilletoday.com/tag/hiking/">🚶🏾Hiking</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-48207"><a href="https://www.rosevilletoday.com/tag/rocklin-history-tour/">📜 Rocklin History Tour</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-29512"><a href="https://www.rosevilletoday.com/news/sacramento/laws/">⚖️ New Laws 2022</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6022"><a href="/columns/disabilities">🐕‍🦺 Disabilities</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-232"><a href="/music/">🎷 Music</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-76975"><a href="https://www.rosevilletoday.com/travel/lake-tahoe/lake-tahoe-bluegrass-beyond-festival/">July 22: Bluegrass &#038; Beyond</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-76690"><a href="https://www.rosevilletoday.com/music/music-articles/10-classic-summer-songs/">🎶 10 Classic Summer Songs</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-238"><a href="/music/concert-venues/">🎷 Concert Schedules</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-29889"><a href="https://www.rosevilletoday.com/music/festivals/">🎸 Music Festivals</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-240"><a href="/music/music-reviews/">🎶 Music Reviews</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-68750"><a href="https://www.rosevilletoday.com/news/roseville/pandora-spotify-youtube-music-compared/">📻 Streaming Compared</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-11101"><a href="/music/grateful-dead-50/">⚡Grateful Dead</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-13241"><a href="/events/">Events</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-76976"><a href="https://www.rosevilletoday.com/travel/lake-tahoe/lake-tahoe-bluegrass-beyond-festival/">July 22: Bluegrass &#038; Beyond</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-26702"><a href="/events/">🎟️ View All Events</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-26703"><a href="https://www.rosevilletoday.com/product/single-event-listing-highlight/">🎉+ ADD Your Event</a></li></ul></li></ul></div></div><div class="header-search-wrap"><div class="td-search-btns-wrap"> <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle" data-toggle="dropdown"><i class="td-icon-search"></i></a> <a id="td-header-search-button-mob" href="#" class="dropdown-toggle" data-toggle="dropdown"><i class="td-icon-search"></i></a></div><div class="td-drop-down-search" aria-labelledby="td-header-search-button"><form method="get" class="td-search-form" action="https://www.rosevilletoday.com/"><div role="search" class="td-head-form-search-wrap"> <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" /></div></form><div id="td-aj-search"></div></div></div></div></div></div></div></div><div class="td-main-content-wrap td-container-wrap"><div class="td-container td-post-template-2"><article id="post-77079" class="post-77079 post type-post status-publish format-standard has-post-thumbnail category-natural-wellness category-sacramento" itemscope itemtype="https://schema.org/Article"><div class="td-pb-row"><div class="td-pb-span12"><div class="td-post-header"><div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://www.rosevilletoday.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Columns" class="entry-crumb" href="https://www.rosevilletoday.com/columns/">Columns</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Natural Wellness" class="entry-crumb" href="https://www.rosevilletoday.com/columns/natural-wellness/">Natural Wellness</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Sacramento Naturopathic Doctor Walks Across America for Health Equity and a Healthy...</span></div></div><ul class="td-category"><li class="entry-category"><a style="background-color:#d44206; color:#fff; border-color:#d44206;" href="https://www.rosevilletoday.com/columns/">Columns</a></li><li class="entry-category"><a style="background-color:#03749c; color:#fff; border-color:#03749c;" href="https://www.rosevilletoday.com/columns/natural-wellness/">Natural Wellness</a></li><li class="entry-category"><a style="background-color:#d44206; color:#fff; border-color:#d44206;" href="https://www.rosevilletoday.com/news/">News</a></li><li class="entry-category"><a style="background-color:#d44206; color:#fff; border-color:#d44206;" href="https://www.rosevilletoday.com/news/sacramento/">Sacramento</a></li></ul><header class="td-post-title"><h1 class="entry-title">Sacramento Naturopathic Doctor Walks Across America for Health Equity and a Healthy America</h1><div class="td-module-meta-info"><div class="td-post-author-name"><div class="td-author-by">▶</div> <a href="https://www.rosevilletoday.com/author/dr-dennis-godby-nd/">Sacramento Naturopathic Medical Center</a><div class="td-author-line"> -</div></div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-07-05T07:49:59-07:00" >July 5, 2022</time></span></div></header></div></div></div><div class="td-pb-row"><div class="td-pb-span8 td-main-content" role="main"><div class="td-ss-main-content"><div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-border td-ps-border-grey td-ps-notext td-ps-icon-color td-ps-text-color td-post-sharing-style16"><style media="all">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</style><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text"><div class="td-social-but-icon"><i class="td-icon-share"></i></div><div class="td-social-but-text">Share</div></div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.rosevilletoday.com%2Fnews%2Fsacramento%2Fnaturopathic-doctor-walks-across-america%2F" title="Facebook" ><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Sacramento+Naturopathic+Doctor+Walks+Across+America+for+Health+Equity+and+a+Healthy+America&url=https%3A%2F%2Fwww.rosevilletoday.com%2Fnews%2Fsacramento%2Fnaturopathic-doctor-walks-across-america%2F&via=rrtoday" title="Twitter" ><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://www.rosevilletoday.com/news/sacramento/naturopathic-doctor-walks-across-america/&title=Sacramento+Naturopathic+Doctor+Walks+Across+America+for+Health+Equity+and+a+Healthy+America" title="Linkedin" ><div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div><div class="td-social-but-text">Linkedin</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#bc83cfc9ded6d9dfc881efdddfceddd1d9d2c8d39cf2ddc8c9ced3ccddc8d4d5df9cf8d3dfc8d3ce9cebddd0d7cf9cfddfced3cfcf9cfdd1d9ced5dfdd9cdad3ce9cf4d9ddd0c8d49cf9cdc9d5c8c59cddd2d89cdd9cf4d9ddd0c8d4c59cfdd1d9ced5dfdd9aded3d8c581d4c8c8cccf869393cbcbcb92ced3cfd9cad5d0d0d9c8d3d8ddc592dfd3d193d2d9cbcf93cfdddfceddd1d9d2c8d393d2ddc8c9ced3ccddc8d4d5df91d8d3dfc8d3ce91cbddd0d7cf91dddfced3cfcf91ddd1d9ced5dfdd93" title="Email"><div class="td-social-but-icon"><i class="td-icon-mail"></i></div><div class="td-social-but-text">Email</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#" title="Print" ><div class="td-social-but-icon"><i class="td-icon-print"></i></div><div class="td-social-but-text">Print</div></a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top" title="More"><div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div> </a></div></div></div><div class="td-post-content tagdiv-type"><div class="td-post-featured-image"><a href="https://www.rosevilletoday.com/wp-content/uploads/2022/07/walk-usa.jpg" data-caption=""><img width="675" height="260" class="entry-thumb td-modal-image" src="https://www.rosevilletoday.com/wp-content/uploads/2022/07/walk-usa.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/07/walk-usa.jpg 675w, https://www.rosevilletoday.com/wp-content/uploads/2022/07/walk-usa-300x116.jpg 300w, https://www.rosevilletoday.com/wp-content/uploads/2022/07/walk-usa-600x231.jpg 600w" sizes="(max-width: 675px) 100vw, 675px" alt="Walk USA for Health Equity" title="walk-usa"/></a></div><h2 id="h-raising-awareness-of-america-s-health-disparities">Raising awareness of America&#8217;s health disparities</h2><p>Sacramento, Calif. -To focus the national spotlight on health equity and emphasize the importance of preventing and reversing disease, and optimizing health, I will be walking across the USA starting on September 12. My solo journey, the third across the U.S., begins in Myrtle Beach, South Carolina.</p><p><strong><a href="https://www.walkusaforhealthequity.org/" target="_blank" rel="noreferrer noopener">Walk USA For Health Equity</a></strong> (WUHE) was created to raise awareness of America&#8217;s health disparities. COVID&#8217;s devastating impact in communities of color where pre-existing pre-disposing, and often preventable medical conditions occurred, are evidence of the prevalence of such disparities. For example, according to researchers from <a href="https://med.nyu.edu" target="_blank" rel="noreferrer noopener">New York University School of Medicine</a>, one&#8217;s zip code has been shown to have a greater impact on health than one&#8217;s genetic code, including the length and quality of life.</p><div class="td-a-rec td-a-rec-id-content_inline tdi_2 td_block_template_11"><style media="all">.tdi_2.td-a-rec{text-align:center}.tdi_2 .td-element-style{z-index:-1}.tdi_2.td-a-rec-img{text-align:left}.tdi_2.td-a-rec-img img{margin:0 auto 0 0}@media (max-width:767px){.tdi_2.td-a-rec-img{text-align:center}}</style><div class="td-visible-desktop"><hr> Join Roseville Today on July 22 @<h3>Hard Rock Lake Tahoe Outdoor Arena</h3> <a href="https://bluegrassbeyond.com/?ref=RosevilleToday"><img alt='Bluegrass & Beyond South Lake Tahoe' class="sponsor-ad" src="https://www.rosevilletoday.com/bluegrass22/bluegrass-fest.jpg" width="645px"></a><hr></div><div class="td-visible-tablet-landscape"><hr> Join Roseville Today on July 22 @<h3>Hard Rock Lake Tahoe Outdoor Arena</h3> <a href="https://bluegrassbeyond.com/?ref=RosevilleToday"><img alt='Bluegrass & Beyond South Lake Tahoe' class="sponsor-ad" src="https://www.rosevilletoday.com/bluegrass22/bluegrass-fest.jpg" width="645px"></a><hr></div><div class="td-visible-tablet-portrait"><hr> Join Roseville Today July 22 @<h3>Hard Rock Lake Tahoe Outdoor Arena</h3> <a href="https://bluegrassbeyond.com/?ref=RosevilleToday"><img alt='Bluegrass & Beyond Festival' class="sponsor-ad" src="https://www.rosevilletoday.com/bluegrass22/bluegrass-340.jpg" width="340px"></a><hr></div><div class="td-visible-phone"><hr> Join Roseville Today on July 22 @<h3>Hard Rock Lake Tahoe Outdoor Arena</h3> <a href="https://bluegrassbeyond.com/?ref=RosevilleToday"><img alt='Lake Tahoe Bluegrass & Beyond' class="sponsor-ad" src="https://www.rosevilletoday.com/bluegrass22/bluegrass-340.jpg"></a><hr></div></div><h3>Health Equity</h3><p>What is health equity? According to the <a href="https://www.rwjf.org/en/library/research/2017/05/what-is-health-equity-.html" target="_blank" rel="noreferrer noopener">Robert Wood Johnson Foundation</a>,</p><blockquote class="wp-block-quote"><p>&#8220;Health equity means that everyone has a fair and just opportunity to be as healthy as possible. This requires removing obstacles to health such as poverty, discrimination, and their consequences, including powerlessness and lack of access to good jobs with fair pay, quality education and housing, safe environments, and health care.&#8221;</p></blockquote><h3 id="h-partnering-with-local-organizations">Partnering with local organizations</h3><p>To focus the national spotlight on all Americans having the opportunity to be healthy, WUHE was created. While information about how to get and stay healthy is vital, so also, is creating safer and life-giving neighborhoods where healthy food is available and affordable. A healthy lifestyle revolution across the USA is truly essential to reduce health disparities in vulnerable communities.</p><p>While I will walk one-fifth of the country each year by myself, I will be partnering with local organizations, such as <a href="https://ncanp.org/" target="_blank" rel="noreferrer noopener">North Carolina Association of Naturopathic Physicians</a>, ministers, health equity advocates and others. Examples of topics that will be included at community forums include: vitamin D, access to safe drinking water, exercise, access to fruit and vegetables, nutrition, mental health issues, and safe neighborhoods. The public events may also include health fairs with blood pressure, heart rate, glucose, and other free health checks.</p><p>The first leg of the walk-610 miles -will begin in Myrtle Beach, SC, on September 12, and end in Knoxville, TN, October 10, 2022. The complete itinerary can found at <a href="https://www.WalkUSAForHealthEquity.org" target="_blank" rel="noreferrer noopener">www.WalkUSAForHealthEquity.org</a>. The 2nd to 5th legs will take place from Knoxville, TN to Seattle, WA from 2023 to 2026.</p><p>To minimize the cost of the trip, and to put myself in a better position to meet people along the route, I will not be using a support vehicle, but will be pushing a &#8220;jogging stroller,&#8221; to carry some provisions. I will camp along the route unless other lodging is provided.</p><p>Each day&#8217;s walk will take approximately 8 hours, depending on the day&#8217;s scheduled distance, weather and the many conversations along the way. I will walk an average of 22 miles per day. Most days, the walk will begin about 7-8 am, and end about 4 pm, depending on local events planned, and other unforeseen factors that may arise.</p><h3>Fun facts of Walk USA For Health Equity</h3><div class="wp-block-image"><figure class="alignleft size-full"><img width="340" height="340" src="https://www.rosevilletoday.com/wp-content/uploads/2022/07/dennis-godby.jpg" alt="Dr Dennis Godby" class="wp-image-77081" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/07/dennis-godby.jpg 340w, https://www.rosevilletoday.com/wp-content/uploads/2022/07/dennis-godby-300x300.jpg 300w, https://www.rosevilletoday.com/wp-content/uploads/2022/07/dennis-godby-150x150.jpg 150w, https://www.rosevilletoday.com/wp-content/uploads/2022/07/dennis-godby-100x100.jpg 100w" sizes="(max-width: 340px) 100vw, 340px" /></figure></div><p>Days: 29; Distance: 610 miles; Steps per day: 48,000; Total steps: 1,342,000; Total hours walking: 244; Expected calories burned: 174,000 (equivalent to 1,581 slices of Dave&#8217;s Killer Bread); Expected water consumed: 200-250 liters; Cars encountered on highway: 63,000; Dogs: undetermined, but one is too many when solo; Bugs: Infinite.</p><p>As a 44-year veteran of long runs and walks of conscience for health and social justice, I hope to inspire transformation in individuals, community-based program efforts, and local/state and national policymaking. This walk will be powered by volunteers and other health equity advocates across the country.</p><p>People often ask me why I do these extreme endurance events that put me at risk. My response is: The amount of risk and vulnerability one is willing to endure for a cause is directly proportional to people&#8217;s willingness to open their hearts, their generosity, and their willingness to listen and be inspired. This method of non-violent, direct action, often &#8220;earns one the right to be heard,&#8221; from people I have just met.</p><p>If you would like to help me spread the word, please check out our website of how you can get involved: <a href="https://www.WalkUSAForHealthEquity.org" target="_blank" rel="noreferrer noopener">www.WalkUSAForHealthEquity.org</a>.</p><div class="wp-block-image"><figure class="alignleft size-full is-resized"><img loading="lazy" src="https://www.rosevilletoday.com/wp-content/uploads/2019/10/dr-godby.jpg" alt="Dr Dennis Godby" class="wp-image-37058" width="85" height="114"/></figure></div><p><strong>Dr. Dennis Godby, Naturopathic Doctor, Sutter Medical Foundation.</strong><br>He may be reached&nbsp;<a href="http://www.sac-nd.com/"><strong><em>SAC-ND.com</em></strong></a>&nbsp;, <strong><a href="https://www.facebook.com/SacramentoNaturopathicCenter/">Facebook</a></strong> or at his Sacramento Office (916) 446-2591.</p><p>Explore additional topics from Dr. Godby at <a href="https://www.rosevilletoday.com/columns/natural-wellness/"><strong>Natural Wellness.</strong></a></p><div class="td-a-rec td-a-rec-id-content_bottom tdi_3 td_block_template_11"><style media="all">.tdi_3.td-a-rec{text-align:center}.tdi_3 .td-element-style{z-index:-1}.tdi_3.td-a-rec-img{text-align:left}.tdi_3.td-a-rec-img img{margin:0 auto 0 0}@media (max-width:767px){.tdi_3.td-a-rec-img{text-align:center}}</style></div></div><footer><div class="td-post-source-tags"></div><div class="td-post-sharing-bottom"><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-border td-ps-border-grey td-ps-rounded td-ps-padding td-ps-icon-color td-post-sharing-style18"><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.rosevilletoday.com%2Fnews%2Fsacramento%2Fnaturopathic-doctor-walks-across-america%2F" title="Facebook" ><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Sacramento+Naturopathic+Doctor+Walks+Across+America+for+Health+Equity+and+a+Healthy+America&url=https%3A%2F%2Fwww.rosevilletoday.com%2Fnews%2Fsacramento%2Fnaturopathic-doctor-walks-across-america%2F&via=rrtoday" title="Twitter" ><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://www.rosevilletoday.com/news/sacramento/naturopathic-doctor-walks-across-america/&title=Sacramento+Naturopathic+Doctor+Walks+Across+America+for+Health+Equity+and+a+Healthy+America" title="Linkedin" ><div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div><div class="td-social-but-text">Linkedin</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#a699d5d3c4ccc3c5d29bf5c7c5d4c7cbc3c8d2c986e8c7d2d3d4c9d6c7d2cecfc586e2c9c5d2c9d486f1c7cacdd586e7c5d4c9d5d586e7cbc3d4cfc5c786c0c9d486eec3c7cad2ce86e3d7d3cfd2df86c7c8c286c786eec3c7cad2cedf86e7cbc3d4cfc5c780c4c9c2df9bced2d2d6d59c8989d1d1d188d4c9d5c3d0cfcacac3d2c9c2c7df88c5c9cb89c8c3d1d589d5c7c5d4c7cbc3c8d2c989c8c7d2d3d4c9d6c7d2cecfc58bc2c9c5d2c9d48bd1c7cacdd58bc7c5d4c9d5d58bc7cbc3d4cfc5c789" title="Email"><div class="td-social-but-icon"><i class="td-icon-mail"></i></div><div class="td-social-but-text">Email</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#" title="Print" ><div class="td-social-but-icon"><i class="td-icon-print"></i></div><div class="td-social-but-text">Print</div></a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom" title="More"><div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div> </a></div></div></div><div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://www.rosevilletoday.com/news/roseville/kia-stinger/">Kia Stinger lacks recognition</a></div></div><div class="td-next-prev-separator"></div></div><div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://www.rosevilletoday.com/author/dr-dennis-godby-nd/">Sacramento Naturopathic Medical Center</a></span></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Sacramento Naturopathic Medical Center"><meta itemprop="url" content="https://www.rosevilletoday.com/author/dr-dennis-godby-nd/"></span><meta itemprop="datePublished" content="2022-07-05T07:49:59-07:00"><meta itemprop="dateModified" content="2022-07-05T07:50:35-07:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.rosevilletoday.com/news/sacramento/naturopathic-doctor-walks-across-america/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.rosevilletoday.com/wp-content/uploads/2022/05/rt-272.jpg"></span><meta itemprop="name" content="Roseville Today"></span><meta itemprop="headline " content="Sacramento Naturopathic Doctor Walks Across America for Health Equity and a Healthy America"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.rosevilletoday.com/wp-content/uploads/2022/07/walk-usa.jpg"><meta itemprop="width" content="675"><meta itemprop="height" content="260"></span></footer><div class="td_block_wrap td_block_related_posts tdi_4 td_with_ajax_pagination td-pb-border-top td_block_template_11" data-td-block-uid="tdi_4" > <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>var block_tdi_4 = new tdBlock();
block_tdi_4.id = "tdi_4";
block_tdi_4.atts = '{"limit":6,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"tdi_4","td_column_number":3,"block_type":"td_block_related_posts","live_filter_cur_post_id":77079,"live_filter_cur_post_author":"6","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_4","tdc_css_class_style":"tdi_4_rand_style"}';
block_tdi_4.td_column_number = "3";
block_tdi_4.block_type = "td_block_related_posts";
block_tdi_4.post_count = "6";
block_tdi_4.found_posts = "489";
block_tdi_4.header_color = "";
block_tdi_4.ajax_pagination_infinite_stop = "";
block_tdi_4.max_num_pages = "82";
tdBlocksArray.push(block_tdi_4);</script> <h4 class="td-related-title td-block-title"><a id="tdi_5" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_4" href="#">▶ Related</a><a id="tdi_6" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_4" href="#">▶ More from Author</a></h4><div id=tdi_4 class="td_block_inner"><div class="td-related-row"><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/sacramento/carmichael-4th-of-july/" rel="nofollow bookmark" class="td-image-wrap" title="Carmichael celebrates 4th of July this Saturday" ><img width="218" height="150" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/06/carmichael-4th-218x150.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/06/carmichael-4th-218x150.jpg 218w, https://www.rosevilletoday.com/wp-content/uploads/2022/06/carmichael-4th-100x70.jpg 100w, https://www.rosevilletoday.com/wp-content/uploads/2022/06/carmichael-4th-534x367.jpg 534w" sizes="(max-width: 218px) 100vw, 218px" alt="Carmichael Red White and Blue" title="Carmichael celebrates 4th of July this Saturday" /></a></div> <a href="https://www.rosevilletoday.com/news/sacramento/" class="td-post-category">Sacramento</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/sacramento/carmichael-4th-of-july/" rel="bookmark" title="Carmichael celebrates 4th of July this Saturday">Carmichael celebrates 4th of July this Saturday</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/sacramento/great-american-triathlon/" rel="nofollow bookmark" class="td-image-wrap" title="Great American Triathlon July 16th along the American River Parkway" ><img width="218" height="150" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/06/great-american-triathlon-218x150.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/06/great-american-triathlon-218x150.jpg 218w, https://www.rosevilletoday.com/wp-content/uploads/2022/06/great-american-triathlon-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Great American Triathlon" title="Great American Triathlon July 16th along the American River Parkway" /></a></div> <a href="https://www.rosevilletoday.com/news/sacramento/" class="td-post-category">Sacramento</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/sacramento/great-american-triathlon/" rel="bookmark" title="Great American Triathlon July 16th along the American River Parkway">Great American Triathlon July 16th along the American River Parkway</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/auburn/special-olympics-torch-run-placer-sacramento/" rel="nofollow bookmark" class="td-image-wrap" title="Special Olympics Torch Run in Placer and Sacramento" ><img width="218" height="150" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2013/06/torch-run-218x150.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2013/06/torch-run-218x150.jpg 218w, https://www.rosevilletoday.com/wp-content/uploads/2013/06/torch-run-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Special Olympics Torch Run" title="Special Olympics Torch Run in Placer and Sacramento" /></a></div> <a href="https://www.rosevilletoday.com/news/auburn/" class="td-post-category">Auburn</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/auburn/special-olympics-torch-run-placer-sacramento/" rel="bookmark" title="Special Olympics Torch Run in Placer and Sacramento">Special Olympics Torch Run in Placer and Sacramento</a></h3></div></div></div></div><div class="td-related-row"><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/15-tips-surviving-summer-chronic-lung-disease/" rel="nofollow bookmark" class="td-image-wrap" title="15 Tips for Surviving Summer With Chronic Lung Disease" ><img width="218" height="150" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2017/06/breathe-218x150.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2017/06/breathe-218x150.jpg 218w, https://www.rosevilletoday.com/wp-content/uploads/2017/06/breathe-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="And Breath sign" title="15 Tips for Surviving Summer With Chronic Lung Disease" /></a></div> <a href="https://www.rosevilletoday.com/news/roseville/" class="td-post-category">Roseville News</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/15-tips-surviving-summer-chronic-lung-disease/" rel="bookmark" title="15 Tips for Surviving Summer With Chronic Lung Disease">15 Tips for Surviving Summer With Chronic Lung Disease</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/sacramento/coping-trauma-mass-shootings/" rel="nofollow bookmark" class="td-image-wrap" title="Coping with the trauma and tragedy of mass shootings" ><img width="218" height="150" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/05/trauma-tragedy-218x150.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/05/trauma-tragedy-218x150.jpg 218w, https://www.rosevilletoday.com/wp-content/uploads/2022/05/trauma-tragedy-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Coping with trauma and tragedy" title="Coping with the trauma and tragedy of mass shootings" /></a></div> <a href="https://www.rosevilletoday.com/press-releases/" class="td-post-category">California News Updates</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/sacramento/coping-trauma-mass-shootings/" rel="bookmark" title="Coping with the trauma and tragedy of mass shootings">Coping with the trauma and tragedy of mass shootings</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/sacramento/gov-newsom-proposed-california-budget/" rel="nofollow bookmark" class="td-image-wrap" title="Governor Newsom $300.7 billion proposed budget fueled in part by massive surplus" ><img width="218" height="150" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/05/proposed-budget-218x150.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/05/proposed-budget-218x150.jpg 218w, https://www.rosevilletoday.com/wp-content/uploads/2022/05/proposed-budget-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Proposed Budget" title="Governor Newsom $300.7 billion proposed budget fueled in part by massive surplus" /></a></div> <a href="https://www.rosevilletoday.com/press-releases/" class="td-post-category">California News Updates</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/sacramento/gov-newsom-proposed-california-budget/" rel="bookmark" title="Governor Newsom $300.7 billion proposed budget fueled in part by massive surplus">Governor Newsom $300.7 billion proposed budget fueled in part by massive surplus</a></h3></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_4" data-td_block_id="tdi_4"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_4" data-td_block_id="tdi_4"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div></div></div></div><div class="td-pb-span4 td-main-sidebar" role="complementary"><div class="td-ss-main-sidebar"><aside id="custom_html-18" class="widget_text td_block_template_11 widget custom_html-18 widget_custom_html"><h4 class="td-block-title"><span>❤️ our Local Sponsors</span></h4><div class="textwidget custom-html-widget"><div id='div-gpt-ad-1526924072370-0' style='width: 300px; height: 250px;'> <script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1526924072370-0'); });</script> </div></div></aside><aside id="rss-4" class="td_block_template_11 widget rss-4 widget_rss"><h4 class="td-block-title"><span><a class="rsswidget rss-widget-feed" href="https://www.rosevilletoday.com/yp/feed/rss2/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.rosevilletoday.com/wp-includes/images/rss.png" alt="RSS" loading="lazy" /></a> <a class="rsswidget rss-widget-title" href="https://www.rosevilletoday.com/yp">📇Business Updates</a></span></h4><ul><li><a class='rsswidget' href='https://www.rosevilletoday.com/yp/thunder-valley-job-fairs-2/'>Thunder Valley Casino Resort Job Fairs in July</a></li><li><a class='rsswidget' href='https://www.rosevilletoday.com/yp/cpc-scientific-rocklin/'>CPC Scientific selects Rocklin for manufacturing facility</a></li><li><a class='rsswidget' href='https://www.rosevilletoday.com/yp/mochinut-roseville/'>Mochinut</a></li><li><a class='rsswidget' href='https://www.rosevilletoday.com/yp/terracina-at-whitney-ranch/'>Terracina at Whitney Ranch</a></li><li><a class='rsswidget' href='https://www.rosevilletoday.com/yp/raleys-one-market-open-west-roseville/'>Raley’s O-N-E Market open in West Roseville</a></li></ul></aside><aside id="custom_html-24" class="widget_text td_block_template_11 widget custom_html-24 widget_custom_html"><h4 class="td-block-title"><span>Local Business &#8211; Join Today!</span></h4><div class="textwidget custom-html-widget"><h3>Business</h3><ul><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/business/commercial-cleaning-service/">Commercial Cleaning</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/business/event-centers/">Event Centers</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/advertise/">Online Advertising</a></li></ul><h3>Dining</h3><ul><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/restaurants/indian/">Indian Restaurants</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/restaurants/bakeries/">Bakeries</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/restaurants/craft-beer/">Craft Brews</a></li></ul><h3>Health &amp; Fitness</h3><ul><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/health-fitness/alternative-medicine/">Alternative Medicine</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/health-fitness/dentists/">Dentists</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/health-fitness/swim-lessons/">Swim Lessons</a></li></ul><h3>Home Improvement</h3><ul><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/home-improvement/heating-air/">Heating and Air</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/home-improvement/pest-control/">Pest Control</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/home-improvement/solar-panel-cleaning/">Solar Panel Cleaning</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/business/roseville-window-cleaning/">Window Cleaning</a></li></ul><h3>Real Estate</h3><ul><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/real-estate/apartment-rentals/">Apartments</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/real-estate/real-estate-agents/">Real Estate Agents</a></li></ul></div></aside></div></div></div></article></div></div><div class="tdc-footer-wrap"><div class="td-footer-wrapper td-footer-container td-container-wrap"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span12"></div></div><div class="td-pb-row"><div class="td-pb-span4"><div class="td_block_wrap td_block_16 td_block_widget tdi_8 td-pb-border-top td_block_template_11 td-column-1 td_block_padding" data-td-block-uid="tdi_8" ><style media="all">.td_block_template_11.widget>ul>li{margin-left:0!important}.td_block_template_11 .td-block-title{font-size:17px;font-weight:500;margin-top:2px;margin-bottom:24px;line-height:44px;padding:0;position:relative;text-align:left}.td_block_template_11 .td-block-title:before,.td_block_template_11 .td-block-title:after{content:'';width:100%;height:2px;position:absolute;left:0;background-color:#f5f5f5}.td_block_template_11 .td-block-title:after{bottom:100%}.td_block_template_11 .td-block-title:before{top:100%}.td_block_template_11 .td-block-title>*{color:#000}.td_block_template_11 .td-subcat-filter{line-height:44px;display:table}.td_block_template_11 .td-subcat-dropdown{line-height:1;position:static}.td_block_template_11 .td-subcat-dropdown .td-subcat-more{margin-bottom:0!important}.td_block_template_11 .td-subcat-dropdown ul:after{height:2px!important}.td_block_template_11 .td-related-title a{margin-right:20px}@media (max-width:767px){.td_block_template_11 .td-related-title a{font-size:15px}}.td_block_template_11 .td-related-title .td-cur-simple-item{color:#4db2ec}</style> <script>var block_tdi_8 = new tdBlock();
block_tdi_8.id = "tdi_8";
block_tdi_8.atts = '{"custom_title":"Latest News","custom_url":"","block_template_id":"","header_text_color":"#","border_color":"#","accent_text_color":"#","mx7_tl":"","mx7_el":"","m6_tl":"","limit":"3","offset":"","el_class":"","post_ids":"-77079","category_id":"","category_ids":"21,27","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget tdi_8","block_type":"td_block_16","separator":"","show_modified_date":"","time_ago":"","time_ago_add_txt":"ago","time_ago_txt_pos":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","mx7f_title_font_header":"","mx7f_title_font_title":"Article title","mx7f_title_font_settings":"","mx7f_title_font_family":"","mx7f_title_font_size":"","mx7f_title_font_line_height":"","mx7f_title_font_style":"","mx7f_title_font_weight":"","mx7f_title_font_transform":"","mx7f_title_font_spacing":"","mx7f_title_":"","mx7f_cat_font_title":"Article category tag","mx7f_cat_font_settings":"","mx7f_cat_font_family":"","mx7f_cat_font_size":"","mx7f_cat_font_line_height":"","mx7f_cat_font_style":"","mx7f_cat_font_weight":"","mx7f_cat_font_transform":"","mx7f_cat_font_spacing":"","mx7f_cat_":"","mx7f_meta_font_title":"Article meta info","mx7f_meta_font_settings":"","mx7f_meta_font_family":"","mx7f_meta_font_size":"","mx7f_meta_font_line_height":"","mx7f_meta_font_style":"","mx7f_meta_font_weight":"","mx7f_meta_font_transform":"","mx7f_meta_font_spacing":"","mx7f_meta_":"","mx7f_ex_font_title":"Article excerpt","mx7f_ex_font_settings":"","mx7f_ex_font_family":"","mx7f_ex_font_size":"","mx7f_ex_font_line_height":"","mx7f_ex_font_style":"","mx7f_ex_font_weight":"","mx7f_ex_font_transform":"","mx7f_ex_font_spacing":"","mx7f_ex_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","color_preset":"","border_top":"","tdc_css_class":"tdi_8","tdc_css_class_style":"tdi_8_rand_style"}';
block_tdi_8.td_column_number = "1";
block_tdi_8.block_type = "td_block_16";
block_tdi_8.post_count = "3";
block_tdi_8.found_posts = "6091";
block_tdi_8.header_color = "";
block_tdi_8.ajax_pagination_infinite_stop = "";
block_tdi_8.max_num_pages = "2031";
tdBlocksArray.push(block_tdi_8);</script> <div class="td-block-title-wrap"><h4 class="td-block-title"><span class="td-pulldown-size">Latest News</span></h4></div><div id=tdi_8 class="td_block_inner td-column-1"><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/kia-stinger/" rel="nofollow bookmark" class="td-image-wrap" title="Kia Stinger lacks recognition" ><img width="100" height="70" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/07/2022-Kia-Stinger-100x70.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/07/2022-Kia-Stinger-100x70.jpg 100w, https://www.rosevilletoday.com/wp-content/uploads/2022/07/2022-Kia-Stinger-218x150.jpg 218w, https://www.rosevilletoday.com/wp-content/uploads/2022/07/2022-Kia-Stinger-534x377.jpg 534w" sizes="(max-width: 100px) 100vw, 100px" alt="Kia Stinger" title="Kia Stinger lacks recognition" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/kia-stinger/" rel="bookmark" title="Kia Stinger lacks recognition">Kia Stinger lacks recognition</a></h3><div class="td-module-meta-info"></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/roseville-summer-youth-bus-pass/" rel="nofollow bookmark" class="td-image-wrap" title="Roseville Summer Youth Bus Pass: Just $10" ><img width="100" height="70" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2015/06/roseville-transit-100x70.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2015/06/roseville-transit-100x70.jpg 100w, https://www.rosevilletoday.com/wp-content/uploads/2015/06/roseville-transit-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Roseville Transit" title="Roseville Summer Youth Bus Pass: Just $10" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/roseville-summer-youth-bus-pass/" rel="bookmark" title="Roseville Summer Youth Bus Pass: Just $10">Roseville Summer Youth Bus Pass: Just $10</a></h3><div class="td-module-meta-info"></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/music/music-articles/creating-4th-july-playlist/" rel="nofollow bookmark" class="td-image-wrap" title="Creating your own 4th of July Playlist to chill out" ><img width="100" height="70" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/07/4th-playlist-100x70.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/07/4th-playlist-100x70.jpg 100w, https://www.rosevilletoday.com/wp-content/uploads/2022/07/4th-playlist-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="4th musical playlist" title="Creating your own 4th of July Playlist to chill out" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/music/music-articles/creating-4th-july-playlist/" rel="bookmark" title="Creating your own 4th of July Playlist to chill out">Creating your own 4th of July Playlist to chill out</a></h3><div class="td-module-meta-info"></div></div></div></div></div></div></div><div class="td-pb-span4"><div class="td_block_wrap td_block_weather td_block_widget tdi_9 td-pb-border-top td_block_template_11" data-td-block-uid="tdi_9" ><style media="all">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</style><div class="td-block-title-wrap"></div><div id=tdi_9 class="td-weather-wrap td_block_inner td-column-1"><div class="td-weather-header"><div class="td-weather-city">Roseville</div><div class="td-weather-condition">scattered clouds</div> <i class="td-location-icon td-icons-location" data-block-uid="tdi_9"></i></div><div class="td-weather-set-location"><form class="td-manual-location-form" action="#" data-block-uid="tdi_9"> <input id="tdi_9" class="td-location-set-input" type="text" name="location" value=""> <label>enter location</label></form></div><div class="td-weather-temperature"><div class="td-weather-temp-wrap"><div class="td-weather-animated-icon"> <span class="td_animation_sprite-27-100-80-0-0-1 scattered-clouds-d td-w-today-icon" data-td-block-uid="tdi_9"></span></div><div class="td-weather-now" data-block-uid="tdi_9"> <span class="td-big-degrees">69.5</span> <span class="td-circle">&deg;</span> <span class="td-weather-unit">F</span></div><div class="td-weather-lo-hi"><div class="td-weather-degrees-wrap"> <i class="td-up-icon td-icons-arrows-up"></i> <span class="td-small-degrees td-w-high-temp">72.7</span> <span class="td-circle">&deg;</span></div><div class="td-weather-degrees-wrap"> <i class="td-down-icon td-icons-arrows-down"></i> <span class="td-small-degrees td-w-low-temp">66.7</span> <span class="td-circle">&deg;</span></div></div></div></div><div class="td-weather-info-wrap"><div class="td-weather-information"><div class="td-weather-section-1"> <i class="td-icons-drop"></i> <span class="td-weather-parameter td-w-today-humidity">73 %</span></div><div class="td-weather-section-2"> <i class="td-icons-wind"></i> <span class="td-weather-parameter td-w-today-wind-speed">1.9mph</span></div><div class="td-weather-section-3"> <i class="td-icons-cloud"></i> <span class="td-weather-parameter td-w-today-clouds">40 %</span></div></div><div class="td-weather-week"><div class="td-weather-days"><div class="td-day-0">Tue</div><div class="td-day-degrees"> <span class="td-degrees-0">86</span> <span class="td-circle">&deg;</span></div></div><div class="td-weather-days"><div class="td-day-1">Wed</div><div class="td-day-degrees"> <span class="td-degrees-1">86</span> <span class="td-circle">&deg;</span></div></div><div class="td-weather-days"><div class="td-day-2">Thu</div><div class="td-day-degrees"> <span class="td-degrees-2">88</span> <span class="td-circle">&deg;</span></div></div><div class="td-weather-days"><div class="td-day-3">Fri</div><div class="td-day-degrees"> <span class="td-degrees-3">91</span> <span class="td-circle">&deg;</span></div></div><div class="td-weather-days"><div class="td-day-4">Sat</div><div class="td-day-degrees"> <span class="td-degrees-4">94</span> <span class="td-circle">&deg;</span></div></div></div></div></div></div></div><div class="td-pb-span4"><div class="td_block_wrap td_block_7 td_block_widget tdi_10 td-pb-border-top td_block_template_11 td-column-1 td_block_padding" data-td-block-uid="tdi_10" > <script>var block_tdi_10 = new tdBlock();
block_tdi_10.id = "tdi_10";
block_tdi_10.atts = '{"custom_title":"Local Real Estate","custom_url":"","block_template_id":"","header_text_color":"#","border_color":"#","accent_text_color":"#","m6_tl":"","limit":"3","offset":"","time_ago_add_txt":"ago","el_class":"","post_ids":"-77079","category_id":"30","category_ids":"53","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget tdi_10","block_type":"td_block_7","separator":"","show_modified_date":"","time_ago":"","time_ago_txt_pos":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","color_preset":"","border_top":"","tdc_css_class":"tdi_10","tdc_css_class_style":"tdi_10_rand_style"}';
block_tdi_10.td_column_number = "1";
block_tdi_10.block_type = "td_block_7";
block_tdi_10.post_count = "3";
block_tdi_10.found_posts = "196";
block_tdi_10.header_color = "";
block_tdi_10.ajax_pagination_infinite_stop = "";
block_tdi_10.max_num_pages = "66";
tdBlocksArray.push(block_tdi_10);</script> <div class="td-block-title-wrap"><h4 class="td-block-title"><span class="td-pulldown-size">Local Real Estate</span></h4></div><div id=tdi_10 class="td_block_inner"><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/home-sellers-be-aware/" rel="nofollow bookmark" class="td-image-wrap" title="Home sellers be aware" ><img width="100" height="70" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/06/home-sellers-100x70.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/06/home-sellers-100x70.jpg 100w, https://www.rosevilletoday.com/wp-content/uploads/2022/06/home-sellers-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Home Sellers" title="Home sellers be aware" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/home-sellers-be-aware/" rel="bookmark" title="Home sellers be aware">Home sellers be aware</a></h3><div class="td-module-meta-info"></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/roseville-housing-market-update/" rel="nofollow bookmark" class="td-image-wrap" title="Roseville Housing Market Update May 4, 2022" ><img width="100" height="70" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/05/real-estate-market-100x70.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/05/real-estate-market-100x70.jpg 100w, https://www.rosevilletoday.com/wp-content/uploads/2022/05/real-estate-market-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Real Estate Market" title="Roseville Housing Market Update May 4, 2022" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/roseville-housing-market-update/" rel="bookmark" title="Roseville Housing Market Update May 4, 2022">Roseville Housing Market Update May 4, 2022</a></h3><div class="td-module-meta-info"></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/rocklin-roseville-real-estate-updates/" rel="nofollow bookmark" class="td-image-wrap" title="Rocklin and Roseville Real Estate Market shows continued strength" ><img width="100" height="70" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/03/placer-housing-market-100x70.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/03/placer-housing-market-100x70.jpg 100w, https://www.rosevilletoday.com/wp-content/uploads/2022/03/placer-housing-market-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Placer Housing Market Updates" title="Rocklin and Roseville Real Estate Market shows continued strength" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/rocklin-roseville-real-estate-updates/" rel="bookmark" title="Rocklin and Roseville Real Estate Market shows continued strength">Rocklin and Roseville Real Estate Market shows continued strength</a></h3><div class="td-module-meta-info"></div></div></div></div></div></div></div></div></div><div class="td-footer-bottom-full"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="https://www.rosevilletoday.com/"><img src="https://www.rosevilletoday.com/wp-content/uploads/2020/12/roseville-today-logo.png" alt="Roseville Today logo" title="" width="272" height="90"/></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div>Business, Travel, & Entertainment. A locally owned, community supported online business since 2003. We're located in Roseville, California and proudly serve communities throughout Placer County and the entire Golden State. <br><br> <b>We have NO affiliation with print, politics, or corporate media.</b></aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/RosevilleToday" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.instagram.com/rosevilletoday/" title="Instagram"> <i class="td-icon-font td-icon-instagram"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.rosevilletoday.com/news/feed/" title="RSS"> <i class="td-icon-font td-icon-rss"></i> </a> </span></aside></div></div></div></div></div><div class="td-sub-footer-container td-container-wrap"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span td-sub-footer-menu"><div class="menu-td-demo-footer-menu-container"><ul id="menu-td-demo-footer-menu" class="td-subfooter-menu"><li id="menu-item-49285" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-49285"><a href="https://www.rosevilletoday.com/">Roseville Today</a></li><li id="menu-item-49286" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-49286"><a href="https://www.rosevilletoday.com/yp/">YP</a></li><li id="menu-item-161" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-161"><a href="/about/">About Us</a></li><li id="menu-item-160" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-160"><a href="/privacy-policy/">Privacy Policy</a></li><li id="menu-item-159" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-159"><a href="/contact/">Contact Us</a></li><li id="menu-item-162" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-162"><a href="/advertise/">Advertise</a></li></ul></div></div><div class="td-pb-span td-sub-footer-copy"> &copy; Roseville Today | 4010 Foothills Blvd. 103- #28 | Roseville, CA 95747</div></div></div></div></div></div> <script>( function ( body ) {
'use strict';
body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
} )( document.body );</script> <style type="text/css" media="all">.td-post-featured-image{float:left;display:block;width:auto;margin:14px}.td-category-pulldown-filter td-wrapper-pulldown-filter{display:none}.td-pulldown-filter-display-option{display:none}.td-subcat-more{display:none}.td-icon-menu-down{display:none}.td-pulldown-filter-list{display:none}.td-pulldown-filter-item{display:none}</style> <script>var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};</script> <script>(function () {
var c = document.body.className;
c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
document.body.className = c;
})();</script> <script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js?ver=2.7.0-wc.6.6.1' id='jquery-blockui-js'></script> <script id='wc-add-to-cart-js-extra'>var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/www.rosevilletoday.com\/cart\/","is_cart":"","cart_redirect_after_add":"yes"};</script> <script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart.min.js?ver=6.6.1' id='wc-add-to-cart-js'></script> <script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/woocommerce/assets/js/js-cookie/js.cookie.min.js?ver=2.1.4-wc.6.6.1' id='js-cookie-js'></script> <script id='woocommerce-js-extra'>var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};</script> <script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js?ver=6.6.1' id='woocommerce-js'></script> <script id='wc-cart-fragments-js-extra'>var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_99652f39b82f1d3ffdbee0deb146621a","fragment_name":"wc_fragments_99652f39b82f1d3ffdbee0deb146621a","request_timeout":"5000"};</script> <script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js?ver=6.6.1' id='wc-cart-fragments-js'></script> <script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/the-events-calendar/common/src/resources/js/underscore-before.js'></script> <script async='async' src='https://www.rosevilletoday.com/wp-includes/js/underscore.min.js?ver=1.13.3' id='underscore-js'></script> <script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/the-events-calendar/common/src/resources/js/underscore-after.js'></script> <script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=4173294bcf58591c4439ff8ccd792f1ex' id='tdb_js_posts_autoload-js'></script> <script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=11.5.1' id='td-site-min-js'></script> <script async='async' src='https://www.rosevilletoday.com/wp-includes/js/comment-reply.min.js?ver=6.0' id='comment-reply-js'></script> <script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=4173294bcf58591c4439ff8ccd792f1ex' id='tdb_js_files_for_front-js'></script> <script>!function(){window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[],advanced_ads_ready_queue.push=window.advanced_ads_ready;for(var d=0,a=advanced_ads_ready_queue.length;d<a;d++)advanced_ads_ready(advanced_ads_ready_queue[d])}();</script> <script>jQuery().ready(function () {
tdWeather.addItem({"block_uid":"tdi_9","location":"5388881","api_location":"Roseville","api_language":"en","api_key":"ae6740d1cdd712b8489a62751fd67013","today_icon":"scattered-clouds-d","today_icon_text":"scattered clouds","today_temp":[20.899999999999999,69.5],"today_humidity":73,"today_wind_speed":[3.1000000000000001,1.8999999999999999],"today_min":[19.300000000000001,66.700000000000003],"today_max":[22.600000000000001,72.700000000000003],"today_clouds":40,"current_unit":1,"forecast":[{"timestamp":1657044000,"day_name":"Tue","day_temp":[30,86],"owm_day_index":0},{"timestamp":1657065600,"day_name":"Wed","day_temp":[30,86],"owm_day_index":2},{"timestamp":1657152000,"day_name":"Thu","day_temp":[31,88],"owm_day_index":10},{"timestamp":1657238400,"day_name":"Fri","day_temp":[33,91],"owm_day_index":18},{"timestamp":1657324800,"day_name":"Sat","day_temp":[35,94],"owm_day_index":26},{"timestamp":1657411200,"day_name":"Sun","day_temp":[36,98],"owm_day_index":34}]});
});</script> <style media="all">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</style> <script type='text/javascript' id='fvm-delayjs' data-cfasync='false'>!function(k,e,x){function r(d,a,g,b){return b=(a?e.getElementById(a):t)||e.createElement(d||"SCRIPT"),a&&(b.id=a),g&&(b.onload=g),b}function u(d){f(function(a){a=[].slice.call(e.querySelectorAll(d));(function v(b,c){if(b=a.shift()){b.parentNode.removeChild(b);var l=b,m,n=void 0;var p=r(l.nodeName);var q=0;for(m=l.attributes;q<m.length;q++)"type"!=(n=m[q]).name&&p.setAttribute(n.name,n.value);(c=(p.text=l.text,p)).src&&!c.hasAttribute("async")?(c.onload=c.onerror=v,e.head.appendChild(c)):(e.head.appendChild(c),
v())}})()})}var f,t,h=[],w=/p/.test(e.readyState);Function();(f=function(d,a){w?x(d,a):h.push(d,a)}).all=u;f.js=function(d,a,g,b){f(function(c){(c=r(t,a,b)).src=d;e.head.appendChild(c)},g)};k.addEventListener("onpageshow"in k?"pageshow":"load",function(){for(w=!u();h[0];)f(h.shift(),h.shift())});k.Defer=f}(this,document,setTimeout);
const userInteractionEvents=["mouseover","keydown","touchstart","touchmove","wheel"];userInteractionEvents.forEach(function(event){window.addEventListener(event,triggerScriptLoader,{passive:!0})});function triggerScriptLoader(){fvmloadscripts();userInteractionEvents.forEach(function(event){window.removeEventListener(event,triggerScriptLoader,{passive:!0})})}function fvmloadscripts(){Defer.all('script[type="fvm-script-delay"]')};</script> <script>(function(){var js = "window['__CF$cv$params']={r:'726191aa78d882b6',m:'2BV.KavMYP7vkrPWXCCetj0zskFuIoy1tINE2WrFwxc-1657039505-0-AU9KZLiWFRQMGzVzq3tF6QpuFk1LQJsgrE0GGqwNVY4FMKbXXBgqAeeb2f0JXum6NehL0QGBVePB1ZQAUSiBhy4R8YsS3wIAGZEjOPOGbz5xQps8O1xAwolL05KSypCCaSiVRVsTRuYpWP+AG8MpQEUk7WoZ+3pBFs6oSBZfxm9Sp/xIOpG5YRZ3ng0mOGYfjg==',s:[0x7f7b026e36,0x824d05a5e6],u:'/cdn-cgi/challenge-platform/h/b'};var now=Date.now()/1000,offset=14400,ts=''+(Math.floor(now)-Math.floor(now%offset)),_cpo=document.createElement('script');_cpo.nonce='',_cpo.src='/cdn-cgi/challenge-platform/h/b/scripts/alpha/invisible.js?ts='+ts,document.getElementsByTagName('head')[0].appendChild(_cpo);";var _0xh = document.createElement('iframe');_0xh.height = 1;_0xh.width = 1;_0xh.style.border = 'none';_0xh.style.visibility = 'hidden';document.body.appendChild(_0xh);function handler() {var _0xi = _0xh.contentDocument || _0xh.contentWindow.document;if (_0xi) {var _0xj = _0xi.createElement('script');_0xj.innerHTML = js;_0xi.getElementsByTagName('head')[0].appendChild(_0xj);}}if (document.readyState !== 'loading') {handler();} else if (window.addEventListener) {document.addEventListener('DOMContentLoaded', handler);} else {var prev = document.onreadystatechange || function () {};document.onreadystatechange = function (e) {prev(e);if (document.readyState !== 'loading') {document.onreadystatechange = prev;handler();}};}})();</script><script defer src="https://static.cloudflareinsights.com/beacon.min.js/v652eace1692a40cfa3763df669d7439c1639079717194" integrity="sha512-Gi7xpJR8tSkrpF7aordPZQlW2DLtzUlZcumS8dMQjwDHEnw9I7ZLyiOj/6tZStRBGtGgN6ceN6cMH8z7etPGlw==" data-cf-beacon='{"rayId":"726191aa78d882b6","token":"9639abc27d734ec8b96408e75d059522","version":"2022.6.0","si":100}' crossorigin="anonymous"></script>
</body></html>