<!doctype html ><html lang="en-US"><head><meta charset="UTF-8" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1661263070-css8f7178ecce1adda0ac859e86f6bd8b026c76285fb51068b543c66fb8f69e6.css" as="style" media="all" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1661263070-css3c532d4d86b7e61949c829f3fd8149543fd29df3a26ac19fccb14ef82508d.css" as="style" media="all" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1661263070-css8d24d86727897d5ed69d4989790ab5b0802985bbca6bb829dbd813147be03.css" as="style" media="all" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1661263070-css341e46dbf54fbd41bba93043f22137c9a06942a3691b2c221f6a6ed1f0320.css" as="style" media="all" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1661263070-csse213050fcd0004f74b5c66f7cd18cb2d7d77933321fdc5afd07d062e4ed25.css" as="style" media="all" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1661263070-css4be15d0b78a279bff0162123244880ebde1fa81d1923dc637675b4e04ee8b.css" as="style" media="only screen and (max-width: 768px)" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1661263070-css335adfefdc7661eb9a9d240ff37c4bdefbc8803624ef25126222cbf890db8.css" as="style" media="all" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1661263070-css9d43086becc17bed9a9b5cde9547da376cfdf7024bf75ed8655b3c5017736.css" as="style" media="all" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1661263070-css0d8813713ec4587e3dc3afa94d040ac398a8b7a9da9268c83fb3affff4100.css" as="style" media="all" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1661263070-css1583aa4a7e3eb664f9d170575013b9ee7311d53b1bf94fd8369fd412178d8.css" as="style" media="all" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1661263070-css8f3089371b7d2a5c5d7612fd625bef656d7ffa242480e11c019acc3d87022.css" as="style" media="all" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1661263070-cssd2a029c684347775a5a4c56c5c8a5fa9575eed477e502c965aadcb8d05367.css" as="style" media="all" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1661263070-csse4f78c2c80a74fdb29b34f312c9a2d5e0a60a2c8fd25857e9528db504613b.css" as="style" media="all" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1661263070-css9203d892be6c135f6eaf84cc3835f03eb45be290299ae5701720ca874df0a.css" as="style" media="all" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1661263070-css7f204d4f1cce0b0d04ffb231e781a20a5e3143bc176caf0cec3f855898893.css" as="style" media="all" /><link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1661263070-css404d6086b9c978048ff90f09f43eb5a7c70cbdf6bbe318fb55ebf8ba35540.css" as="style" media="all" /> <script data-cfasync="false">function fvmuag(){var e=navigator.userAgent;if(e.match(/x11.*ox\/54|id\s4.*us.*ome\/62|oobo|ight|tmet|eadl|ngdo|PTST/i))return!1;if(e.match(/x11.*me\/86\.0/i)){var r=screen.width;if("number"==typeof r&&1367==r)return!1}return!0}</script> <title>🌹Roseville State of the City Address this Friday at West Park High School - Roseville Today</title><meta name="viewport" content="width=device-width, initial-scale=1.0"><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /><meta name="description" content="Roseville, Calif.- This Friday, August 26th at 10:00 am, the Roseville 2022 State of the City speech will take place at the beautifully, modern West Park High School." /><link rel="canonical" href="https://www.rosevilletoday.com/news/roseville/state-of-city-address/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="🌹Roseville State of the City Address this Friday at West Park High School" /><meta property="og:description" content="Roseville, Calif.- This Friday, August 26th at 10:00 am, the Roseville 2022 State of the City speech will take place at the beautifully, modern West Park High School." /><meta property="og:url" content="https://www.rosevilletoday.com/news/roseville/state-of-city-address/" /><meta property="og:site_name" content="Roseville Today" /><meta property="article:publisher" content="https://www.facebook.com/RosevilleToday" /><meta property="article:published_time" content="2022-08-23T18:40:20+00:00" /><meta property="article:modified_time" content="2022-08-23T18:45:30+00:00" /><meta property="og:image" content="https://www.rosevilletoday.com/wp-content/uploads/2022/08/state-of-city.jpg" /><meta property="og:image:width" content="675" /><meta property="og:image:height" content="430" /><meta property="og:image:type" content="image/jpeg" /><meta name="author" content="Staff" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@rrtoday" /><meta name="twitter:site" content="@rrtoday" /><meta name="twitter:label1" content="Written by" /><meta name="twitter:data1" content="Staff" /><meta name="twitter:label2" content="Est. reading time" /><meta name="twitter:data2" content="2 minutes" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Article","@id":"https://www.rosevilletoday.com/news/roseville/state-of-city-address/#article","isPartOf":{"@id":"https://www.rosevilletoday.com/news/roseville/state-of-city-address/"},"author":{"name":"Staff","@id":"https://www.rosevilletoday.com/#/schema/person/bf27b0f4159cee1e3a0c12604ba793af"},"headline":"🌹Roseville State of the City Address this Friday at West Park High School","datePublished":"2022-08-23T18:40:20+00:00","dateModified":"2022-08-23T18:45:30+00:00","mainEntityOfPage":{"@id":"https://www.rosevilletoday.com/news/roseville/state-of-city-address/"},"wordCount":257,"publisher":{"@id":"https://www.rosevilletoday.com/#organization"},"image":{"@id":"https://www.rosevilletoday.com/news/roseville/state-of-city-address/#primaryimage"},"thumbnailUrl":"https://www.rosevilletoday.com/wp-content/uploads/2022/08/state-of-city.jpg","articleSection":["Roseville News"],"inLanguage":"en-US"},{"@type":"WebPage","@id":"https://www.rosevilletoday.com/news/roseville/state-of-city-address/","url":"https://www.rosevilletoday.com/news/roseville/state-of-city-address/","name":"🌹Roseville State of the City Address this Friday at West Park High School - Roseville Today","isPartOf":{"@id":"https://www.rosevilletoday.com/#website"},"primaryImageOfPage":{"@id":"https://www.rosevilletoday.com/news/roseville/state-of-city-address/#primaryimage"},"image":{"@id":"https://www.rosevilletoday.com/news/roseville/state-of-city-address/#primaryimage"},"thumbnailUrl":"https://www.rosevilletoday.com/wp-content/uploads/2022/08/state-of-city.jpg","datePublished":"2022-08-23T18:40:20+00:00","dateModified":"2022-08-23T18:45:30+00:00","description":"Roseville, Calif.- This Friday, August 26th at 10:00 am, the Roseville 2022 State of the City speech will take place at the beautifully, modern West Park High School.","breadcrumb":{"@id":"https://www.rosevilletoday.com/news/roseville/state-of-city-address/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.rosevilletoday.com/news/roseville/state-of-city-address/"]}]},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.rosevilletoday.com/news/roseville/state-of-city-address/#primaryimage","url":"https://www.rosevilletoday.com/wp-content/uploads/2022/08/state-of-city.jpg","contentUrl":"https://www.rosevilletoday.com/wp-content/uploads/2022/08/state-of-city.jpg","width":675,"height":430,"caption":"Roseville City Hall"},{"@type":"BreadcrumbList","@id":"https://www.rosevilletoday.com/news/roseville/state-of-city-address/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.rosevilletoday.com/"},{"@type":"ListItem","position":2,"name":"News","item":"https://www.rosevilletoday.com/news/"},{"@type":"ListItem","position":3,"name":"Roseville News","item":"https://www.rosevilletoday.com/news/roseville/"},{"@type":"ListItem","position":4,"name":"🌹Roseville State of the City Address this Friday at West Park High School"}]},{"@type":"WebSite","@id":"https://www.rosevilletoday.com/#website","url":"https://www.rosevilletoday.com/","name":"Roseville Today","description":"Business, Travel and Entertainment","publisher":{"@id":"https://www.rosevilletoday.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.rosevilletoday.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"Organization","@id":"https://www.rosevilletoday.com/#organization","name":"Roseville Today","url":"https://www.rosevilletoday.com/","sameAs":["https://www.instagram.com/rosevilletoday/","https://www.facebook.com/RosevilleToday","https://twitter.com/rrtoday"],"logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.rosevilletoday.com/#/schema/logo/image/","url":"https://www.rosevilletoday.com/wp-content/uploads/2021/04/rt-logo.png","contentUrl":"https://www.rosevilletoday.com/wp-content/uploads/2021/04/rt-logo.png","width":544,"height":180,"caption":"Roseville Today"},"image":{"@id":"https://www.rosevilletoday.com/#/schema/logo/image/"}},{"@type":"Person","@id":"https://www.rosevilletoday.com/#/schema/person/bf27b0f4159cee1e3a0c12604ba793af","name":"Staff","description":"Staff posts at Rocklin &amp; Roseville Today include original content and a variety of sources respected and authoritative 3rd party sources. Please use the contact link at the bottom of this page for inquiries and corrections. Roseville, CA News and Local Updates","url":"https://www.rosevilletoday.com/author/staff/"}]}</script> <link rel="alternate" type="application/rss+xml" title="Roseville Today &raquo; Feed" href="https://www.rosevilletoday.com/feed/" /><link rel="alternate" type="text/calendar" title="Roseville Today &raquo; iCal Feed" href="https://www.rosevilletoday.com/events/?ical=1" /><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://www.rosevilletoday.com"> <script type="application/ld+json">{
"@context": "http://schema.org",
"@type": "BreadcrumbList",
"itemListElement": [
{
"@type": "ListItem",
"position": 1,
"item": {
"@type": "WebSite",
"@id": "https://www.rosevilletoday.com/",
"name": "Home"
}
},
{
"@type": "ListItem",
"position": 2,
"item": {
"@type": "WebPage",
"@id": "https://www.rosevilletoday.com/news/",
"name": "News"
}
}
,{
"@type": "ListItem",
"position": 3,
"item": {
"@type": "WebPage",
"@id": "https://www.rosevilletoday.com/news/roseville/",
"name": "Roseville News"                                
}
}
,{
"@type": "ListItem",
"position": 4,
"item": {
"@type": "WebPage",
"@id": "https://www.rosevilletoday.com/news/roseville/state-of-city-address/",
"name": "🌹Roseville State of the City Address this Friday at West Park High..."                                
}
}    
]
}</script> <link rel="icon" type="image/png" href="https://www.rosevilletoday.com/wp-content/uploads/2021/12/favicon.jpg"> <script id="rosev-ready">window.advanced_ads_ready=function(e,a){a=a||"complete";var d=function(e){return"interactive"===a?"loading"!==e:"complete"===e};d(document.readyState)?e():document.addEventListener("readystatechange",(function(a){d(a.target.readyState)&&e()}),{once:"interactive"===a})},window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[];</script> <link rel='stylesheet' id='formidable-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1661263070-css8f7178ecce1adda0ac859e86f6bd8b026c76285fb51068b543c66fb8f69e6.css' type='text/css' media='all' /><link rel='stylesheet' id='wp-block-library-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1661263070-css3c532d4d86b7e61949c829f3fd8149543fd29df3a26ac19fccb14ef82508d.css' type='text/css' media='all' /><link rel='stylesheet' id='wc-blocks-vendors-style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1661263070-css8d24d86727897d5ed69d4989790ab5b0802985bbca6bb829dbd813147be03.css' type='text/css' media='all' /><link rel='stylesheet' id='wc-blocks-style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1661263070-css341e46dbf54fbd41bba93043f22137c9a06942a3691b2c221f6a6ed1f0320.css' type='text/css' media='all' /><style id='global-styles-inline-css' type='text/css' media="all">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</style><link rel='stylesheet' id='woocommerce-layout-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1661263070-csse213050fcd0004f74b5c66f7cd18cb2d7d77933321fdc5afd07d062e4ed25.css' type='text/css' media='all' /><link rel='stylesheet' id='woocommerce-smallscreen-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1661263070-css4be15d0b78a279bff0162123244880ebde1fa81d1923dc637675b4e04ee8b.css' type='text/css' media='only screen and (max-width: 768px)' /><link rel='stylesheet' id='woocommerce-general-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1661263070-css335adfefdc7661eb9a9d240ff37c4bdefbc8803624ef25126222cbf890db8.css' type='text/css' media='all' /><style id='woocommerce-inline-inline-css' type='text/css' media="all">.woocommerce form .form-row .required{visibility:visible}</style><link rel='stylesheet' id='wp_automatic_gallery_style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1661263070-css9d43086becc17bed9a9b5cde9547da376cfdf7024bf75ed8655b3c5017736.css' type='text/css' media='all' /><link rel='stylesheet' id='td-plugin-multi-purpose-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1661263070-css0d8813713ec4587e3dc3afa94d040ac398a8b7a9da9268c83fb3affff4100.css' type='text/css' media='all' /><link crossorigin="anonymous" rel='stylesheet' id='google-fonts-style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1661263070-css1583aa4a7e3eb664f9d170575013b9ee7311d53b1bf94fd8369fd412178d8.css' type='text/css' media='all' /><link rel='stylesheet' id='td-theme-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1661263070-css8f3089371b7d2a5c5d7612fd625bef656d7ffa242480e11c019acc3d87022.css' type='text/css' media='all' /><style id='td-theme-inline-css' type='text/css' media="all">@media (max-width:767px){.td-header-desktop-wrap{display:none}}@media (min-width:767px){.td-header-mobile-wrap{display:none}}</style><link rel='stylesheet' id='td-theme-woo-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1661263070-cssd2a029c684347775a5a4c56c5c8a5fa9575eed477e502c965aadcb8d05367.css' type='text/css' media='all' /><link rel='stylesheet' id='td-legacy-framework-front-style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1661263070-csse4f78c2c80a74fdb29b34f312c9a2d5e0a60a2c8fd25857e9528db504613b.css' type='text/css' media='all' /><link rel='stylesheet' id='td-legacy-framework-woo-style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1661263070-css9203d892be6c135f6eaf84cc3835f03eb45be290299ae5701720ca874df0a.css' type='text/css' media='all' /><link rel='stylesheet' id='td-standard-pack-framework-front-style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1661263070-css7f204d4f1cce0b0d04ffb231e781a20a5e3143bc176caf0cec3f855898893.css' type='text/css' media='all' /><link rel='stylesheet' id='td-theme-demo-style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1661263070-css404d6086b9c978048ff90f09f43eb5a7c70cbdf6bbe318fb55ebf8ba35540.css' type='text/css' media='all' /> <script async='async' src='https://www.rosevilletoday.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script> <script async='async' src='https://www.rosevilletoday.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script> <script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/wp-automatic/js/main-front.js?ver=6.0.1' id='wp_automatic_gallery-js'></script> <script>window.tdb_globals = {"wpRestNonce":"9ffb93937d","wpRestUrl":"https:\/\/www.rosevilletoday.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/","globalSettings":{"tdcSavingHistory":false},"isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};</script> <style id="tdb-global-colors" media="all">:root{--accent-color:#fff}</style> <script>window.tdwGlobal = {"adminUrl":"https:\/\/www.rosevilletoday.com\/wp-admin\/","wpRestNonce":"9ffb93937d","wpRestUrl":"https:\/\/www.rosevilletoday.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/"};</script> <script>window.tdaGlobal = {"adminUrl":"https:\/\/www.rosevilletoday.com\/wp-admin\/","wpRestNonce":"9ffb93937d","wpRestUrl":"https:\/\/www.rosevilletoday.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/","postId":78200};</script> <noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript><link rel="amphtml" href="https://www.rosevilletoday.com/news/roseville/state-of-city-address/?amp"> <script  src='https://www.googletagservices.com/tag/js/gpt.js' async></script> <script>var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];</script> <script>googletag.cmd.push(function() {
googletag.defineSlot('/1027827/300x250', [[300, 250], [336, 280]], 'div-gpt-ad-1526924072370-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});</script> <script>var tdBlocksArray = []; //here we store all the items for the current page
//td_block class - each ajax block uses a object of this class for requests
function tdBlock() {
this.id = '';
this.block_type = 1; //block type id (1-234 etc)
this.atts = '';
this.td_column_number = '';
this.td_current_page = 1; //
this.post_count = 0; //from wp
this.found_posts = 0; //from wp
this.max_num_pages = 0; //from wp
this.td_filter_value = ''; //current live filter value
this.is_ajax_running = false;
this.td_user_action = ''; // load more or infinite loader (used by the animation)
this.header_color = '';
this.ajax_pagination_infinite_stop = ''; //show load more at page x
}
// td_js_generator - mini detector
(function(){
var htmlTag = document.getElementsByTagName("html")[0];
if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
htmlTag.className += ' ie10';
}
if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
htmlTag.className += ' ie11';
}
if ( navigator.userAgent.indexOf("Edge") > -1 ) {
htmlTag.className += ' ieEdge';
}
if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
htmlTag.className += ' td-md-is-ios';
}
var user_agent = navigator.userAgent.toLowerCase();
if ( user_agent.indexOf("android") > -1 ) {
htmlTag.className += ' td-md-is-android';
}
if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
htmlTag.className += ' td-md-is-os-x';
}
if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
htmlTag.className += ' td-md-is-chrome';
}
if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
htmlTag.className += ' td-md-is-firefox';
}
if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
htmlTag.className += ' td-md-is-safari';
}
if( -1 !== navigator.userAgent.indexOf('IEMobile') ){
htmlTag.className += ' td-md-is-iemobile';
}
})();
var tdLocalCache = {};
( function () {
"use strict";
tdLocalCache = {
data: {},
remove: function (resource_id) {
delete tdLocalCache.data[resource_id];
},
exist: function (resource_id) {
return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
},
get: function (resource_id) {
return tdLocalCache.data[resource_id];
},
set: function (resource_id, cachedData) {
tdLocalCache.remove(resource_id);
tdLocalCache.data[resource_id] = cachedData;
}
};
})();
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var tdc_is_installed="yes";
var td_ajax_url="https:\/\/www.rosevilletoday.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=11.5.1";
var td_get_template_directory_uri="https:\/\/www.rosevilletoday.com\/wp-content\/plugins\/td-composer\/legacy\/common";
var tds_snap_menu="smart_snap_always";
var tds_logo_on_sticky="show";
var tds_header_style="3";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var td_user_incorrect="Username incorrect!";
var td_email_user_empty="Email or username empty!";
var td_pass_empty="Pass empty!";
var td_pass_pattern_incorrect="Invalid Pass Pattern!";
var td_retype_pass_incorrect="Retyped Pass incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#285a91";
var tds_smart_sidebar="";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var tdBlockNonce="14e86b70e6";
var tdDateNamesI18n={"month_names":["January","February","March","April","May","June","July","August","September","October","November","December"],"month_names_short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"day_names":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"day_names_short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]};
var td_ad_background_click_link="";
var td_ad_background_click_target="";</script> <script data-ad-client="ca-pub-5649489283520750" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script async src="https://www.googletagmanager.com/gtag/js?id=G-1069ECQ8NK"></script> <script>window.dataLayer = window.dataLayer || [];
function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'G-1069ECQ8NK');</script> <style type="text/css" id="wp-custom-css" media="all">div.tribe-events-single-event-recurrence-description{visibility:hidden;display:none}.td-author-counters{display:none}td{vertical-align:top!important}#yplink li a{color:#0f4c81}.tribe-events-widget-events-list{font-size:12px;border-radius:12px;background-color:#fafaf7;background-color:#bce5ff;background-color:#ffe789;background-color:#c9dcef}.td-visible-desktop{background-color:#fff}.td-visible-tablet-landscape{background-color:#fff}.td-visible-tablet-portrait{background-color:#fff}.td-visible-phone{background-color:#b5d2f6;border-radius:6px}.sponsor-ad{padding:12px}h2.tribe-events-widget-events-list__header-title{font-weight:700;font-size:1.8em;color:#004e7e;position:relative;left:75px;left:100px}h3.tribe-events-widget-events-list__event-title{font-size:1.5em}a.yps{color:#1b2880;font-size:15px;color:#333}a.tribe-events-widget-events-list__view-more-link{padding-left:60px;font-weight:700;font-size:1.1em;position:relative;left:75px;position:relative;left:50px}.tribe-events-widget-events-list__event-datetime-wrapper{display:none}.tribe-events-widget-events-list__event-date-tag{font-weight:700;color:#343f47}.rss-widget-icon{display:none}a.rsswidget{color:#ffa128;font-weight:700;font-size:.9em;font-family:sans-serif,Arial}.rsswidget:link{color:#012e81;color:#333}.rsswidget:visited{color:#00276e}.tribe-events-notices{background-color:#ffc780;color:#000;font-weight:700;font-size:1.4em}.imgpad{padding-right:15px}#showcase{width:345px;height:auto}.tribe-events-calendar-list__event-row--featured{background-color:#e7e7e5;border-radius:8px}h2{padding-right:50px}</style><style media="all">.tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,.tds-button2 .tdm-btn-text,.tds-button2 i,.tds-button5:hover .tdm-btn-text,.tds-button5:hover i,.tds-button6 .tdm-btn-text,.tds-button6 i,.tdm_block_list .tdm-list-item i,.tdm_block_pricing .tdm-pricing-feature i,body .tdm-social-item i{color:#285a91}.tds-button1,.tds-button6:after,.tds-title2 .tdm-title-line:after,.tds-title3 .tdm-title-line:after,.tdm_block_pricing.tdm-pricing-featured:before,.tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,.tds-progress-bar1 .tdm-progress-bar:after,.tds-progress-bar2 .tdm-progress-bar:after,.tds-social3 .tdm-social-item{background-color:#285a91}.tds-button2:before,.tds-button6:before,.tds-progress-bar3 .tdm-progress-bar:after{border-color:#285a91}.tdm-btn-style1{background-color:#285a91}.tdm-btn-style2:before{border-color:#285a91}.tdm-btn-style2{color:#285a91}.tdm-btn-style3{-webkit-box-shadow:0 2px 16px #285a91;-moz-box-shadow:0 2px 16px #285a91;box-shadow:0 2px 16px #285a91}.tdm-btn-style3:hover{-webkit-box-shadow:0 4px 26px #285a91;-moz-box-shadow:0 4px 26px #285a91;box-shadow:0 4px 26px #285a91}</style></head><body class="post-template-default single single-post postid-78200 single-format-standard theme-Newspaper td-standard-pack woocommerce-no-js tribe-no-js page-template-newspaper tribe-theme-Newspaper state-of-city-address global-block-template-11 td-local-news single_template_2 aa-prefix-rosev- td-boxed-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="td-scroll-up td-hide-scroll-up-on-mob" style="display:none;"><i class="td-icon-menu-up"></i></div><div class="td-menu-background" style="visibility:hidden"></div><div id="td-mobile-nav" style="visibility:hidden"><div class="td-mobile-container"><div class="td-menu-socials-wrap"><div class="td-menu-socials"> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/RosevilleToday" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.instagram.com/rosevilletoday/" title="Instagram"> <i class="td-icon-font td-icon-instagram"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.rosevilletoday.com/news/feed/" title="RSS"> <i class="td-icon-font td-icon-rss"></i> </a> </span></div><div class="td-mobile-close"> <a href="#" aria-label="Close"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-mobile-content"><div class="menu-td-demo-header-menu-container"><ul id="menu-td-demo-header-menu" class="td-mobile-main-menu"><li id="menu-item-168" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first menu-item-168"><a href="https://www.rosevilletoday.com/">Home</a></li><li id="menu-item-173" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-173"><a href="/news/">Local news<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-175" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-175"><a href="/news/roseville/">🌹 Roseville</a></li><li id="menu-item-174" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-174"><a href="/news/rocklin/">Rocklin</a></li><li id="menu-item-46156" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-46156"><a href="https://www.rosevilletoday.com/news/lincoln/">Lincoln</a></li><li id="menu-item-33550" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33550"><a href="https://www.rosevilletoday.com/news/auburn/">Auburn</a></li><li id="menu-item-50887" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50887"><a href="https://www.rosevilletoday.com/news/folsom/">Folsom</a></li><li id="menu-item-176" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-176"><a href="/news/sacramento/">Sacramento</a></li><li id="menu-item-48015" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48015"><a href="https://www.rosevilletoday.com/press-releases/">California News</a></li><li id="menu-item-57252" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57252"><a href="https://www.rosevilletoday.com/news/roseville/californias-10-largest-reservoirs-drought-status/">Reservoir Levels</a></li><li id="menu-item-69957" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-69957"><a href="https://www.rosevilletoday.com/news/roseville/california-snowpack-levels/">California Snowpack</a></li></ul></li><li id="menu-item-17466" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-17466"><a href="https://www.rosevilletoday.com/yp/">Yellow Pages<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-54119" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54119"><a href="https://www.rosevilletoday.com/yp/business/">Business</a></li><li id="menu-item-54120" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54120"><a href="https://www.rosevilletoday.com/yp/community/">Community</a></li><li id="menu-item-54121" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54121"><a href="https://www.rosevilletoday.com/yp/health-fitness/">Health &#038; Fitness</a></li><li id="menu-item-54122" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54122"><a href="https://www.rosevilletoday.com/yp/home-improvement/">Home Improvement</a></li><li id="menu-item-54123" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54123"><a href="https://www.rosevilletoday.com/yp/real-estate/">Real Estate</a></li><li id="menu-item-54124" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54124"><a href="https://www.rosevilletoday.com/yp/restaurants/">Restaurants</a></li></ul></li><li id="menu-item-233" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-233"><a href="/travel/">Travel<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-30808" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30808"><a href="https://www.rosevilletoday.com/author/todd-schofield/">🧳Travel Reviews</a></li><li id="menu-item-77900" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-77900"><a href="https://www.rosevilletoday.com/news/roseville/lowest-gas-prices-in-roseville/">Gas Prices</a></li><li id="menu-item-28186" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28186"><a href="https://www.rosevilletoday.com/travel/bay-area/">Bay Area</a></li><li id="menu-item-26018" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26018"><a href="https://www.rosevilletoday.com/travel/lake-tahoe/">Lake Tahoe &#8211; Reno</a></li><li id="menu-item-26019" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26019"><a href="https://www.rosevilletoday.com/travel/monterey-carmel/">Monterey and Carmel</a></li><li id="menu-item-26020" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26020"><a href="https://www.rosevilletoday.com/travel/napa-valley/">Napa Valley</a></li><li id="menu-item-26021" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26021"><a href="https://www.rosevilletoday.com/travel/sonoma/">Sonoma County</a></li><li id="menu-item-26022" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26022"><a href="https://www.rosevilletoday.com/travel/palm-springs/">Palm Springs Area</a></li><li id="menu-item-230" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-230"><a href="/travel/local-travel/">Placer / El Dorado / Sacramento</a></li></ul></li><li id="menu-item-234" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-234"><a href="/columns/">Columns<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-69530" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-69530"><a href="#">🌹 Why Roseville?<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-69894" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-69894"><a href="https://www.rosevilletoday.com/news/roseville/placer-county-ranks-1-in-quality-of-life-second-healthiest/">🌹 Quality of Life</a></li><li id="menu-item-69531" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-69531"><a href="https://www.rosevilletoday.com/news/roseville/roseville-only-california-city-among-moneys-best-places-to-live/">🌹 Places to Live</a></li><li id="menu-item-69534" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-69534"><a href="https://www.rosevilletoday.com/news/roseville/roseville-ranks-14th-nationally-for-younger-homebuyers/">🌹 Young Homebuyers</a></li><li id="menu-item-69533" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-69533"><a href="https://www.rosevilletoday.com/news/roseville/roseville-ranked-5th-in-nation-to-work-at-home/">🌹 Work from Home</a></li><li id="menu-item-75172" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-75172"><a href="https://www.rosevilletoday.com/news/roseville/venture-lab-roseville/">🌹 Entrepreneurs</a></li><li id="menu-item-69532" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-69532"><a href="https://www.rosevilletoday.com/news/roseville/roseville-9th-best-city-to-retire-in-united-states/">🌹 Retirement</a></li><li id="menu-item-69535" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-69535"><a href="https://www.rosevilletoday.com/travel/local-travel/top-5-reasons-we-love-roseville/">❤️ Our Favorites</a></li></ul></li><li id="menu-item-235" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-235"><a href="/columns/real-estate/">🏠 Real Estate</a></li><li id="menu-item-236" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-236"><a href="/columns/natural-wellness/">🍎 Natural Medicine</a></li><li id="menu-item-3876" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3876"><a href="/columns/car-reviews/">🚗 Weidel on Wheels</a></li><li id="menu-item-30989" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30989"><a href="https://www.rosevilletoday.com/author/todd-schofield/">✈️ Travel &#038; Music</a></li><li id="menu-item-47565" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47565"><a href="https://www.rosevilletoday.com/tag/roseville-city-school-district/">🏫 Roseville City School District</a></li><li id="menu-item-47564" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47564"><a href="https://www.rosevilletoday.com/tag/roseville-joint-union-high-school-district/">🏫 Roseville Joint Union HSD</a></li><li id="menu-item-48314" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48314"><a href="https://www.rosevilletoday.com/tag/roseville-safety-first/">👮 Roseville Safety Tips</a></li><li id="menu-item-48238" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48238"><a href="https://www.rosevilletoday.com/tag/hiking/">🚶🏾Hiking</a></li><li id="menu-item-48207" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48207"><a href="https://www.rosevilletoday.com/tag/rocklin-history-tour/">📜 Rocklin History Tour</a></li><li id="menu-item-29512" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29512"><a href="https://www.rosevilletoday.com/news/sacramento/laws/">⚖️ New Laws 2022</a></li><li id="menu-item-6022" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6022"><a href="/columns/disabilities">🐕‍🦺 Disabilities</a></li></ul></li><li id="menu-item-232" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-232"><a href="/music/">🎷 Music<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-78081" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-78081"><a href="https://www.rosevilletoday.com/tag/free-concerts/">🎟️ FREE Concerts</a></li><li id="menu-item-238" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-238"><a href="/music/concert-venues/">🎷 Concert Schedules</a></li><li id="menu-item-240" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-240"><a href="/music/music-reviews/">🎶 Music Reviews</a></li><li id="menu-item-68750" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-68750"><a href="https://www.rosevilletoday.com/news/roseville/pandora-spotify-youtube-music-compared/">📻 Streaming Compared</a></li></ul></li><li id="menu-item-13241" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-13241"><a href="/events/">Events<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-26702" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26702"><a href="/events/">🎟️ View All Events</a></li><li id="menu-item-26703" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26703"><a href="https://www.rosevilletoday.com/product/single-event-listing-highlight/">🎉+ ADD Your Event</a></li></ul></li></ul></div></div></div></div><div class="td-search-background" style="visibility:hidden"></div><div class="td-search-wrap-mob" style="visibility:hidden"><div class="td-drop-down-search"><form method="get" class="td-search-form" action="https://www.rosevilletoday.com/"><div class="td-search-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div><div role="search" class="td-search-input"> <span>Search</span> <input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" /></div></form><div id="td-aj-search-mob" class="td-ajax-search-flex"></div></div></div><div id="td-outer-wrap" class="td-theme-wrap"><div class="tdc-header-wrap"><div class="td-header-wrap td-header-style-3"><div class="td-header-top-menu-full td-container-wrap"><div class="td-container td-header-row td-header-top-menu"><div class="top-bar-style-2"><div class="td-header-sp-top-widget"> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/RosevilleToday" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.instagram.com/rosevilletoday/" title="Instagram"> <i class="td-icon-font td-icon-instagram"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.rosevilletoday.com/news/feed/" title="RSS"> <i class="td-icon-font td-icon-rss"></i> </a> </span></div><div class="td-header-sp-top-menu"><div class="td_data_time"><div > Tuesday, August 23, 2022</div></div></div></div><div id="login-form" class="white-popup-block mfp-hide mfp-with-anim td-login-modal-wrap"><div class="td-login-wrap"> <a href="#" aria-label="Back" class="td-back-button"><i class="td-icon-modal-back"></i></a><div id="td-login-div" class="td-login-form-div td-display-block"><div class="td-login-panel-title">Sign in</div><div class="td-login-panel-descr">Welcome! Log into your account</div><div class="td_display_err"></div><form id="loginForm" action="#" method="post"><div class="td-login-inputs"><input class="td-login-input" autocomplete="username" type="text" name="login_email" id="login_email" value="" required><label for="login_email">your username</label></div><div class="td-login-inputs"><input class="td-login-input" autocomplete="current-password" type="password" name="login_pass" id="login_pass" value="" required><label for="login_pass">your password</label></div> <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login"></form><div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div><div class="td-login-info-text"><a class="privacy-policy-link" href="https://www.rosevilletoday.com/privacy-policy/">Privacy Policy</a></div></div><div id="td-forgot-pass-div" class="td-login-form-div td-display-none"><div class="td-login-panel-title">Password recovery</div><div class="td-login-panel-descr">Recover your password</div><div class="td_display_err"></div><form id="forgotpassForm" action="#" method="post"><div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label for="forgot_email">your email</label></div> <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password"></form><div class="td-login-info-text">A password will be e-mailed to you.</div></div></div></div></div></div><div class="td-banner-wrap-full td-container-wrap"><div class="td-container td-header-row td-header-header"><div class="td-header-sp-logo"> <a class="td-main-logo" href="https://www.rosevilletoday.com/"> <img class="td-retina-data" data-retina="https://www.rosevilletoday.com/wp-content/uploads/2022/05/rt-544-300x99.jpg" src="https://www.rosevilletoday.com/wp-content/uploads/2022/05/rt-272.jpg" alt="Rocklin & Roseville Today" width="272" height="90"/> <span class="td-visual-hidden">Roseville Today</span> </a></div><div class="td-header-sp-recs"><div class="td-header-rec-wrap"><div class="td-a-rec td-a-rec-id-header td-rec-hide-on-p tdi_1 td_block_template_11"><style media="all">.tdi_1.td-a-rec{text-align:center}.tdi_1 .td-element-style{z-index:-1}.tdi_1.td-a-rec-img{text-align:left}.tdi_1.td-a-rec-img img{margin:0 auto 0 0}@media (max-width:767px){.tdi_1.td-a-rec-img{text-align:center}}</style><div class="td-all-devices"><a target="_blank" href="https://instagram.com/mochinut_roseville?igshid=YmMyMTA2M2Y="><img width="728" height="90" alt="Mochinut Roseville" src="https://www.rosevilletoday.com/mochinut/mochinut-728b.jpg"/></a></div></div></div></div></div></div><div class="td-header-menu-wrap-full td-container-wrap"><div class="td-header-menu-wrap"><div class="td-container td-header-row td-header-main-menu black-menu"><div id="td-header-menu" role="navigation"><div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div><div class="td-main-menu-logo td-logo-in-header"> <a class="td-main-logo" href="https://www.rosevilletoday.com/"> <img class="td-retina-data" data-retina="https://www.rosevilletoday.com/wp-content/uploads/2022/05/rt-544-300x99.jpg" src="https://www.rosevilletoday.com/wp-content/uploads/2022/05/rt-272.jpg" alt="Rocklin & Roseville Today" width="272" height="90"/> </a></div><div class="menu-td-demo-header-menu-container"><ul id="menu-td-demo-header-menu-1" class="sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-168"><a href="https://www.rosevilletoday.com/">Home</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-173"><a href="/news/">Local news</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-175"><a href="/news/roseville/">🌹 Roseville</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-174"><a href="/news/rocklin/">Rocklin</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-46156"><a href="https://www.rosevilletoday.com/news/lincoln/">Lincoln</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-33550"><a href="https://www.rosevilletoday.com/news/auburn/">Auburn</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-50887"><a href="https://www.rosevilletoday.com/news/folsom/">Folsom</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-176"><a href="/news/sacramento/">Sacramento</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-48015"><a href="https://www.rosevilletoday.com/press-releases/">California News</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-57252"><a href="https://www.rosevilletoday.com/news/roseville/californias-10-largest-reservoirs-drought-status/">Reservoir Levels</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-69957"><a href="https://www.rosevilletoday.com/news/roseville/california-snowpack-levels/">California Snowpack</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-17466"><a href="https://www.rosevilletoday.com/yp/">Yellow Pages</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-54119"><a href="https://www.rosevilletoday.com/yp/business/">Business</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-54120"><a href="https://www.rosevilletoday.com/yp/community/">Community</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-54121"><a href="https://www.rosevilletoday.com/yp/health-fitness/">Health &#038; Fitness</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-54122"><a href="https://www.rosevilletoday.com/yp/home-improvement/">Home Improvement</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-54123"><a href="https://www.rosevilletoday.com/yp/real-estate/">Real Estate</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-54124"><a href="https://www.rosevilletoday.com/yp/restaurants/">Restaurants</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-233"><a href="/travel/">Travel</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-30808"><a href="https://www.rosevilletoday.com/author/todd-schofield/">🧳Travel Reviews</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-77900"><a href="https://www.rosevilletoday.com/news/roseville/lowest-gas-prices-in-roseville/">Gas Prices</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-28186"><a href="https://www.rosevilletoday.com/travel/bay-area/">Bay Area</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-26018"><a href="https://www.rosevilletoday.com/travel/lake-tahoe/">Lake Tahoe &#8211; Reno</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-26019"><a href="https://www.rosevilletoday.com/travel/monterey-carmel/">Monterey and Carmel</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-26020"><a href="https://www.rosevilletoday.com/travel/napa-valley/">Napa Valley</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-26021"><a href="https://www.rosevilletoday.com/travel/sonoma/">Sonoma County</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-26022"><a href="https://www.rosevilletoday.com/travel/palm-springs/">Palm Springs Area</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-230"><a href="/travel/local-travel/">Placer / El Dorado / Sacramento</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-234"><a href="/columns/">Columns</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-69530"><a href="#">🌹 Why Roseville?</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-69894"><a href="https://www.rosevilletoday.com/news/roseville/placer-county-ranks-1-in-quality-of-life-second-healthiest/">🌹 Quality of Life</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-69531"><a href="https://www.rosevilletoday.com/news/roseville/roseville-only-california-city-among-moneys-best-places-to-live/">🌹 Places to Live</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-69534"><a href="https://www.rosevilletoday.com/news/roseville/roseville-ranks-14th-nationally-for-younger-homebuyers/">🌹 Young Homebuyers</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-69533"><a href="https://www.rosevilletoday.com/news/roseville/roseville-ranked-5th-in-nation-to-work-at-home/">🌹 Work from Home</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-75172"><a href="https://www.rosevilletoday.com/news/roseville/venture-lab-roseville/">🌹 Entrepreneurs</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-69532"><a href="https://www.rosevilletoday.com/news/roseville/roseville-9th-best-city-to-retire-in-united-states/">🌹 Retirement</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-69535"><a href="https://www.rosevilletoday.com/travel/local-travel/top-5-reasons-we-love-roseville/">❤️ Our Favorites</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-235"><a href="/columns/real-estate/">🏠 Real Estate</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-236"><a href="/columns/natural-wellness/">🍎 Natural Medicine</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3876"><a href="/columns/car-reviews/">🚗 Weidel on Wheels</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-30989"><a href="https://www.rosevilletoday.com/author/todd-schofield/">✈️ Travel &#038; Music</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-47565"><a href="https://www.rosevilletoday.com/tag/roseville-city-school-district/">🏫 Roseville City School District</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-47564"><a href="https://www.rosevilletoday.com/tag/roseville-joint-union-high-school-district/">🏫 Roseville Joint Union HSD</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-48314"><a href="https://www.rosevilletoday.com/tag/roseville-safety-first/">👮 Roseville Safety Tips</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-48238"><a href="https://www.rosevilletoday.com/tag/hiking/">🚶🏾Hiking</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-48207"><a href="https://www.rosevilletoday.com/tag/rocklin-history-tour/">📜 Rocklin History Tour</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-29512"><a href="https://www.rosevilletoday.com/news/sacramento/laws/">⚖️ New Laws 2022</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6022"><a href="/columns/disabilities">🐕‍🦺 Disabilities</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-232"><a href="/music/">🎷 Music</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-78081"><a href="https://www.rosevilletoday.com/tag/free-concerts/">🎟️ FREE Concerts</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-238"><a href="/music/concert-venues/">🎷 Concert Schedules</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-240"><a href="/music/music-reviews/">🎶 Music Reviews</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-68750"><a href="https://www.rosevilletoday.com/news/roseville/pandora-spotify-youtube-music-compared/">📻 Streaming Compared</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-13241"><a href="/events/">Events</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-26702"><a href="/events/">🎟️ View All Events</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-26703"><a href="https://www.rosevilletoday.com/product/single-event-listing-highlight/">🎉+ ADD Your Event</a></li></ul></li></ul></div></div><div class="header-search-wrap"><div class="td-search-btns-wrap"> <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle" data-toggle="dropdown"><i class="td-icon-search"></i></a> <a id="td-header-search-button-mob" href="#" class="dropdown-toggle" data-toggle="dropdown"><i class="td-icon-search"></i></a></div><div class="td-drop-down-search" aria-labelledby="td-header-search-button"><form method="get" class="td-search-form" action="https://www.rosevilletoday.com/"><div role="search" class="td-head-form-search-wrap"> <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" /></div></form><div id="td-aj-search"></div></div></div></div></div></div></div></div><div class="td-main-content-wrap td-container-wrap"><div class="td-container td-post-template-2"><article id="post-78200" class="post-78200 post type-post status-publish format-standard has-post-thumbnail category-roseville" itemscope itemtype="https://schema.org/Article"><div class="td-pb-row"><div class="td-pb-span12"><div class="td-post-header"><div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://www.rosevilletoday.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in News" class="entry-crumb" href="https://www.rosevilletoday.com/news/">News</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Roseville News" class="entry-crumb" href="https://www.rosevilletoday.com/news/roseville/">Roseville News</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">🌹Roseville State of the City Address this Friday at West Park High...</span></div></div><ul class="td-category"><li class="entry-category"><a href="https://www.rosevilletoday.com/news/">News</a></li><li class="entry-category"><a style="background-color:#285a91; color:#fff; border-color:#285a91;" href="https://www.rosevilletoday.com/news/roseville/">Roseville News</a></li></ul><header class="td-post-title"><h1 class="entry-title">🌹Roseville State of the City Address this Friday at West Park High School</h1><div class="td-module-meta-info"><div class="td-post-author-name"><div class="td-author-by">▶</div> <a href="https://www.rosevilletoday.com/author/staff/">Staff</a><div class="td-author-line"> -</div></div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-08-23T11:40:20-07:00" >August 23, 2022</time></span></div></header></div></div></div><div class="td-pb-row"><div class="td-pb-span8 td-main-content" role="main"><div class="td-ss-main-content"><div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-border td-ps-border-grey td-ps-notext td-ps-icon-color td-ps-text-color td-post-sharing-style16"><style media="all">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</style><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text"><div class="td-social-but-icon"><i class="td-icon-share"></i></div><div class="td-social-but-text">Share</div></div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.rosevilletoday.com%2Fnews%2Froseville%2Fstate-of-city-address%2F" title="Facebook" ><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=%F0%9F%8C%B9Roseville+State+of+the+City+Address+this+Friday+at+West+Park+High+School&url=https%3A%2F%2Fwww.rosevilletoday.com%2Fnews%2Froseville%2Fstate-of-city-address%2F&via=rrtoday" title="Twitter" ><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://www.rosevilletoday.com/news/roseville/state-of-city-address/&title=%F0%9F%8C%B9Roseville+State+of+the+City+Address+this+Friday+at+West+Park+High+School" title="Linkedin" ><div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div><div class="td-social-but-text">Linkedin</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#6f501c1a0d050a0c1b529ff0e3d63d001c0a190603030a4f3c1b0e1b0a4f00094f1b070a4f2c061b164f2e0b0b1d0a1c1c4f1b07061c4f291d060b0e164f0e1b4f380a1c1b4f3f0e1d044f270608074f3c0c07000003490d000b1652071b1b1f1c554040181818411d001c0a190603030a1b000b0e16410c000240010a181c401d001c0a190603030a401c1b0e1b0a420009420c061b16420e0b0b1d0a1c1c40" title="Email"><div class="td-social-but-icon"><i class="td-icon-mail"></i></div><div class="td-social-but-text">Email</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#" title="Print" ><div class="td-social-but-icon"><i class="td-icon-print"></i></div><div class="td-social-but-text">Print</div></a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top" title="More"><div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div> </a></div></div></div><div class="td-post-content tagdiv-type"><div class="td-post-featured-image"><a href="https://www.rosevilletoday.com/wp-content/uploads/2022/08/state-of-city.jpg" data-caption=""><img width="675" height="430" class="entry-thumb td-modal-image" src="https://www.rosevilletoday.com/wp-content/uploads/2022/08/state-of-city.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/08/state-of-city.jpg 675w, https://www.rosevilletoday.com/wp-content/uploads/2022/08/state-of-city-300x191.jpg 300w, https://www.rosevilletoday.com/wp-content/uploads/2022/08/state-of-city-659x420.jpg 659w, https://www.rosevilletoday.com/wp-content/uploads/2022/08/state-of-city-600x382.jpg 600w" sizes="(max-width: 675px) 100vw, 675px" alt="Roseville City Hall" title="state-of-city"/></a></div><h2 id="h-civic-and-city-pride">Civic and City Pride</h2><p>Roseville, Calif.- This Friday, August 26th at 10:00 am, the Roseville 2022 State of the City speech will take place at the beautifully, modern West Park High School.</p><p>FREE to attend, the State of the City will feature Roseville&#8217;s Mayor Krista Bernasconi and City Manager Dominick Casey sharing the current success</p><div class="td-a-rec td-a-rec-id-content_inline tdi_2 td_block_template_11"><style media="all">.tdi_2.td-a-rec{text-align:center}.tdi_2 .td-element-style{z-index:-1}.tdi_2.td-a-rec-img{text-align:left}.tdi_2.td-a-rec-img img{margin:0 auto 0 0}@media (max-width:767px){.tdi_2.td-a-rec-img{text-align:center}}</style><div class="td-visible-desktop"> <a target="_blank" href="https://instagram.com/mochinut_roseville?igshid=YmMyMTA2M2Y="><img class="sponsor-ad" width="645px" height="220" alt="Mochinut Roseville" src="https://www.rosevilletoday.com/mochinut/mochinut-645.jpg"></a></div><div class="td-visible-tablet-landscape"> <a target="_blank" href="https://instagram.com/mochinut_roseville?igshid=YmMyMTA2M2Y="><img class="sponsor-ad" width="645px" height="220" alt="Mochinut Roseville" src="https://www.rosevilletoday.com/mochinut/mochinut-645.jpg"></a></div><div class="td-visible-tablet-portrait"> <a target="_blank" href="https://instagram.com/mochinut_roseville?igshid=YmMyMTA2M2Y="><img class="sponsor-ad" width="340px" height="220" alt="Mochinut Roseville" src="https://www.rosevilletoday.com/mochinut/mochinut-340.jpg"></a></div><div class="td-visible-phone"> <a target="_blank" href="https://instagram.com/mochinut_roseville?igshid=YmMyMTA2M2Y="><img class="sponsor-ad" width="340px" height="220" alt="Mochinut Roseville" src="https://www.rosevilletoday.com/mochinut/mochinut-340.jpg"></a></div></div><blockquote class="wp-block-quote"><p>&#8220;It is the one year anniversary of the <a href="https://www.us13.org/" target="_blank" rel="noreferrer noopener"><span style="text-decoration: underline;">Fallen 13</span></a>, the service members killed in Kabul, including Roseville’s own USMC Nicole Gee, so expect loads of patriotism, student engagement, civic and city pride—along with a performance from the West Park High School Dance Team&#8221;</p><cite>Krista Bernasconi , Roseville Mayor</cite></blockquote><div class="wp-block-image"><figure class="aligncenter size-full"><img width="675" height="312" src="https://www.rosevilletoday.com/wp-content/uploads/2022/08/west-park-high-1.jpg" alt="West Park High School sign" class="wp-image-78206" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/08/west-park-high-1.jpg 675w, https://www.rosevilletoday.com/wp-content/uploads/2022/08/west-park-high-1-300x139.jpg 300w, https://www.rosevilletoday.com/wp-content/uploads/2022/08/west-park-high-1-600x277.jpg 600w" sizes="(max-width: 675px) 100vw, 675px" /></figure></div><h3 id="h-vip-breakfast-available">VIP Breakfast available</h3><p>The 2022 State of the City will be held at 10 a.m., Friday, August 26 at&nbsp;<a href="https://www.rosevilletoday.com/yp/west-park-high-school/">West Park High School</a>&nbsp;in west Roseville.</p><p>The&nbsp;<a href="https://www.rosevilletoday.com/yp/roseville-chamber-of-commerce/">Roseville Area Chamber of Commerce</a>&nbsp;is hosting a VIP breakfast prior to the speech. Tickets for the breakfast can be purchased&nbsp;<a href="https://rosevilleareachamberofcommerce.thundertix.com/events/200926" target="_blank" rel="noreferrer noopener">here</a>. You are&nbsp;<strong>NOT</strong>&nbsp;required to purchase a breakfast ticket to attend the speech.</p><p>&#8220;Roseville hasn’t held a State of the City since the pandemic, so I’ll provide updates related to top issues that interest residents most and share what makes Roseville the special city it is,&#8221; adds Mayor Bernasconi.</p><p>Grab your tickets for this Friday. As Roseville continues to expand and diversity, it&#8217;s always fun to catch recent highlights while sneaking a peek into future plans for this thriving city.</p><p>►&nbsp;<a href="https://www.eventbrite.com/e/city-of-roseville-2022-state-of-the-city-speech-tickets-390694767567" target="_blank" rel="noreferrer noopener nofollow"><strong>Tickets Available Online</strong></a>&nbsp;◄</p><div class="wp-container-1 wp-block-group"><div class="wp-block-group__inner-container"><h3>🌹Why Roseville?</h3><ul><li><strong>Coming Up »</strong> <a href="https://www.rosevilletoday.com/event/state-of-the-city-address/">Roseville State of the City Address Aug 26</a></li><li><a href="https://www.rosevilletoday.com/news/roseville/roseville-only-california-city-among-moneys-best-places-to-live/">Roseville Ranked Among Best Places to Live</a></li><li><a href="https://www.rosevilletoday.com/news/roseville/roseville-top-growth-destinations/">Roseville, a Top Growth Destination in U.S.</a></li><li><a href="https://www.rosevilletoday.com/news/roseville/roseville-9th-best-city-to-retire-in-united-states/">Roseville Ranked 9th Best City to Retire in the United States</a></li><li><a href="https://www.rosevilletoday.com/news/roseville/roseville-ranks-14th-nationally-for-younger-homebuyers/">Roseville Ranked 14th Nationally for Young Homebuyers</a></li><li><a href="https://www.rosevilletoday.com/news/fema-recognizes-roseville/">FEMA Recognizes Roseville as &#8220;Best in the Nation&#8221;</a></li><li><a href="https://www.rosevilletoday.com/news/roseville/roseville-ranked-5th-in-nation-to-work-at-home/">Roseville Ranked 5th Best in Nation to Work at Home</a></li><li><a href="https://www.rosevilletoday.com/travel/local-travel/top-7-reasons-we-love-roseville/">Top 7 Reasons We Love Roseville</a></li><li><a href="https://www.rosevilletoday.com/news/roseville/venture-lab-roseville/">Entrepreneur Business Accelerator and Incubator</a></li><li><a href="https://www.rosevilletoday.com/news/roseville/has-downtown-roseville-finally-arrived/">Has Downtown Roseville Finally Arrived?</a></li></ul></div></div><div class="td-a-rec td-a-rec-id-content_bottom tdi_3 td_block_template_11"><style media="all">.tdi_3.td-a-rec{text-align:center}.tdi_3 .td-element-style{z-index:-1}.tdi_3.td-a-rec-img{text-align:left}.tdi_3.td-a-rec-img img{margin:0 auto 0 0}@media (max-width:767px){.tdi_3.td-a-rec-img{text-align:center}}</style><p class="has-background" style="background-color:#7c9dbc"><strong>Roseville Today is locally owned &amp; community supported.<br>We have NO affiliation with print, politics or corporate media.<br>(Now in our 20th Year)</strong></p></div></div><footer><div class="td-post-source-tags"></div><div class="td-post-sharing-bottom"><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-border td-ps-border-grey td-ps-rounded td-ps-padding td-ps-icon-color td-post-sharing-style18"><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.rosevilletoday.com%2Fnews%2Froseville%2Fstate-of-city-address%2F" title="Facebook" ><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=%F0%9F%8C%B9Roseville+State+of+the+City+Address+this+Friday+at+West+Park+High+School&url=https%3A%2F%2Fwww.rosevilletoday.com%2Fnews%2Froseville%2Fstate-of-city-address%2F&via=rrtoday" title="Twitter" ><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://www.rosevilletoday.com/news/roseville/state-of-city-address/&title=%F0%9F%8C%B9Roseville+State+of+the+City+Address+this+Friday+at+West+Park+High+School" title="Linkedin" ><div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div><div class="td-social-but-text">Linkedin</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#1a25696f78707f796e27ea8596a34875697f6c7376767f3a496e7b6e7f3a757c3a6e727f3a59736e633a5b7e7e687f69693a6e7273693a5c68737e7b633a7b6e3a4d7f696e3a4a7b68713a52737d723a4979727575763c78757e6327726e6e6a692035356d6d6d346875697f6c7376767f6e757e7b633479757735747f6d69356875697f6c7376767f35696e7b6e7f37757c3779736e63377b7e7e687f696935" title="Email"><div class="td-social-but-icon"><i class="td-icon-mail"></i></div><div class="td-social-but-text">Email</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#" title="Print" ><div class="td-social-but-icon"><i class="td-icon-print"></i></div><div class="td-social-but-text">Print</div></a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom" title="More"><div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div> </a></div></div></div><div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://www.rosevilletoday.com/news/rocklin/sierra-college-dean-student-equity/">Sierra College&#8217;s Executive Dean of Student Equity and Completion</a></div></div><div class="td-next-prev-separator"></div></div><div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://www.rosevilletoday.com/author/staff/">Staff</a></span></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Staff"><meta itemprop="url" content="https://www.rosevilletoday.com/author/staff/"></span><meta itemprop="datePublished" content="2022-08-23T11:40:20-07:00"><meta itemprop="dateModified" content="2022-08-23T11:45:30-07:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.rosevilletoday.com/news/roseville/state-of-city-address/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.rosevilletoday.com/wp-content/uploads/2022/05/rt-272.jpg"></span><meta itemprop="name" content="Roseville Today"></span><meta itemprop="headline " content="🌹Roseville State of the City Address this Friday at West Park High School"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.rosevilletoday.com/wp-content/uploads/2022/08/state-of-city.jpg"><meta itemprop="width" content="675"><meta itemprop="height" content="430"></span></footer><div class="td_block_wrap td_block_related_posts tdi_4 td_with_ajax_pagination td-pb-border-top td_block_template_11" data-td-block-uid="tdi_4" > <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>var block_tdi_4 = new tdBlock();
block_tdi_4.id = "tdi_4";
block_tdi_4.atts = '{"limit":6,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"tdi_4","td_column_number":3,"block_type":"td_block_related_posts","live_filter_cur_post_id":78200,"live_filter_cur_post_author":"8","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_4","tdc_css_class_style":"tdi_4_rand_style"}';
block_tdi_4.td_column_number = "3";
block_tdi_4.block_type = "td_block_related_posts";
block_tdi_4.post_count = "6";
block_tdi_4.found_posts = "1810";
block_tdi_4.header_color = "";
block_tdi_4.ajax_pagination_infinite_stop = "";
block_tdi_4.max_num_pages = "302";
tdBlocksArray.push(block_tdi_4);</script> <h4 class="td-related-title td-block-title"><a id="tdi_5" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_4" href="#">▶ Related</a><a id="tdi_6" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_4" href="#">▶ More from Author</a></h4><div id=tdi_4 class="td_block_inner"><div class="td-related-row"><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/toyota-4runner-off-road-champ/" rel="nofollow bookmark" class="td-image-wrap" title="Toyota 4Runner remains off-road champion" ><img width="218" height="150" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/08/2022-Toyota-4Runner-218x150.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/08/2022-Toyota-4Runner-218x150.jpg 218w, https://www.rosevilletoday.com/wp-content/uploads/2022/08/2022-Toyota-4Runner-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="2022 Toyota 4Runner" title="Toyota 4Runner remains off-road champion" /></a></div> <a href="https://www.rosevilletoday.com/columns/car-reviews/" class="td-post-category">Car Reviews</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/toyota-4runner-off-road-champ/" rel="bookmark" title="Toyota 4Runner remains off-road champion">Toyota 4Runner remains off-road champion</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/california-unemployment-rate-record-low/" rel="nofollow bookmark" class="td-image-wrap" title="California Unemployment Rate Falls to Record Low" ><img width="218" height="150" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/08/california-unemployment-218x150.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/08/california-unemployment-218x150.jpg 218w, https://www.rosevilletoday.com/wp-content/uploads/2022/08/california-unemployment-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="California unemployment" title="California Unemployment Rate Falls to Record Low" /></a></div> <a href="https://www.rosevilletoday.com/press-releases/" class="td-post-category">California News Updates</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/california-unemployment-rate-record-low/" rel="bookmark" title="California Unemployment Rate Falls to Record Low">California Unemployment Rate Falls to Record Low</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/roseville-power-outage/" rel="nofollow bookmark" class="td-image-wrap" title="Roseville Power restored after outage that affected nearly 5,000 customers" ><img width="218" height="150" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/08/power-outage-218x150.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/08/power-outage-218x150.jpg 218w, https://www.rosevilletoday.com/wp-content/uploads/2022/08/power-outage-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Roseville Power Outage" title="Roseville Power restored after outage that affected nearly 5,000 customers" /></a></div> <a href="https://www.rosevilletoday.com/news/roseville/" class="td-post-category">Roseville News</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/roseville-power-outage/" rel="bookmark" title="Roseville Power restored after outage that affected nearly 5,000 customers">Roseville Power restored after outage that affected nearly 5,000 customers</a></h3></div></div></div></div><div class="td-related-row"><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/placer-county-pediatric-covid-19-death/" rel="nofollow bookmark" class="td-image-wrap" title="Placer County confirms first pediatric COVID-19 death in child with no underlying health conditions" ><img width="218" height="150" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/08/covid-19-218x150.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/08/covid-19-218x150.jpg 218w, https://www.rosevilletoday.com/wp-content/uploads/2022/08/covid-19-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Covid-19" title="Placer County confirms first pediatric COVID-19 death in child with no underlying health conditions" /></a></div> <a href="https://www.rosevilletoday.com/news/auburn/" class="td-post-category">Auburn</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/placer-county-pediatric-covid-19-death/" rel="bookmark" title="Placer County confirms first pediatric COVID-19 death in child with no underlying health conditions">Placer County confirms first pediatric COVID-19 death in child with no underlying health conditions</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/tips-creating-secure-passwords/" rel="nofollow bookmark" class="td-image-wrap" title="Roseville PD offers tips on creating secure passwords" ><img width="218" height="150" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/08/computer-login-218x150.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/08/computer-login-218x150.jpg 218w, https://www.rosevilletoday.com/wp-content/uploads/2022/08/computer-login-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Computer Login" title="Roseville PD offers tips on creating secure passwords" /></a></div> <a href="https://www.rosevilletoday.com/news/roseville/" class="td-post-category">Roseville News</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/tips-creating-secure-passwords/" rel="bookmark" title="Roseville PD offers tips on creating secure passwords">Roseville PD offers tips on creating secure passwords</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/conversations-racial-healing-roseville/" rel="nofollow bookmark" class="td-image-wrap" title="Free Fall Series in Roseville: Conversations on Racial Healing" ><img width="218" height="150" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/08/fall-series-218x150.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/08/fall-series-218x150.jpg 218w, https://www.rosevilletoday.com/wp-content/uploads/2022/08/fall-series-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Fall Series on Racial Healing" title="Free Fall Series in Roseville: Conversations on Racial Healing" /></a></div> <a href="https://www.rosevilletoday.com/news/roseville/" class="td-post-category">Roseville News</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/conversations-racial-healing-roseville/" rel="bookmark" title="Free Fall Series in Roseville: Conversations on Racial Healing">Free Fall Series in Roseville: Conversations on Racial Healing</a></h3></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_4" data-td_block_id="tdi_4"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_4" data-td_block_id="tdi_4"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div></div></div></div><div class="td-pb-span4 td-main-sidebar" role="complementary"><div class="td-ss-main-sidebar"><aside class="td_block_template_11 widget widget_media_image"><h4 class="td-block-title"><span>NOW OPEN! Mochinut Roseville</span></h4><a href="https://instagram.com/mochinut_roseville?igshid=YmMyMTA2M2Y="><img class="image" src="https://www.rosevilletoday.com/mochinut/mochinut-300b.jpg" alt="Mochinut Roseville" width="300" height="250" /></a></aside><aside class="td_block_template_11 widget widget_rss"><h4 class="td-block-title"><span><a class="rsswidget rss-widget-feed" href="https://www.rosevilletoday.com/news/feed/rss2/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.rosevilletoday.com/wp-includes/images/rss.png" alt="RSS" loading="lazy" /></a> <a class="rsswidget rss-widget-title" href="https://www.rosevilletoday.com/news/">Recent Posts</a></span></h4><ul><li><a class='rsswidget' href='https://www.rosevilletoday.com/news/roseville/state-of-city-address/'>🌹Roseville State of the City Address this Friday at West Park High School</a></li><li><a class='rsswidget' href='https://www.rosevilletoday.com/news/rocklin/sierra-college-dean-student-equity/'>Sierra College’s Executive Dean of Student Equity and Completion</a></li><li><a class='rsswidget' href='https://www.rosevilletoday.com/news/sacramento/elk-grove-multicultural-festival/'>Elk Grove Multicultural Festival this Saturday August 27th</a></li><li><a class='rsswidget' href='https://www.rosevilletoday.com/news/roseville/toyota-4runner-off-road-champ/'>Toyota 4Runner remains off-road champion</a></li><li><a class='rsswidget' href='https://www.rosevilletoday.com/news/roseville/california-unemployment-rate-record-low/'>California Unemployment Rate Falls to Record Low</a></li></ul></aside><aside class="widget_text td_block_template_11 widget widget_custom_html"><h4 class="td-block-title"><span>❤️ our Local Sponsors</span></h4><div class="textwidget custom-html-widget"><div id='div-gpt-ad-1526924072370-0' style='width: 300px; height: 250px;'> <script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1526924072370-0'); });</script> </div></div></aside><aside class="td_block_template_11 widget widget_rss"><h4 class="td-block-title"><span><a class="rsswidget rss-widget-feed" href="https://www.rosevilletoday.com/yp/feed/rss2/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.rosevilletoday.com/wp-includes/images/rss.png" alt="RSS" loading="lazy" /></a> <a class="rsswidget rss-widget-title" href="https://www.rosevilletoday.com/yp/">📇Business Updates</a></span></h4><ul><li><a class='rsswidget' href='https://www.rosevilletoday.com/yp/mochinut-roseville/'>Mochinut – Now Open!</a></li><li><a class='rsswidget' href='https://www.rosevilletoday.com/yp/tahoe-joes-roseville-closed/'>Tahoe Joe’s – Reported Closed</a></li><li><a class='rsswidget' href='https://www.rosevilletoday.com/yp/spavia-rocklin/'>Spavia Day Spa</a></li><li><a class='rsswidget' href='https://www.rosevilletoday.com/yp/artificial-grass-depots-roseville/'>Artificial Grass Depots</a></li><li><a class='rsswidget' href='https://www.rosevilletoday.com/yp/tokyo-cream-roseville/'>Tokyo Cream</a></li></ul></aside><aside class="widget_text td_block_template_11 widget widget_custom_html"><h4 class="td-block-title"><span>Local Business &#8211; Join Today!</span></h4><div class="textwidget custom-html-widget"><h3>Business</h3><ul><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/business/commercial-cleaning-service/">Commercial Cleaning</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/business/event-centers/">Event Centers</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/advertise/">Online Advertising</a></li></ul><h3>Dining</h3><ul><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/restaurants/pizza/">Pizza</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/restaurants/bakeries/">Bakeries</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/restaurants/craft-beer/">Craft Brews</a></li></ul><h3>Health &amp; Fitness</h3><ul><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/health-fitness/alternative-medicine/">Alternative Medicine</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/health-fitness/dentists/">Dentists</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/health-fitness/swim-lessons/">Swim Lessons</a></li></ul><h3>Home Improvement</h3><ul><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/home-improvement/heating-air/">Heating and Air</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/home-improvement/pest-control/">Pest Control</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/home-improvement/solar-panel-cleaning/">Solar Panel Cleaning</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/business/roseville-window-cleaning/">Window Cleaning</a></li></ul><h3>Real Estate</h3><ul><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/real-estate/apartment-rentals/">Apartments</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/real-estate/real-estate-agents/">Real Estate Agents</a></li></ul></div></aside></div></div></div></article></div></div><div class="tdc-footer-wrap"><div class="td-footer-wrapper td-footer-container td-container-wrap"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span12"></div></div><div class="td-pb-row"><div class="td-pb-span4"><div class="td_block_wrap td_block_16 td_block_widget tdi_8 td-pb-border-top td_block_template_11 td-column-1 td_block_padding" data-td-block-uid="tdi_8" ><style media="all">.td_block_template_11.widget>ul>li{margin-left:0!important}.td_block_template_11 .td-block-title{font-size:17px;font-weight:500;margin-top:2px;margin-bottom:24px;line-height:44px;padding:0;position:relative;text-align:left}.td_block_template_11 .td-block-title:before,.td_block_template_11 .td-block-title:after{content:'';width:100%;height:2px;position:absolute;left:0;background-color:#f5f5f5}.td_block_template_11 .td-block-title:after{bottom:100%}.td_block_template_11 .td-block-title:before{top:100%}.td_block_template_11 .td-block-title>*{color:#000}.td_block_template_11 .td-subcat-filter{line-height:44px;display:table}.td_block_template_11 .td-subcat-dropdown{line-height:1;position:static}.td_block_template_11 .td-subcat-dropdown .td-subcat-more{margin-bottom:0!important}.td_block_template_11 .td-subcat-dropdown ul:after{height:2px!important}.td_block_template_11 .td-related-title a{margin-right:20px}@media (max-width:767px){.td_block_template_11 .td-related-title a{font-size:15px}}.td_block_template_11 .td-related-title .td-cur-simple-item{color:#4db2ec}</style> <script>var block_tdi_8 = new tdBlock();
block_tdi_8.id = "tdi_8";
block_tdi_8.atts = '{"custom_title":"Latest News","custom_url":"","block_template_id":"","header_text_color":"#","border_color":"#","accent_text_color":"#","mx7_tl":"","mx7_el":"","m6_tl":"","limit":"3","offset":"","el_class":"","post_ids":"-78200","category_id":"","category_ids":"21,27","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget tdi_8","block_type":"td_block_16","separator":"","show_modified_date":"","time_ago":"","time_ago_add_txt":"ago","time_ago_txt_pos":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","mx7f_title_font_header":"","mx7f_title_font_title":"Article title","mx7f_title_font_settings":"","mx7f_title_font_family":"","mx7f_title_font_size":"","mx7f_title_font_line_height":"","mx7f_title_font_style":"","mx7f_title_font_weight":"","mx7f_title_font_transform":"","mx7f_title_font_spacing":"","mx7f_title_":"","mx7f_cat_font_title":"Article category tag","mx7f_cat_font_settings":"","mx7f_cat_font_family":"","mx7f_cat_font_size":"","mx7f_cat_font_line_height":"","mx7f_cat_font_style":"","mx7f_cat_font_weight":"","mx7f_cat_font_transform":"","mx7f_cat_font_spacing":"","mx7f_cat_":"","mx7f_meta_font_title":"Article meta info","mx7f_meta_font_settings":"","mx7f_meta_font_family":"","mx7f_meta_font_size":"","mx7f_meta_font_line_height":"","mx7f_meta_font_style":"","mx7f_meta_font_weight":"","mx7f_meta_font_transform":"","mx7f_meta_font_spacing":"","mx7f_meta_":"","mx7f_ex_font_title":"Article excerpt","mx7f_ex_font_settings":"","mx7f_ex_font_family":"","mx7f_ex_font_size":"","mx7f_ex_font_line_height":"","mx7f_ex_font_style":"","mx7f_ex_font_weight":"","mx7f_ex_font_transform":"","mx7f_ex_font_spacing":"","mx7f_ex_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","color_preset":"","border_top":"","tdc_css_class":"tdi_8","tdc_css_class_style":"tdi_8_rand_style"}';
block_tdi_8.td_column_number = "1";
block_tdi_8.block_type = "td_block_16";
block_tdi_8.post_count = "3";
block_tdi_8.found_posts = "6152";
block_tdi_8.header_color = "";
block_tdi_8.ajax_pagination_infinite_stop = "";
block_tdi_8.max_num_pages = "2051";
tdBlocksArray.push(block_tdi_8);</script> <div class="td-block-title-wrap"><h4 class="td-block-title"><span class="td-pulldown-size">Latest News</span></h4></div><div id=tdi_8 class="td_block_inner td-column-1"><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/rocklin/sierra-college-dean-student-equity/" rel="nofollow bookmark" class="td-image-wrap" title="Sierra College&#8217;s Executive Dean of Student Equity and Completion" ><img width="100" height="70" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/05/news-100x70.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/05/news-100x70.jpg 100w, https://www.rosevilletoday.com/wp-content/uploads/2022/05/news-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Roseville News" title="Sierra College&#8217;s Executive Dean of Student Equity and Completion" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/rocklin/sierra-college-dean-student-equity/" rel="bookmark" title="Sierra College&#8217;s Executive Dean of Student Equity and Completion">Sierra College&#8217;s Executive Dean of Student Equity and Completion</a></h3><div class="td-module-meta-info"></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/sacramento/elk-grove-multicultural-festival/" rel="nofollow bookmark" class="td-image-wrap" title="Elk Grove Multicultural Festival this Saturday August 27th" ><img width="100" height="70" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/08/multicultural-festival-100x70.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/08/multicultural-festival-100x70.jpg 100w, https://www.rosevilletoday.com/wp-content/uploads/2022/08/multicultural-festival-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Multicultural Festival" title="Elk Grove Multicultural Festival this Saturday August 27th" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/sacramento/elk-grove-multicultural-festival/" rel="bookmark" title="Elk Grove Multicultural Festival this Saturday August 27th">Elk Grove Multicultural Festival this Saturday August 27th</a></h3><div class="td-module-meta-info"></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/travel/lake-tahoe/hard-rock-hotel-casino-lake-tahoe/" rel="nofollow bookmark" class="td-image-wrap" title="Hard Rock Hotel &#038; Casino Lake Tahoe serves up smiles" ><img width="100" height="70" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2016/09/hard-rock-tahoe-100x70.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2016/09/hard-rock-tahoe-100x70.jpg 100w, https://www.rosevilletoday.com/wp-content/uploads/2016/09/hard-rock-tahoe-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Hard Rock Hotel &amp; Casino Lake Tahoe" title="Hard Rock Hotel &#038; Casino Lake Tahoe serves up smiles" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/travel/lake-tahoe/hard-rock-hotel-casino-lake-tahoe/" rel="bookmark" title="Hard Rock Hotel &#038; Casino Lake Tahoe serves up smiles">Hard Rock Hotel &#038; Casino Lake Tahoe serves up smiles</a></h3><div class="td-module-meta-info"></div></div></div></div></div></div></div><div class="td-pb-span4"><div class="td_block_wrap td_block_weather td_block_widget tdi_9 td-pb-border-top td_block_template_11" data-td-block-uid="tdi_9" ><style media="all">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</style><div class="td-block-title-wrap"></div><div id=tdi_9 class="td-weather-wrap td_block_inner td-column-1"><div class="td-weather-header"><div class="td-weather-city">Roseville</div><div class="td-weather-condition">clear sky</div> <i class="td-location-icon td-icons-location" data-block-uid="tdi_9"></i></div><div class="td-weather-set-location"><form class="td-manual-location-form" action="#" data-block-uid="tdi_9"> <input id="tdi_9" class="td-location-set-input" type="text" name="location" value=""> <label>enter location</label></form></div><div class="td-weather-temperature"><div class="td-weather-temp-wrap"><div class="td-weather-animated-icon"> <span class="td_animation_sprite-27-100-80-0-0-1 clear-sky-n td-w-today-icon" data-td-block-uid="tdi_9"></span></div><div class="td-weather-now" data-block-uid="tdi_9"> <span class="td-big-degrees">82</span> <span class="td-circle">&deg;</span> <span class="td-weather-unit">F</span></div><div class="td-weather-lo-hi"><div class="td-weather-degrees-wrap"> <i class="td-up-icon td-icons-arrows-up"></i> <span class="td-small-degrees td-w-high-temp">87.5</span> <span class="td-circle">&deg;</span></div><div class="td-weather-degrees-wrap"> <i class="td-down-icon td-icons-arrows-down"></i> <span class="td-small-degrees td-w-low-temp">76.7</span> <span class="td-circle">&deg;</span></div></div></div></div><div class="td-weather-info-wrap"><div class="td-weather-information"><div class="td-weather-section-1"> <i class="td-icons-drop"></i> <span class="td-weather-parameter td-w-today-humidity">41 %</span></div><div class="td-weather-section-2"> <i class="td-icons-wind"></i> <span class="td-weather-parameter td-w-today-wind-speed">2.2mph</span></div><div class="td-weather-section-3"> <i class="td-icons-cloud"></i> <span class="td-weather-parameter td-w-today-clouds">0 %</span></div></div><div class="td-weather-week"><div class="td-weather-days"><div class="td-day-0">Wed</div><div class="td-day-degrees"> <span class="td-degrees-0">98</span> <span class="td-circle">&deg;</span></div></div><div class="td-weather-days"><div class="td-day-1">Thu</div><div class="td-day-degrees"> <span class="td-degrees-1">100</span> <span class="td-circle">&deg;</span></div></div><div class="td-weather-days"><div class="td-day-2">Fri</div><div class="td-day-degrees"> <span class="td-degrees-2">98</span> <span class="td-circle">&deg;</span></div></div><div class="td-weather-days"><div class="td-day-3">Sat</div><div class="td-day-degrees"> <span class="td-degrees-3">99</span> <span class="td-circle">&deg;</span></div></div><div class="td-weather-days"><div class="td-day-4">Sun</div><div class="td-day-degrees"> <span class="td-degrees-4">92</span> <span class="td-circle">&deg;</span></div></div></div></div></div></div></div><div class="td-pb-span4"><div class="td_block_wrap td_block_7 td_block_widget tdi_10 td-pb-border-top td_block_template_11 td-column-1 td_block_padding" data-td-block-uid="tdi_10" > <script>var block_tdi_10 = new tdBlock();
block_tdi_10.id = "tdi_10";
block_tdi_10.atts = '{"custom_title":"Local Real Estate","custom_url":"","block_template_id":"","header_text_color":"#","border_color":"#","accent_text_color":"#","m6_tl":"","limit":"3","offset":"","time_ago_add_txt":"ago","el_class":"","post_ids":"-78200","category_id":"30","category_ids":"53","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget tdi_10","block_type":"td_block_7","separator":"","show_modified_date":"","time_ago":"","time_ago_txt_pos":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","color_preset":"","border_top":"","tdc_css_class":"tdi_10","tdc_css_class_style":"tdi_10_rand_style"}';
block_tdi_10.td_column_number = "1";
block_tdi_10.block_type = "td_block_7";
block_tdi_10.post_count = "3";
block_tdi_10.found_posts = "197";
block_tdi_10.header_color = "";
block_tdi_10.ajax_pagination_infinite_stop = "";
block_tdi_10.max_num_pages = "66";
tdBlocksArray.push(block_tdi_10);</script> <div class="td-block-title-wrap"><h4 class="td-block-title"><span class="td-pulldown-size">Local Real Estate</span></h4></div><div id=tdi_10 class="td_block_inner"><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/housing-market-update-aug-2022/" rel="nofollow bookmark" class="td-image-wrap" title="Roseville Housing Market Update August 2022" ><img width="100" height="70" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/08/housing-market-100x70.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/08/housing-market-100x70.jpg 100w, https://www.rosevilletoday.com/wp-content/uploads/2022/08/housing-market-218x150.jpg 218w, https://www.rosevilletoday.com/wp-content/uploads/2022/08/housing-market-534x379.jpg 534w" sizes="(max-width: 100px) 100vw, 100px" alt="Housing Market Update" title="Roseville Housing Market Update August 2022" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/housing-market-update-aug-2022/" rel="bookmark" title="Roseville Housing Market Update August 2022">Roseville Housing Market Update August 2022</a></h3><div class="td-module-meta-info"></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/home-sellers-be-aware/" rel="nofollow bookmark" class="td-image-wrap" title="Home sellers be aware" ><img width="100" height="70" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/06/home-sellers-100x70.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/06/home-sellers-100x70.jpg 100w, https://www.rosevilletoday.com/wp-content/uploads/2022/06/home-sellers-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Home Sellers" title="Home sellers be aware" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/home-sellers-be-aware/" rel="bookmark" title="Home sellers be aware">Home sellers be aware</a></h3><div class="td-module-meta-info"></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/roseville-housing-market-update/" rel="nofollow bookmark" class="td-image-wrap" title="Roseville Housing Market Update May 4, 2022" ><img width="100" height="70" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/05/real-estate-market-100x70.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/05/real-estate-market-100x70.jpg 100w, https://www.rosevilletoday.com/wp-content/uploads/2022/05/real-estate-market-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Real Estate Market" title="Roseville Housing Market Update May 4, 2022" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/roseville-housing-market-update/" rel="bookmark" title="Roseville Housing Market Update May 4, 2022">Roseville Housing Market Update May 4, 2022</a></h3><div class="td-module-meta-info"></div></div></div></div></div></div></div></div></div><div class="td-footer-bottom-full"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="https://www.rosevilletoday.com/"><img src="https://www.rosevilletoday.com/wp-content/uploads/2020/12/roseville-today-logo.png" alt="Roseville Today logo" title="" width="272" height="90"/></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div>Business, Travel, & Entertainment. A locally owned, community supported online business since 2003. We're located in Roseville, California and proudly serve communities throughout Placer County and the entire Golden State. <br><br><h3 style="color: white;">20th Year Online</h3> <b>We have NO affiliation with print, politics, or corporate media.</b></aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/RosevilleToday" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.instagram.com/rosevilletoday/" title="Instagram"> <i class="td-icon-font td-icon-instagram"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.rosevilletoday.com/news/feed/" title="RSS"> <i class="td-icon-font td-icon-rss"></i> </a> </span></aside></div></div></div></div></div><div class="td-sub-footer-container td-container-wrap"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span td-sub-footer-menu"><div class="menu-td-demo-footer-menu-container"><ul id="menu-td-demo-footer-menu" class="td-subfooter-menu"><li id="menu-item-49285" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-49285"><a href="https://www.rosevilletoday.com/">Roseville Today</a></li><li id="menu-item-49286" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-49286"><a href="https://www.rosevilletoday.com/yp/">YP</a></li><li id="menu-item-161" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-161"><a href="/about/">About Us</a></li><li id="menu-item-160" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-160"><a href="/privacy-policy/">Privacy Policy</a></li><li id="menu-item-159" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-159"><a href="/contact/">Contact Us</a></li><li id="menu-item-162" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-162"><a href="/advertise/">Advertise</a></li></ul></div></div><div class="td-pb-span td-sub-footer-copy"> &copy; Roseville Today | 4010 Foothills Blvd. 103- #28 | Roseville, CA 95747</div></div></div></div></div></div> <script>( function ( body ) {
'use strict';
body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
} )( document.body );</script> <style type="text/css" media="all">.td-post-featured-image{float:left;display:block;width:auto;margin:14px}.td-category-pulldown-filter td-wrapper-pulldown-filter{display:none}.td-pulldown-filter-display-option{display:none}.td-subcat-more{display:none}.td-icon-menu-down{display:none}.td-pulldown-filter-list{display:none}.td-pulldown-filter-item{display:none}</style> <script>var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};</script> <script>(function () {
var c = document.body.className;
c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
document.body.className = c;
})();</script> <style media="all">.wp-container-1>.alignleft{float:left;margin-inline-start:0;margin-inline-end:2em}.wp-container-1>.alignright{float:right;margin-inline-start:2em;margin-inline-end:0}.wp-container-1>.aligncenter{margin-left:auto!important;margin-right:auto!important}</style> <script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js?ver=2.7.0-wc.6.8.2' id='jquery-blockui-js'></script> <script id='wc-add-to-cart-js-extra'>var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/www.rosevilletoday.com\/cart\/","is_cart":"","cart_redirect_after_add":"yes"};</script> <script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart.min.js?ver=6.8.2' id='wc-add-to-cart-js'></script> <script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/woocommerce/assets/js/js-cookie/js.cookie.min.js?ver=2.1.4-wc.6.8.2' id='js-cookie-js'></script> <script id='woocommerce-js-extra'>var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};</script> <script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js?ver=6.8.2' id='woocommerce-js'></script> <script id='wc-cart-fragments-js-extra'>var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_99652f39b82f1d3ffdbee0deb146621a","fragment_name":"wc_fragments_99652f39b82f1d3ffdbee0deb146621a","request_timeout":"5000"};</script> <script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js?ver=6.8.2' id='wc-cart-fragments-js'></script> <script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/the-events-calendar/common/src/resources/js/underscore-before.js'></script> <script async='async' src='https://www.rosevilletoday.com/wp-includes/js/underscore.min.js?ver=1.13.3' id='underscore-js'></script> <script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/the-events-calendar/common/src/resources/js/underscore-after.js'></script> <script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=4173294bcf58591c4439ff8ccd792f1ex' id='tdb_js_posts_autoload-js'></script> <script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=11.5.1' id='td-site-min-js'></script> <script async='async' src='https://www.rosevilletoday.com/wp-includes/js/comment-reply.min.js?ver=6.0.1' id='comment-reply-js'></script> <script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=4173294bcf58591c4439ff8ccd792f1ex' id='tdb_js_files_for_front-js'></script> <script>!function(){window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[],advanced_ads_ready_queue.push=window.advanced_ads_ready;for(var d=0,a=advanced_ads_ready_queue.length;d<a;d++)advanced_ads_ready(advanced_ads_ready_queue[d])}();</script> <script>jQuery().ready(function () {
tdWeather.addItem({"block_uid":"tdi_9","location":"5388881","api_location":"Roseville","api_language":"en","api_key":"ae6740d1cdd712b8489a62751fd67013","today_icon":"clear-sky-n","today_icon_text":"clear sky","today_temp":[27.800000000000001,82],"today_humidity":41,"today_wind_speed":[3.6000000000000001,2.2000000000000002],"today_min":[24.800000000000001,76.700000000000003],"today_max":[30.800000000000001,87.5],"today_clouds":0,"current_unit":1,"forecast":[{"timestamp":1661320800,"day_name":"Wed","day_temp":[37,98],"owm_day_index":0},{"timestamp":1661385600,"day_name":"Thu","day_temp":[38,100],"owm_day_index":6},{"timestamp":1661472000,"day_name":"Fri","day_temp":[36,98],"owm_day_index":14},{"timestamp":1661558400,"day_name":"Sat","day_temp":[37,99],"owm_day_index":22},{"timestamp":1661644800,"day_name":"Sun","day_temp":[33,92],"owm_day_index":30}]});
});</script> <style media="all">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</style> <script type='text/javascript' id='fvm-delayjs' data-cfasync='false'>!function(k,e,x){function r(d,a,g,b){return b=(a?e.getElementById(a):t)||e.createElement(d||"SCRIPT"),a&&(b.id=a),g&&(b.onload=g),b}function u(d){f(function(a){a=[].slice.call(e.querySelectorAll(d));(function v(b,c){if(b=a.shift()){b.parentNode.removeChild(b);var l=b,m,n=void 0;var p=r(l.nodeName);var q=0;for(m=l.attributes;q<m.length;q++)"type"!=(n=m[q]).name&&p.setAttribute(n.name,n.value);(c=(p.text=l.text,p)).src&&!c.hasAttribute("async")?(c.onload=c.onerror=v,e.head.appendChild(c)):(e.head.appendChild(c),
v())}})()})}var f,t,h=[],w=/p/.test(e.readyState);Function();(f=function(d,a){w?x(d,a):h.push(d,a)}).all=u;f.js=function(d,a,g,b){f(function(c){(c=r(t,a,b)).src=d;e.head.appendChild(c)},g)};k.addEventListener("onpageshow"in k?"pageshow":"load",function(){for(w=!u();h[0];)f(h.shift(),h.shift())});k.Defer=f}(this,document,setTimeout);
const userInteractionEvents=["mouseover","keydown","touchstart","touchmove","wheel"];userInteractionEvents.forEach(function(event){window.addEventListener(event,triggerScriptLoader,{passive:!0})});function triggerScriptLoader(){fvmloadscripts();userInteractionEvents.forEach(function(event){window.removeEventListener(event,triggerScriptLoader,{passive:!0})})}function fvmloadscripts(){Defer.all('script[type="fvm-script-delay"]')};</script> <script>(function(){var js = "window['__CF$cv$params']={r:'73f9fd8ebbe88011',m:'mfdKfrgHOqscSBe1ds_uIopkElvZpYnw5k4cL7P2rVU-1661322114-0-ATPfI9EAv9JMUHfxWyIsh6z1gmjUD/ny7TwuOoWR1NBdJ7mLE+e6r+IhX7ZF4mJMwEoWOJnv880UmwTaPExXI+Uvr/MFp813DjcIt4g2hQWyYQYKMOlcGRFpE3qet+OJkvoZpPx2cpSWFyW0xJBgmq5S0lQLQ5yucc0g3koEks32',s:[0x1dff18ed34,0xcb54de86e4],u:'/cdn-cgi/challenge-platform/h/g'};var now=Date.now()/1000,offset=14400,ts=''+(Math.floor(now)-Math.floor(now%offset)),_cpo=document.createElement('script');_cpo.nonce='',_cpo.src='/cdn-cgi/challenge-platform/h/g/scripts/alpha/invisible.js?ts='+ts,document.getElementsByTagName('head')[0].appendChild(_cpo);";var _0xh = document.createElement('iframe');_0xh.height = 1;_0xh.width = 1;_0xh.style.position = 'absolute';_0xh.style.top = 0;_0xh.style.left = 0;_0xh.style.border = 'none';_0xh.style.visibility = 'hidden';document.body.appendChild(_0xh);function handler() {var _0xi = _0xh.contentDocument || _0xh.contentWindow.document;if (_0xi) {var _0xj = _0xi.createElement('script');_0xj.nonce = '';_0xj.innerHTML = js;_0xi.getElementsByTagName('head')[0].appendChild(_0xj);}}if (document.readyState !== 'loading') {handler();} else if (window.addEventListener) {document.addEventListener('DOMContentLoaded', handler);} else {var prev = document.onreadystatechange || function () {};document.onreadystatechange = function (e) {prev(e);if (document.readyState !== 'loading') {document.onreadystatechange = prev;handler();}};}})();</script><script defer src="https://static.cloudflareinsights.com/beacon.min.js/v652eace1692a40cfa3763df669d7439c1639079717194" integrity="sha512-Gi7xpJR8tSkrpF7aordPZQlW2DLtzUlZcumS8dMQjwDHEnw9I7ZLyiOj/6tZStRBGtGgN6ceN6cMH8z7etPGlw==" data-cf-beacon='{"rayId":"73f9fd8ebbe88011","token":"9639abc27d734ec8b96408e75d059522","version":"2022.8.0","si":100}' crossorigin="anonymous"></script>
</body></html>