<!doctype html > 
<html lang="en-US"> 
<head>
<meta charset="UTF-8" />
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-cssc93e344ec9e7b3fcb4ae77e56a71eb6a1b4dce68e6ae7a0a5491b648fdc14.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-cssec0e45fffe57cbc7f647cab2fa7b7fcddd64e2e7fb84ddf77c226153ee016.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-cssfcf6b6974b9a68414d37d5aff2dffbea0667333f07048c909a8ae00ec34be.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-cssb999e9002efd462c58621e1110733fb9b200823060e2c0c40cf366e1ee301.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-cssa7bf1234c745b1a778081563877bbf1763f8fa450b886c8bcdbf069d8ce44.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css0e1fb593733b4de557e85744af556a617ae1e3d4b4f4d9d44b74b3ff263af.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css89a54f944715a1a6c407de44291e8f32b1e40025446575d4d30a1cfe2551b.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css2ff6189fb8b7929bcfd947da677ef6965dd7e47b71d370f68834bcfa4ea9a.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-cssd607aae37a61cd572f2cb1cd16fc155d3f381c8d5b8495d2f8c1cdfb92bd6.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-cssd68300237f5b26755979a51058c69687d0f2e090c4b0b301d38d5e59a70d2.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css5f04141fd55dd45afcb09292d8d9d89d5e845695a0b50e0df0b2da062a145.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css78ef6846be851a3910e080140ec0b4cef22c99f03804c8334c36c66279410.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css6fcece541908ad1e946007297ccb5fd980c95a8942441a92d21264a1f217a.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css94760df859b56a4549826355d9f49e9c379f99f4c52920526546d1288126e.css" as="style" media="only screen and (max-width: 768px)" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-csse69784554cb137c3ee371b0ba58e22aec067144aeb580c52e09e3a6b3f215.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css7ae43c9cdc5bf2ec622068982fb5841cc359af832b5eac4a4626dc5bc3166.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css6bd3edb9410f51a232a9ccd064cff291c3bd49a1eb5ed0f14836f00d3dcf6.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css6f6576841da27794fc1e864589474a3455dd50b7fd1abe8bd98799d3d8ea8.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-cssee328d8376b4dfdd0b52ff6fc41438ac291e12d5ef4d8d0f71d6773257b56.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css166924482041e66b4ab2b2feefd8f651aec524a974592fa13915e8a11a924.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css271125cb95dbaf41cbbccab990d48125b58a0104c1ef1affef07cfb152174.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-cssbf25e29772fe47ec8054d032b8a529d0370b40e2090ea17f7b808a12880c2.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css3a73980d33860f8ec62c721b34106591130403c017d6e2c25f475f89248c1.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css35a6d8787aaab7e3fc9ae121155a6695ac1089d73635db89491267b00c44a.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css6dc6d5ed6ec53a3a9c6581b0cd477d8dd6a652a13f3d511f9f5a65dc26a74.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css528ce13bbd8be9fb6d9b4b8ce416b5ea8bb7a6b46d77dd77dea68322737df.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css0cb27d222e75e3db900ad4453b5a498ddea7a2fbf03e1024254e8f9a05b35.css" as="style" media="all" />
<script data-cfasync="false">function fvmuag(){var e=navigator.userAgent;if(e.match(/x11.*ox\/54|id\s4.*us.*ome\/62|oobo|ight|tmet|eadl|ngdo|PTST/i))return!1;if(e.match(/x11.*me\/86\.0/i)){var r=screen.width;if("number"==typeof r&&1367==r)return!1}return!0}</script>
<title>Roseville drives Placer County growth ranking among top in California - Roseville Today</title>
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<meta name="description" content="Roseville, Calif.- Businesses know a good investment when they see it. And Placer County continues to draw those businesses, ranking 4th in" />
<link rel="canonical" href="https://www.rosevilletoday.com/news/roseville/roseville-drives-placer-county/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Roseville drives Placer County growth ranking among top in California" />
<meta property="og:description" content="According to recent SmartAsset Study Roseville, Calif.- Businesses know a good investment when they see it. And Placer County continues to draw those" />
<meta property="og:url" content="https://www.rosevilletoday.com/news/roseville/roseville-drives-placer-county/" />
<meta property="og:site_name" content="Roseville Today" />
<meta property="article:publisher" content="https://www.facebook.com/RosevilleToday" />
<meta property="article:published_time" content="2022-02-04T00:32:36+00:00" />
<meta property="article:modified_time" content="2022-02-04T00:34:02+00:00" />
<meta property="og:image" content="https://www.rosevilletoday.com/wp-content/uploads/2022/01/roseville-news.jpg" />
<meta property="og:image:width" content="340" />
<meta property="og:image:height" content="328" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@rrtoday" />
<meta name="twitter:site" content="@rrtoday" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Staff" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="1 minute" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.rosevilletoday.com/#organization","name":"Roseville Today","url":"https://www.rosevilletoday.com/","sameAs":["https://www.facebook.com/RosevilleToday","https://www.instagram.com/rosevilletoday/","https://twitter.com/rrtoday"],"logo":{"@type":"ImageObject","@id":"https://www.rosevilletoday.com/#logo","inLanguage":"en-US","url":"https://www.rosevilletoday.com/wp-content/uploads/2021/04/rt-logo.png","contentUrl":"https://www.rosevilletoday.com/wp-content/uploads/2021/04/rt-logo.png","width":544,"height":180,"caption":"Roseville Today"},"image":{"@id":"https://www.rosevilletoday.com/#logo"}},{"@type":"WebSite","@id":"https://www.rosevilletoday.com/#website","url":"https://www.rosevilletoday.com/","name":"Roseville Today","description":"Business, Travel and Entertainment","publisher":{"@id":"https://www.rosevilletoday.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.rosevilletoday.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.rosevilletoday.com/news/roseville/roseville-drives-placer-county/#primaryimage","inLanguage":"en-US","url":"https://www.rosevilletoday.com/wp-content/uploads/2022/01/roseville-news.jpg","contentUrl":"https://www.rosevilletoday.com/wp-content/uploads/2022/01/roseville-news.jpg","width":340,"height":328,"caption":"Roseville news"},{"@type":"WebPage","@id":"https://www.rosevilletoday.com/news/roseville/roseville-drives-placer-county/#webpage","url":"https://www.rosevilletoday.com/news/roseville/roseville-drives-placer-county/","name":"Roseville drives Placer County growth ranking among top in California - Roseville Today","isPartOf":{"@id":"https://www.rosevilletoday.com/#website"},"primaryImageOfPage":{"@id":"https://www.rosevilletoday.com/news/roseville/roseville-drives-placer-county/#primaryimage"},"datePublished":"2022-02-04T00:32:36+00:00","dateModified":"2022-02-04T00:34:02+00:00","description":"Roseville, Calif.- Businesses know a good investment when they see it. And Placer County continues to draw those businesses, ranking 4th in","breadcrumb":{"@id":"https://www.rosevilletoday.com/news/roseville/roseville-drives-placer-county/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.rosevilletoday.com/news/roseville/roseville-drives-placer-county/"]}]},{"@type":"BreadcrumbList","@id":"https://www.rosevilletoday.com/news/roseville/roseville-drives-placer-county/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.rosevilletoday.com/"},{"@type":"ListItem","position":2,"name":"News","item":"https://www.rosevilletoday.com/news/"},{"@type":"ListItem","position":3,"name":"Roseville News","item":"https://www.rosevilletoday.com/news/roseville/"},{"@type":"ListItem","position":4,"name":"Roseville drives Placer County growth ranking among top in California"}]},{"@type":"Article","@id":"https://www.rosevilletoday.com/news/roseville/roseville-drives-placer-county/#article","isPartOf":{"@id":"https://www.rosevilletoday.com/news/roseville/roseville-drives-placer-county/#webpage"},"author":{"@id":"https://www.rosevilletoday.com/#/schema/person/bf27b0f4159cee1e3a0c12604ba793af"},"headline":"Roseville drives Placer County growth ranking among top in California","datePublished":"2022-02-04T00:32:36+00:00","dateModified":"2022-02-04T00:34:02+00:00","mainEntityOfPage":{"@id":"https://www.rosevilletoday.com/news/roseville/roseville-drives-placer-county/#webpage"},"wordCount":145,"publisher":{"@id":"https://www.rosevilletoday.com/#organization"},"image":{"@id":"https://www.rosevilletoday.com/news/roseville/roseville-drives-placer-county/#primaryimage"},"thumbnailUrl":"https://www.rosevilletoday.com/wp-content/uploads/2022/01/roseville-news.jpg","articleSection":["Roseville News"],"inLanguage":"en-US"},{"@type":"Person","@id":"https://www.rosevilletoday.com/#/schema/person/bf27b0f4159cee1e3a0c12604ba793af","name":"Staff","description":"Staff posts at Rocklin &amp; Roseville Today include original content and a variety of sources respected and authoritative 3rd party sources. Please use the contact link at the bottom of this page for inquiries and corrections. Roseville, CA News and Local Updates","url":"https://www.rosevilletoday.com/author/staff/"}]}</script>
<link rel="alternate" type="application/rss+xml" title="Roseville Today &raquo; Feed" href="https://www.rosevilletoday.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Roseville Today &raquo; Comments Feed" href="https://www.rosevilletoday.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Roseville Today &raquo; iCal Feed" href="https://www.rosevilletoday.com/events/?ical=1" />
<meta name="et-api-version" content="v1">
<meta name="et-api-origin" content="https://www.rosevilletoday.com">
<meta name="tec-api-version" content="v1">
<meta name="tec-api-origin" content="https://www.rosevilletoday.com">
<script type="application/ld+json">{
"@context": "http://schema.org",
"@type": "BreadcrumbList",
"itemListElement": [
{
"@type": "ListItem",
"position": 1,
"item": {
"@type": "WebSite",
"@id": "https://www.rosevilletoday.com/",
"name": "Home"
}
},
{
"@type": "ListItem",
"position": 2,
"item": {
"@type": "WebPage",
"@id": "https://www.rosevilletoday.com/news/",
"name": "News"
}
}
,{
"@type": "ListItem",
"position": 3,
"item": {
"@type": "WebPage",
"@id": "https://www.rosevilletoday.com/news/roseville/",
"name": "Roseville News"                                
}
}
,{
"@type": "ListItem",
"position": 4,
"item": {
"@type": "WebPage",
"@id": "https://www.rosevilletoday.com/news/roseville/roseville-drives-placer-county/",
"name": "Roseville drives Placer County growth ranking among top in California"                                
}
}    
]
}</script>
<link rel="icon" type="image/png" href="https://www.rosevilletoday.com/wp-content/uploads/2021/12/favicon.jpg"> 
<script id="rosev-ready">
window.advanced_ads_ready=function(e,a){a=a||"complete";var d=function(e){return"interactive"===a?"loading"!==e:"complete"===e};d(document.readyState)?e():document.addEventListener("readystatechange",(function(a){d(a.target.readyState)&&e()}),{once:"interactive"===a})},window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[];		</script>
<link rel='stylesheet' id='tec-variables-full-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-cssc93e344ec9e7b3fcb4ae77e56a71eb6a1b4dce68e6ae7a0a5491b648fdc14.css' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-cssec0e45fffe57cbc7f647cab2fa7b7fcddd64e2e7fb84ddf77c226153ee016.css' type='text/css' media='all' />
<link rel='stylesheet' id='event-tickets-plus-tickets-css-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-cssfcf6b6974b9a68414d37d5aff2dffbea0667333f07048c909a8ae00ec34be.css' type='text/css' media='all' />
<link rel='stylesheet' id='tec-variables-skeleton-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-cssb999e9002efd462c58621e1110733fb9b200823060e2c0c40cf366e1ee301.css' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-common-skeleton-style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-cssa7bf1234c745b1a778081563877bbf1763f8fa450b886c8bcdbf069d8ce44.css' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-common-full-style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css0e1fb593733b4de557e85744af556a617ae1e3d4b4f4d9d44b74b3ff263af.css' type='text/css' media='all' />
<link rel='stylesheet' id='event-tickets-tickets-css-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css89a54f944715a1a6c407de44291e8f32b1e40025446575d4d30a1cfe2551b.css' type='text/css' media='all' />
<link rel='stylesheet' id='event-tickets-tickets-rsvp-css-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css2ff6189fb8b7929bcfd947da677ef6965dd7e47b71d370f68834bcfa4ea9a.css' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-pro-mini-calendar-block-styles-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-cssd607aae37a61cd572f2cb1cd16fc155d3f381c8d5b8495d2f8c1cdfb92bd6.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-cssd68300237f5b26755979a51058c69687d0f2e090c4b0b301d38d5e59a70d2.css' type='text/css' media='all' />
<link rel='stylesheet' id='wc-blocks-vendors-style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css5f04141fd55dd45afcb09292d8d9d89d5e845695a0b50e0df0b2da062a145.css' type='text/css' media='all' />
<link rel='stylesheet' id='wc-blocks-style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css78ef6846be851a3910e080140ec0b4cef22c99f03804c8334c36c66279410.css' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css' media="all">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</style>
<link rel='stylesheet' id='woocommerce-layout-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css6fcece541908ad1e946007297ccb5fd980c95a8942441a92d21264a1f217a.css' type='text/css' media='all' />
<link rel='stylesheet' id='woocommerce-smallscreen-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css94760df859b56a4549826355d9f49e9c379f99f4c52920526546d1288126e.css' type='text/css' media='only screen and (max-width: 768px)' />
<link rel='stylesheet' id='woocommerce-general-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-csse69784554cb137c3ee371b0ba58e22aec067144aeb580c52e09e3a6b3f215.css' type='text/css' media='all' />
<style id='woocommerce-inline-inline-css' type='text/css' media="all">.woocommerce form .form-row .required{visibility:visible}</style>
<link rel='stylesheet' id='wp_automatic_gallery_style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css7ae43c9cdc5bf2ec622068982fb5841cc359af832b5eac4a4626dc5bc3166.css' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css6bd3edb9410f51a232a9ccd064cff291c3bd49a1eb5ed0f14836f00d3dcf6.css' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='google-fonts-style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css6f6576841da27794fc1e864589474a3455dd50b7fd1abe8bd98799d3d8ea8.css' type='text/css' media='all' />
<link rel='stylesheet' id='event-tickets-rsvp-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-cssee328d8376b4dfdd0b52ff6fc41438ac291e12d5ef4d8d0f71d6773257b56.css' type='text/css' media='all' />
<link rel='stylesheet' id='event-tickets-tpp-css-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css166924482041e66b4ab2b2feefd8f651aec524a974592fa13915e8a11a924.css' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css271125cb95dbaf41cbbccab990d48125b58a0104c1ef1affef07cfb152174.css' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css' media="all">@media (max-width:767px){.td-header-desktop-wrap{display:none}}@media (min-width:767px){.td-header-mobile-wrap{display:none}}</style>
<link rel='stylesheet' id='td-theme-woo-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-cssbf25e29772fe47ec8054d032b8a529d0370b40e2090ea17f7b808a12880c2.css' type='text/css' media='all' />
<link rel='stylesheet' id='TribeEventsWooTickets-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css3a73980d33860f8ec62c721b34106591130403c017d6e2c25f475f89248c1.css' type='text/css' media='all' />
<link rel='stylesheet' id='td-legacy-framework-front-style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css35a6d8787aaab7e3fc9ae121155a6695ac1089d73635db89491267b00c44a.css' type='text/css' media='all' />
<link rel='stylesheet' id='td-legacy-framework-woo-style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css6dc6d5ed6ec53a3a9c6581b0cd477d8dd6a652a13f3d511f9f5a65dc26a74.css' type='text/css' media='all' />
<link rel='stylesheet' id='td-standard-pack-framework-front-style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css528ce13bbd8be9fb6d9b4b8ce416b5ea8bb7a6b46d77dd77dea68322737df.css' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1643820220-css0cb27d222e75e3db900ad4453b5a498ddea7a2fbf03e1024254e8f9a05b35.css' type='text/css' media='all' /> 
<script async='async' src='https://www.rosevilletoday.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/event-tickets/common/src/resources/js/underscore-before.js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-includes/js/underscore.min.js?ver=1.13.1' id='underscore-js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/event-tickets/common/src/resources/js/underscore-after.js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-includes/js/wp-util.js?ver=5.9' id='wp-util-not-in-footer-js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/wp-automatic/js/main-front.js?ver=5.9' id='wp_automatic_gallery-js'></script>
<script>window.tdb_globals = {"wpRestNonce":"a3b237fb0e","wpRestUrl":"https:\/\/www.rosevilletoday.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};</script>
<style media="all">:root{--accent-color:#fff}</style> 
<script>window.tdwGlobal = {"adminUrl":"https:\/\/www.rosevilletoday.com\/wp-admin\/","wpRestNonce":"a3b237fb0e","wpRestUrl":"https:\/\/www.rosevilletoday.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/"};</script>
<script>window.tdaGlobal = {"adminUrl":"https:\/\/www.rosevilletoday.com\/wp-admin\/","wpRestNonce":"a3b237fb0e","wpRestUrl":"https:\/\/www.rosevilletoday.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/","postId":68934};</script>
<noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
<link rel="amphtml" href="https://www.rosevilletoday.com/news/roseville/roseville-drives-placer-county/?amp">
<script  src='https://www.googletagservices.com/tag/js/gpt.js' async></script>
<script>var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];</script>
<script>googletag.cmd.push(function() {
googletag.defineSlot('/1027827/300x250', [[300, 250], [336, 280]], 'div-gpt-ad-1526924072370-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});</script>
<script>var tdBlocksArray = []; //here we store all the items for the current page
//td_block class - each ajax block uses a object of this class for requests
function tdBlock() {
this.id = '';
this.block_type = 1; //block type id (1-234 etc)
this.atts = '';
this.td_column_number = '';
this.td_current_page = 1; //
this.post_count = 0; //from wp
this.found_posts = 0; //from wp
this.max_num_pages = 0; //from wp
this.td_filter_value = ''; //current live filter value
this.is_ajax_running = false;
this.td_user_action = ''; // load more or infinite loader (used by the animation)
this.header_color = '';
this.ajax_pagination_infinite_stop = ''; //show load more at page x
}
// td_js_generator - mini detector
(function(){
var htmlTag = document.getElementsByTagName("html")[0];
if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
htmlTag.className += ' ie10';
}
if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
htmlTag.className += ' ie11';
}
if ( navigator.userAgent.indexOf("Edge") > -1 ) {
htmlTag.className += ' ieEdge';
}
if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
htmlTag.className += ' td-md-is-ios';
}
var user_agent = navigator.userAgent.toLowerCase();
if ( user_agent.indexOf("android") > -1 ) {
htmlTag.className += ' td-md-is-android';
}
if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
htmlTag.className += ' td-md-is-os-x';
}
if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
htmlTag.className += ' td-md-is-chrome';
}
if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
htmlTag.className += ' td-md-is-firefox';
}
if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
htmlTag.className += ' td-md-is-safari';
}
if( -1 !== navigator.userAgent.indexOf('IEMobile') ){
htmlTag.className += ' td-md-is-iemobile';
}
})();
var tdLocalCache = {};
( function () {
"use strict";
tdLocalCache = {
data: {},
remove: function (resource_id) {
delete tdLocalCache.data[resource_id];
},
exist: function (resource_id) {
return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
},
get: function (resource_id) {
return tdLocalCache.data[resource_id];
},
set: function (resource_id, cachedData) {
tdLocalCache.remove(resource_id);
tdLocalCache.data[resource_id] = cachedData;
}
};
})();
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var tdc_is_installed="yes";
var td_ajax_url="https:\/\/www.rosevilletoday.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=11.4";
var td_get_template_directory_uri="https:\/\/www.rosevilletoday.com\/wp-content\/plugins\/td-composer\/legacy\/common";
var tds_snap_menu="smart_snap_always";
var tds_logo_on_sticky="show";
var tds_header_style="3";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var td_user_incorrect="Username incorrect!";
var td_email_user_empty="Email or username empty!";
var td_pass_empty="Pass empty!";
var td_pass_pattern_incorrect="Invalid Pass Pattern!";
var td_retype_pass_incorrect="Retyped Pass incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#02355a";
var tds_smart_sidebar="";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var tdBlockNonce="9973c29aa3";
var tdDateNamesI18n={"month_names":["January","February","March","April","May","June","July","August","September","October","November","December"],"month_names_short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"day_names":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"day_names_short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]};
var td_ad_background_click_link="";
var td_ad_background_click_target="";</script>
<script data-ad-client="ca-pub-5649489283520750" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script async src="https://www.googletagmanager.com/gtag/js?id=G-1069ECQ8NK"></script>
<script>window.dataLayer = window.dataLayer || [];
function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'G-1069ECQ8NK');</script>
<style type="text/css" id="wp-custom-css" media="all">div.tribe-events-single-event-recurrence-description{visibility:hidden;display:none}.td-author-counters{display:none}td{vertical-align:top!important}#yplink li a{color:#0f4c81}.tribe-events-widget-events-list{font-size:12px;border-radius:12px;background-color:#fafaf7}.td-visible-desktop{background-color:#fff}.td-visible-tablet-landscape{background-color:#fff}.td-visible-tablet-portrait{background-color:#fff}.td-visible-phone{background-color:#b5d2f6;border-radius:6px}.sponsor-ad{padding:12px}h2.tribe-events-widget-events-list__header-title{font-weight:700;font-size:1.8em;color:#004e7e;position:relative;left:75px;left:100px}h3.tribe-events-widget-events-list__event-title{font-size:1.5em}a.yps{color:#1b2880;font-size:15px;color:#333}a.tribe-events-widget-events-list__view-more-link{padding-left:60px;font-weight:700;font-size:1.1em;position:relative;left:75px;position:relative;left:50px}.tribe-events-widget-events-list__event-datetime-wrapper{display:none}.tribe-events-widget-events-list__event-date-tag{font-weight:700;color:#343f47}.rss-widget-icon{display:none}a.rsswidget{color:#ffa128;font-weight:700;font-size:.9em;font-family:sans-serif,Arial}.rsswidget:link{color:#012e81;color:#333}.rsswidget:visited{color:#00276e}.tribe-events-notices{background-color:#ffc780;color:#000;font-weight:700;font-size:1.4em}.imgpad{padding-right:15px}#showcase{width:345px;height:auto}.tribe-events-calendar-list__event-row--featured{background-color:#e7e7e5;border-radius:8px}</style>
<style media="all">.tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,.tds-button2 .tdm-btn-text,.tds-button2 i,.tds-button5:hover .tdm-btn-text,.tds-button5:hover i,.tds-button6 .tdm-btn-text,.tds-button6 i,.tdm_block_list .tdm-list-item i,.tdm_block_pricing .tdm-pricing-feature i,body .tdm-social-item i{color:#02355a}.tds-button1,.tds-button6:after,.tds-title2 .tdm-title-line:after,.tds-title3 .tdm-title-line:after,.tdm_block_pricing.tdm-pricing-featured:before,.tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,.tds-progress-bar1 .tdm-progress-bar:after,.tds-progress-bar2 .tdm-progress-bar:after,.tds-social3 .tdm-social-item{background-color:#02355a}.tds-button2:before,.tds-button6:before,.tds-progress-bar3 .tdm-progress-bar:after{border-color:#02355a}.tdm-btn-style1{background-color:#02355a}.tdm-btn-style2:before{border-color:#02355a}.tdm-btn-style2{color:#02355a}.tdm-btn-style3{-webkit-box-shadow:0 2px 16px #02355a;-moz-box-shadow:0 2px 16px #02355a;box-shadow:0 2px 16px #02355a}.tdm-btn-style3:hover{-webkit-box-shadow:0 4px 26px #02355a;-moz-box-shadow:0 4px 26px #02355a;box-shadow:0 4px 26px #02355a}</style>
<script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head>
<body class="post-template-default single single-post postid-68934 single-format-standard theme-Newspaper td-standard-pack woocommerce-no-js tribe-no-js page-template-www-rrtoday_609-public-wp-content-themes-newspaper-page-php tribe-theme-Newspaper roseville-drives-placer-county global-block-template-11 td-local-news single_template_2 aa-prefix-rosev- td-boxed-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage"> <div class="td-scroll-up td-hide-scroll-up-on-mob" style="display:none;"><i class="td-icon-menu-up"></i></div><div class="td-menu-background"></div><div id="td-mobile-nav"><div class="td-mobile-container"><div class="td-menu-socials-wrap"><div class="td-menu-socials"> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/RosevilleToday" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.instagram.com/rosevilletoday/" title="Instagram"> <i class="td-icon-font td-icon-instagram"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.rosevilletoday.com/news/feed/" title="RSS"> <i class="td-icon-font td-icon-rss"></i> </a> </span></div><div class="td-mobile-close"> <a href="#" aria-label="Close"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-mobile-content"><div class="menu-td-demo-header-menu-container"><ul id="menu-td-demo-header-menu" class="td-mobile-main-menu"><li id="menu-item-168" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first menu-item-168"><a href="https://www.rosevilletoday.com/">Home</a></li><li id="menu-item-173" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-173"><a href="/news/">Local news<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-175" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-175"><a href="/news/roseville/">Roseville</a></li><li id="menu-item-54118" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54118"><a href="https://www.rosevilletoday.com/yp/business-news/">Business News</a></li><li id="menu-item-174" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-174"><a href="/news/rocklin/">Rocklin</a></li><li id="menu-item-46156" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-46156"><a href="https://www.rosevilletoday.com/news/lincoln/">Lincoln</a></li><li id="menu-item-33550" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33550"><a href="https://www.rosevilletoday.com/news/auburn/">Auburn</a></li><li id="menu-item-50887" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50887"><a href="https://www.rosevilletoday.com/news/folsom/">Folsom</a></li><li id="menu-item-176" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-176"><a href="/news/sacramento/">Sacramento</a></li><li id="menu-item-48015" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48015"><a href="https://www.rosevilletoday.com/press-releases/">California News</a></li><li id="menu-item-42480" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42480"><a href="https://www.rosevilletoday.com/tag/coronavirus/">Covid-19 Updates</a></li><li id="menu-item-57252" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57252"><a href="https://www.rosevilletoday.com/news/roseville/californias-10-largest-reservoirs-drought-status/">Reservoir Levels</a></li></ul></li><li id="menu-item-17466" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-17466"><a href="https://www.rosevilletoday.com/yp/">Yellow Pages<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-66414" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-66414"><a href="https://www.rosevilletoday.com/news/roseville/roseville-weekly-business-updates/">Weekly Business Updates</a></li><li id="menu-item-54119" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54119"><a href="https://www.rosevilletoday.com/yp/business/">Business</a></li><li id="menu-item-54120" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54120"><a href="https://www.rosevilletoday.com/yp/community/">Community</a></li><li id="menu-item-54121" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54121"><a href="https://www.rosevilletoday.com/yp/health-fitness/">Health &#038; Fitness</a></li><li id="menu-item-54122" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54122"><a href="https://www.rosevilletoday.com/yp/home-improvement/">Home Improvement</a></li><li id="menu-item-54123" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54123"><a href="https://www.rosevilletoday.com/yp/real-estate/">Real Estate</a></li><li id="menu-item-54124" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54124"><a href="https://www.rosevilletoday.com/yp/restaurants/">Restaurants</a></li></ul></li><li id="menu-item-233" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-233"><a href="/travel/">Travel<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-30808" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30808"><a href="https://www.rosevilletoday.com/author/todd-schofield/">Travel Reviews</a></li><li id="menu-item-28186" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28186"><a href="https://www.rosevilletoday.com/travel/bay-area/">Bay Area</a></li><li id="menu-item-26018" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26018"><a href="https://www.rosevilletoday.com/travel/lake-tahoe/">Lake Tahoe &#8211; Reno</a></li><li id="menu-item-26019" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26019"><a href="https://www.rosevilletoday.com/travel/monterey-carmel/">Monterey and Carmel</a></li><li id="menu-item-26020" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26020"><a href="https://www.rosevilletoday.com/travel/napa-valley/">Napa Valley</a></li><li id="menu-item-26022" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26022"><a href="https://www.rosevilletoday.com/travel/palm-springs/">Palm Springs Area</a></li><li id="menu-item-230" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-230"><a href="/travel/local-travel/">Placer / El Dorado / Sacramento</a></li><li id="menu-item-26021" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26021"><a href="https://www.rosevilletoday.com/travel/sonoma/">Sonoma County</a></li></ul></li><li id="menu-item-234" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-234"><a href="/columns/">Columns<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-29512" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29512"><a href="https://www.rosevilletoday.com/news/sacramento/laws/">New Laws 2022</a></li><li id="menu-item-30989" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30989"><a href="https://www.rosevilletoday.com/author/todd-schofield/">Travel &#038; Music</a></li><li id="menu-item-235" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-235"><a href="/columns/real-estate/">Real Estate</a></li><li id="menu-item-236" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-236"><a href="/columns/natural-wellness/">Natural Medicine</a></li><li id="menu-item-47565" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47565"><a href="https://www.rosevilletoday.com/tag/roseville-city-school-district/">Roseville City School District</a></li><li id="menu-item-47564" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47564"><a href="https://www.rosevilletoday.com/tag/roseville-joint-union-high-school-district/">Roseville Joint Union HSD</a></li><li id="menu-item-3876" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3876"><a href="/columns/car-reviews/">Weidel on Wheels</a></li><li id="menu-item-48314" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48314"><a href="https://www.rosevilletoday.com/tag/roseville-safety-first/">Roseville Safety Tips</a></li><li id="menu-item-48238" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48238"><a href="https://www.rosevilletoday.com/tag/hiking/">Hiking</a></li><li id="menu-item-48207" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48207"><a href="https://www.rosevilletoday.com/tag/rocklin-history-tour/">Rocklin History Tour</a></li><li id="menu-item-6022" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6022"><a href="/columns/disabilities">Disabilities</a></li></ul></li><li id="menu-item-13241" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-13241"><a href="/events/">Events<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-26702" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26702"><a href="/events/">View All Events</a></li><li id="menu-item-26703" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26703"><a href="https://www.rosevilletoday.com/product/single-event-listing-highlight/">+ ADD Your Event</a></li></ul></li><li id="menu-item-232" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-232"><a href="/music/">Music<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-238" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-238"><a href="/music/concert-venues/">Concert Schedules</a></li><li id="menu-item-29889" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29889"><a href="https://www.rosevilletoday.com/music/festivals/">Music Festivals</a></li><li id="menu-item-240" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-240"><a href="/music/music-reviews/">Music Reviews</a></li><li id="menu-item-68750" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-68750"><a href="https://www.rosevilletoday.com/news/roseville/pandora-spotify-youtube-music-compared/">Streaming Compared</a></li><li id="menu-item-11101" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11101"><a href="/music/grateful-dead-50/">Grateful Dead- 50 Days</a></li></ul></li></ul></div></div></div></div><div class="td-search-background"></div><div class="td-search-wrap-mob"><div class="td-drop-down-search"><form method="get" class="td-search-form" action="https://www.rosevilletoday.com/"><div class="td-search-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div><div role="search" class="td-search-input"> <span>Search</span> <input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" /></div></form><div id="td-aj-search-mob" class="td-ajax-search-flex"></div></div></div><div id="td-outer-wrap" class="td-theme-wrap"><div class="tdc-header-wrap"><div class="td-header-wrap td-header-style-3"><div class="td-header-top-menu-full td-container-wrap"><div class="td-container td-header-row td-header-top-menu"><div class="top-bar-style-2"><div class="td-header-sp-top-widget"> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/RosevilleToday" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.instagram.com/rosevilletoday/" title="Instagram"> <i class="td-icon-font td-icon-instagram"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.rosevilletoday.com/news/feed/" title="RSS"> <i class="td-icon-font td-icon-rss"></i> </a> </span></div><div class="td-header-sp-top-menu"><div class="td_data_time"><div > Thursday, February 3, 2022</div></div></div></div><div id="login-form" class="white-popup-block mfp-hide mfp-with-anim"><div class="td-login-wrap"> <a href="#" aria-label="Back" class="td-back-button"><i class="td-icon-modal-back"></i></a><div id="td-login-div" class="td-login-form-div td-display-block"><div class="td-login-panel-title">Sign in</div><div class="td-login-panel-descr">Welcome! Log into your account</div><div class="td_display_err"></div><form id="loginForm" action="#" method="post"><div class="td-login-inputs"><input class="td-login-input" autocomplete="username" type="text" name="login_email" id="login_email" value="" required><label for="login_email">your username</label></div><div class="td-login-inputs"><input class="td-login-input" autocomplete="current-password" type="password" name="login_pass" id="login_pass" value="" required><label for="login_pass">your password</label></div> <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login"></form><div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div><div class="td-login-info-text"><a class="privacy-policy-link" href="https://www.rosevilletoday.com/privacy-policy/">Privacy Policy</a></div></div><div id="td-forgot-pass-div" class="td-login-form-div td-display-none"><div class="td-login-panel-title">Password recovery</div><div class="td-login-panel-descr">Recover your password</div><div class="td_display_err"></div><form id="forgotpassForm" action="#" method="post"><div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label for="forgot_email">your email</label></div> <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password"></form><div class="td-login-info-text">A password will be e-mailed to you.</div></div></div></div></div></div><div class="td-banner-wrap-full td-container-wrap"><div class="td-container td-header-row td-header-header"><div class="td-header-sp-logo"> <a class="td-main-logo" href="https://www.rosevilletoday.com/"> <img class="td-retina-data" data-retina="https://www.rosevilletoday.com/wp-content/uploads/2021/03/retina-logo-blue.png" src="https://www.rosevilletoday.com/wp-content/uploads/2021/06/logo-blue2.png" alt="Rocklin & Roseville Today" width="272" height="90"/> <span class="td-visual-hidden">Roseville Today</span> </a></div><div class="td-header-sp-recs"><div class="td-header-rec-wrap"><div class="td-a-rec td-a-rec-id-header td-rec-hide-on-tp td-rec-hide-on-p tdi_1 td_block_template_11">
<style media="all">.tdi_1.td-a-rec{text-align:center}.tdi_1 .td-element-style{z-index:-1}.tdi_1.td-a-rec-img{text-align:left}.tdi_1.td-a-rec-img img{margin:0 auto 0 0}@media (max-width:767px){.tdi_1.td-a-rec-img{text-align:center}}</style><div class="td-all-devices"><a href="https://www.rosevilletoday.com/advertise/"><img width="728" height="90" alt="Roseville Today" src="https://www.rosevilletoday.com/_img/roseville-leaderboard.jpg"/></a></div></div></div></div></div></div><div class="td-header-menu-wrap-full td-container-wrap"><div class="td-header-menu-wrap"><div class="td-container td-header-row td-header-main-menu black-menu"><div id="td-header-menu" role="navigation"><div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div><div class="td-main-menu-logo td-logo-in-header"> <a class="td-main-logo" href="https://www.rosevilletoday.com/"> <img class="td-retina-data" data-retina="https://www.rosevilletoday.com/wp-content/uploads/2021/03/retina-logo-blue.png" src="https://www.rosevilletoday.com/wp-content/uploads/2021/06/logo-blue2.png" alt="Rocklin & Roseville Today" width="272" height="90"/> </a></div><div class="menu-td-demo-header-menu-container"><ul id="menu-td-demo-header-menu-1" class="sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-168"><a href="https://www.rosevilletoday.com/">Home</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-173"><a href="/news/">Local news</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-175"><a href="/news/roseville/">Roseville</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-54118"><a href="https://www.rosevilletoday.com/yp/business-news/">Business News</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-174"><a href="/news/rocklin/">Rocklin</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-46156"><a href="https://www.rosevilletoday.com/news/lincoln/">Lincoln</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-33550"><a href="https://www.rosevilletoday.com/news/auburn/">Auburn</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-50887"><a href="https://www.rosevilletoday.com/news/folsom/">Folsom</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-176"><a href="/news/sacramento/">Sacramento</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-48015"><a href="https://www.rosevilletoday.com/press-releases/">California News</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-42480"><a href="https://www.rosevilletoday.com/tag/coronavirus/">Covid-19 Updates</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-57252"><a href="https://www.rosevilletoday.com/news/roseville/californias-10-largest-reservoirs-drought-status/">Reservoir Levels</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-17466"><a href="https://www.rosevilletoday.com/yp/">Yellow Pages</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-66414"><a href="https://www.rosevilletoday.com/news/roseville/roseville-weekly-business-updates/">Weekly Business Updates</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-54119"><a href="https://www.rosevilletoday.com/yp/business/">Business</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-54120"><a href="https://www.rosevilletoday.com/yp/community/">Community</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-54121"><a href="https://www.rosevilletoday.com/yp/health-fitness/">Health &#038; Fitness</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-54122"><a href="https://www.rosevilletoday.com/yp/home-improvement/">Home Improvement</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-54123"><a href="https://www.rosevilletoday.com/yp/real-estate/">Real Estate</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-54124"><a href="https://www.rosevilletoday.com/yp/restaurants/">Restaurants</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-233"><a href="/travel/">Travel</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-30808"><a href="https://www.rosevilletoday.com/author/todd-schofield/">Travel Reviews</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-28186"><a href="https://www.rosevilletoday.com/travel/bay-area/">Bay Area</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-26018"><a href="https://www.rosevilletoday.com/travel/lake-tahoe/">Lake Tahoe &#8211; Reno</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-26019"><a href="https://www.rosevilletoday.com/travel/monterey-carmel/">Monterey and Carmel</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-26020"><a href="https://www.rosevilletoday.com/travel/napa-valley/">Napa Valley</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-26022"><a href="https://www.rosevilletoday.com/travel/palm-springs/">Palm Springs Area</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-230"><a href="/travel/local-travel/">Placer / El Dorado / Sacramento</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-26021"><a href="https://www.rosevilletoday.com/travel/sonoma/">Sonoma County</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-234"><a href="/columns/">Columns</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-29512"><a href="https://www.rosevilletoday.com/news/sacramento/laws/">New Laws 2022</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-30989"><a href="https://www.rosevilletoday.com/author/todd-schofield/">Travel &#038; Music</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-235"><a href="/columns/real-estate/">Real Estate</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-236"><a href="/columns/natural-wellness/">Natural Medicine</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-47565"><a href="https://www.rosevilletoday.com/tag/roseville-city-school-district/">Roseville City School District</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-47564"><a href="https://www.rosevilletoday.com/tag/roseville-joint-union-high-school-district/">Roseville Joint Union HSD</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3876"><a href="/columns/car-reviews/">Weidel on Wheels</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-48314"><a href="https://www.rosevilletoday.com/tag/roseville-safety-first/">Roseville Safety Tips</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-48238"><a href="https://www.rosevilletoday.com/tag/hiking/">Hiking</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-48207"><a href="https://www.rosevilletoday.com/tag/rocklin-history-tour/">Rocklin History Tour</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6022"><a href="/columns/disabilities">Disabilities</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-13241"><a href="/events/">Events</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-26702"><a href="/events/">View All Events</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-26703"><a href="https://www.rosevilletoday.com/product/single-event-listing-highlight/">+ ADD Your Event</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-232"><a href="/music/">Music</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-238"><a href="/music/concert-venues/">Concert Schedules</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-29889"><a href="https://www.rosevilletoday.com/music/festivals/">Music Festivals</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-240"><a href="/music/music-reviews/">Music Reviews</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-68750"><a href="https://www.rosevilletoday.com/news/roseville/pandora-spotify-youtube-music-compared/">Streaming Compared</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-11101"><a href="/music/grateful-dead-50/">Grateful Dead- 50 Days</a></li></ul></li></ul></div></div><div class="header-search-wrap"><div class="td-search-btns-wrap"> <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle" data-toggle="dropdown"><i class="td-icon-search"></i></a> <a id="td-header-search-button-mob" href="#" class="dropdown-toggle" data-toggle="dropdown"><i class="td-icon-search"></i></a></div><div class="td-drop-down-search" aria-labelledby="td-header-search-button"><form method="get" class="td-search-form" action="https://www.rosevilletoday.com/"><div role="search" class="td-head-form-search-wrap"> <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" /></div></form><div id="td-aj-search"></div></div></div></div></div></div></div></div><div class="td-main-content-wrap td-container-wrap"><div class="td-container td-post-template-2"><article id="post-68934" class="post-68934 post type-post status-publish format-standard has-post-thumbnail category-roseville" itemscope itemtype="https://schema.org/Article"><div class="td-pb-row"><div class="td-pb-span12"><div class="td-post-header"><div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://www.rosevilletoday.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in News" class="entry-crumb" href="https://www.rosevilletoday.com/news/">News</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Roseville News" class="entry-crumb" href="https://www.rosevilletoday.com/news/roseville/">Roseville News</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Roseville drives Placer County growth ranking among top in California</span></div></div><ul class="td-category"><li class="entry-category"><a style="background-color:#d44206; color:#fff; border-color:#d44206;" href="https://www.rosevilletoday.com/news/">News</a></li><li class="entry-category"><a style="background-color:#03749c; color:#fff; border-color:#03749c;" href="https://www.rosevilletoday.com/news/roseville/">Roseville News</a></li></ul><header class="td-post-title"><h1 class="entry-title">Roseville drives Placer County growth ranking among top in California</h1><div class="td-module-meta-info"><div class="td-post-author-name"><div class="td-author-by">▶</div> <a href="https://www.rosevilletoday.com/author/staff/">Staff</a><div class="td-author-line"> -</div></div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-02-03T16:32:36-08:00" >February 3, 2022</time></span></div></header></div></div></div><div class="td-pb-row"><div class="td-pb-span8 td-main-content" role="main"><div class="td-ss-main-content"><div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-border td-ps-border-grey td-ps-notext td-ps-icon-color td-ps-text-color td-post-sharing-style16">
<style media="all">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</style><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text"><div class="td-social-but-icon"><i class="td-icon-share"></i></div><div class="td-social-but-text">Share</div></div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.rosevilletoday.com%2Fnews%2Froseville%2Froseville-drives-placer-county%2F" title="Facebook" ><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Roseville+drives+Placer+County+growth+ranking+among+top+in+California&url=https%3A%2F%2Fwww.rosevilletoday.com%2Fnews%2Froseville%2Froseville-drives-placer-county%2F&via=rrtoday" title="Twitter" ><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://www.rosevilletoday.com/news/roseville/roseville-drives-placer-county/&title=Roseville+drives+Placer+County+growth+ranking+among+top+in+California" title="Linkedin" ><div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div><div class="td-social-but-text">Linkedin</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#a699d5d3c4ccc3c5d29bf4c9d5c3d0cfcacac386c2d4cfd0c3d586f6cac7c5c3d486e5c9d3c8d2df86c1d4c9d1d2ce86d4c7c8cdcfc8c186c7cbc9c8c186d2c9d686cfc886e5c7cacfc0c9d4c8cfc780c4c9c2df9bced2d2d6d59c8989d1d1d188d4c9d5c3d0cfcacac3d2c9c2c7df88c5c9cb89c8c3d1d589d4c9d5c3d0cfcacac389d4c9d5c3d0cfcacac38bc2d4cfd0c3d58bd6cac7c5c3d48bc5c9d3c8d2df89" title="Email"><div class="td-social-but-icon"><i class="td-icon-mail"></i></div><div class="td-social-but-text">Email</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#" title="Print" ><div class="td-social-but-icon"><i class="td-icon-print"></i></div><div class="td-social-but-text">Print</div> </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top" title="More"><div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div> </a></div></div></div><div class="td-post-content tagdiv-type"><div class="td-post-featured-image"><a href="https://www.rosevilletoday.com/wp-content/uploads/2022/01/roseville-news.jpg" data-caption=""><img width="340" height="328" class="entry-thumb td-modal-image" src="https://www.rosevilletoday.com/wp-content/uploads/2022/01/roseville-news.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/01/roseville-news.jpg 340w, https://www.rosevilletoday.com/wp-content/uploads/2022/01/roseville-news-300x289.jpg 300w" sizes="(max-width: 340px) 100vw, 340px" alt="Roseville news" title="roseville-news"/></a></div><div class="td-a-rec td-a-rec-id-content_top td-rec-hide-on-m td-rec-hide-on-tl td-rec-hide-on-tp td-rec-hide-on-p tdi_3 td_block_template_11">
<style media="all">.tdi_3.td-a-rec{text-align:center}.tdi_3 .td-element-style{z-index:-1}.tdi_3.td-a-rec-img{text-align:left}.tdi_3.td-a-rec-img img{margin:0 auto 0 0}@media (max-width:767px){.tdi_3.td-a-rec-img{text-align:center}}</style></div><h2 id="h-according-to-recent-smartasset-study">According to recent SmartAsset Study</h2><p>Roseville, Calif.- Businesses know a good investment when they see it. And Placer County continues to draw those businesses, ranking 4th in California for counties with the most incoming investments. A recent <a href="http://View the SmartAsset study and interactive map."><strong>SmartAsset study</strong></a> evaluated investments in business, real estate, government and the local economy to determine the ranking.</p><p>Placer County ranked high in the number of businesses established over a three-year period, marking 8.5% growth compared to the state average of 3%. When looking at business growth alone, Placer rose to second among California’s counties, just behind Riverside (8.7%).</p><div class="td-a-rec td-a-rec-id-content_inline tdi_2 td_block_template_11">
<style media="all">.tdi_2.td-a-rec{text-align:center}.tdi_2 .td-element-style{z-index:-1}.tdi_2.td-a-rec-img{text-align:left}.tdi_2.td-a-rec-img img{margin:0 auto 0 0}@media (max-width:767px){.tdi_2.td-a-rec-img{text-align:center}}</style><div class="td-visible-desktop"> Roseville Today Sponsor <br> <a href="https://www.behaviorfrontiers.com/sacramento-ca?ref=RosevilleToday" target="_blank"><img class="sponsor-ad" src="https://www.rosevilletoday.com/-img/autism.jpg" width="655px" alt="Autism Treatment Center"></a></div><div class="td-visible-tablet-landscape"> Roseville Today Sponsor <br> <a href="https://www.behaviorfrontiers.com/sacramento-ca?ref=RosevilleToday" target="_blank"><img class="sponsor-ad" src="https://www.rosevilletoday.com/-img/autism.jpg" width="655px" alt="Autism Treatment Center"></a></div><div class="td-visible-tablet-portrait"> Roseville Today Sponsor <br> <a href="https://www.behaviorfrontiers.com/sacramento-ca?ref=RosevilleToday" target="_blank"><img class="sponsor-ad" src="https://www.rosevilletoday.com/-img/autism-sm.jpg" width="340px" alt="Autism Treatment Center"></a></div><div class="td-visible-phone"> Roseville Today Sponsor <br> <a href="https://www.behaviorfrontiers.com/sacramento-ca?ref=RosevilleToday" target="_blank"><img class="sponsor-ad" src="https://www.rosevilletoday.com/-img/autism-sm.jpg" width="340px" alt="Autism Treatment Center"></a></div></div><p>Inflation-adjusted Gross Domestic Product growth and <a href="https://www.rosevilletoday.com/columns/real-estate/">local residential real estate</a> market investment also contributed to the area’s high marks.</p><p>Los Angeles, <strong><a href="https://www.orangecountytoday.com" target="_blank" rel="noreferrer noopener">Orange</a></strong> and San Diego Counties rank first through third, respectively. Nearby Sacramento County is eighth on the investment list.</p><div class="wp-container-61fca0536d16f wp-block-group"><div class="wp-block-group__inner-container"><h3>🌹Why Roseville?</h3><ul><li><a href="https://www.rosevilletoday.com/news/roseville/roseville-only-california-city-among-moneys-best-places-to-live/">Roseville Ranked Among Best Places to Live</a></li><li><a href="https://www.rosevilletoday.com/news/roseville/roseville-9th-best-city-to-retire-in-united-states/">Roseville Ranked 9th Best City to Retire in the United States</a></li><li><a href="https://www.rosevilletoday.com/news/roseville/roseville-ranks-14th-nationally-for-younger-homebuyers/">Roseville Ranked 14th Nationally for Young Homebuyers</a></li><li><a href="https://www.rosevilletoday.com/news/fema-recognizes-roseville/">FEMA Recognizes Roseville as &#8220;Best in the Nation&#8221;</a></li><li><a href="https://www.rosevilletoday.com/news/roseville/roseville-ranked-5th-in-nation-to-work-at-home/">Roseville Ranked 5th Best in Nation to Work at Home</a></li><li><a href="https://www.rosevilletoday.com/travel/local-travel/top-5-reasons-we-love-roseville/">Top 5 Reasons We Love Roseville</a></li></ul></div></div><div class="td-a-rec td-a-rec-id-content_bottom tdi_4 td_block_template_11">
<style media="all">.tdi_4.td-a-rec{text-align:center}.tdi_4 .td-element-style{z-index:-1}.tdi_4.td-a-rec-img{text-align:left}.tdi_4.td-a-rec-img img{margin:0 auto 0 0}@media (max-width:767px){.tdi_4.td-a-rec-img{text-align:center}}</style></div></div><footer><div class="td-post-source-tags"><div class="td-post-source-via td-no-tags"><div class="td-post-small-box"><span>SOURCE</span><a rel="nofollow" href="#">City of Roseville</a></div></div></div><div class="td-post-sharing-bottom"><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-border td-ps-border-grey td-ps-rounded td-ps-padding td-ps-icon-color td-post-sharing-style18"><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.rosevilletoday.com%2Fnews%2Froseville%2Froseville-drives-placer-county%2F" title="Facebook" ><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Roseville+drives+Placer+County+growth+ranking+among+top+in+California&url=https%3A%2F%2Fwww.rosevilletoday.com%2Fnews%2Froseville%2Froseville-drives-placer-county%2F&via=rrtoday" title="Twitter" ><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://www.rosevilletoday.com/news/roseville/roseville-drives-placer-county/&title=Roseville+drives+Placer+County+growth+ranking+among+top+in+California" title="Linkedin" ><div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div><div class="td-social-but-text">Linkedin</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#b18ec2c4d3dbd4d2c58ce3dec2d4c7d8ddddd491d5c3d8c7d4c291e1ddd0d2d4c391f2dec4dfc5c891d6c3dec6c5d991c3d0dfdad8dfd691d0dcdedfd691c5dec191d8df91f2d0ddd8d7dec3dfd8d097d3ded5c88cd9c5c5c1c28b9e9ec6c6c69fc3dec2d4c7d8ddddd4c5ded5d0c89fd2dedc9edfd4c6c29ec3dec2d4c7d8ddddd49ec3dec2d4c7d8ddddd49cd5c3d8c7d4c29cc1ddd0d2d4c39cd2dec4dfc5c89e" title="Email"><div class="td-social-but-icon"><i class="td-icon-mail"></i></div><div class="td-social-but-text">Email</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#" title="Print" ><div class="td-social-but-icon"><i class="td-icon-print"></i></div><div class="td-social-but-text">Print</div> </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom" title="More"><div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div> </a></div></div></div><div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://www.rosevilletoday.com/news/auburn/free-online-job-training-placer/">Free online job training through Placer County Library</a></div></div><div class="td-next-prev-separator"></div></div><div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://www.rosevilletoday.com/author/staff/">Staff</a></span></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person">
<meta itemprop="name" content="Staff"></span>
<meta itemprop="datePublished" content="2022-02-03T16:32:36-08:00">
<meta itemprop="dateModified" content="2022-02-03T16:34:02-08:00">
<meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.rosevilletoday.com/news/roseville/roseville-drives-placer-county/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
<meta itemprop="url" content="https://www.rosevilletoday.com/wp-content/uploads/2021/06/logo-blue2.png"></span>
<meta itemprop="name" content="Roseville Today"></span>
<meta itemprop="headline " content="Roseville drives Placer County growth ranking among top in California"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
<meta itemprop="url" content="https://www.rosevilletoday.com/wp-content/uploads/2022/01/roseville-news.jpg">
<meta itemprop="width" content="340">
<meta itemprop="height" content="328"></span></footer><div class="td_block_wrap td_block_related_posts tdi_5 td_with_ajax_pagination td-pb-border-top td_block_template_11" data-td-block-uid="tdi_5" >
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>var block_tdi_5 = new tdBlock();
block_tdi_5.id = "tdi_5";
block_tdi_5.atts = '{"limit":6,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"tdi_5","td_column_number":3,"block_type":"td_block_related_posts","live_filter_cur_post_id":68934,"live_filter_cur_post_author":"8","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_5","tdc_css_class_style":"tdi_5_rand_style"}';
block_tdi_5.td_column_number = "3";
block_tdi_5.block_type = "td_block_related_posts";
block_tdi_5.post_count = "6";
block_tdi_5.found_posts = "1795";
block_tdi_5.header_color = "";
block_tdi_5.ajax_pagination_infinite_stop = "";
block_tdi_5.max_num_pages = "300";
tdBlocksArray.push(block_tdi_5);</script>
<h4 class="td-related-title td-block-title"><a id="tdi_6" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_5" href="#">▶ Related</a><a id="tdi_7" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_5" href="#">▶ More from Author</a></h4><div id=tdi_5 class="td_block_inner"><div class="td-related-row"><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/valentines-amador-wine-country/" rel="bookmark" class="td-image-wrap" title="Celebrate Valentine&#8217;s in Amador Wine Country" ><img width="218" height="150" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/02/valentines-amador-218x150.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/02/valentines-amador-218x150.jpg 218w, https://www.rosevilletoday.com/wp-content/uploads/2022/02/valentines-amador-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Valentine&#039;s in Amador Wine Country" title="Celebrate Valentine&#8217;s in Amador Wine Country" /></a></div> <a href="https://www.rosevilletoday.com/travel/local-travel/" class="td-post-category">Local Travel</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/valentines-amador-wine-country/" rel="bookmark" title="Celebrate Valentine&#8217;s in Amador Wine Country">Celebrate Valentine&#8217;s in Amador Wine Country</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/spring-real-estate-market-roseville/" rel="bookmark" class="td-image-wrap" title="Spring Real Estate Market in Roseville" ><img width="218" height="150" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/02/cherry-blossom-218x150.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/02/cherry-blossom-218x150.jpg 218w, https://www.rosevilletoday.com/wp-content/uploads/2022/02/cherry-blossom-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Cherry Blossoms" title="Spring Real Estate Market in Roseville" /></a></div> <a href="https://www.rosevilletoday.com/columns/real-estate/" class="td-post-category">Real Estate</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/spring-real-estate-market-roseville/" rel="bookmark" title="Spring Real Estate Market in Roseville">Spring Real Estate Market in Roseville</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/2022-placer-county-fair/" rel="bookmark" class="td-image-wrap" title="2022 Placer County Meet Me at the Fair in Roseville" ><img width="218" height="150" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2019/05/meet-me-at-the-fair-218x150.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2019/05/meet-me-at-the-fair-218x150.jpg 218w, https://www.rosevilletoday.com/wp-content/uploads/2019/05/meet-me-at-the-fair-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Placer COunty Meet Me at the Fair" title="2022 Placer County Meet Me at the Fair in Roseville" /></a></div> <a href="https://www.rosevilletoday.com/news/roseville/" class="td-post-category">Roseville News</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/2022-placer-county-fair/" rel="bookmark" title="2022 Placer County Meet Me at the Fair in Roseville">2022 Placer County Meet Me at the Fair in Roseville</a></h3></div></div></div></div><div class="td-related-row"><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/communication-tools-engage-roseville-students-and-families/" rel="bookmark" class="td-image-wrap" title="Communication Tools Engage Roseville Students and Families" ><img width="218" height="150" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2020/05/derek-garcia-218x150.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2020/05/derek-garcia-218x150.jpg 218w, https://www.rosevilletoday.com/wp-content/uploads/2020/05/derek-garcia-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Derk Garcia" title="Communication Tools Engage Roseville Students and Families" /></a></div> <a href="https://www.rosevilletoday.com/news/roseville/" class="td-post-category">Roseville News</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/communication-tools-engage-roseville-students-and-families/" rel="bookmark" title="Communication Tools Engage Roseville Students and Families">Communication Tools Engage Roseville Students and Families</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/miss-california-heartshine-roseville/" rel="bookmark" class="td-image-wrap" title="Miss California HeartShine&#8217;s looks for Roseville Contestants" ><img width="218" height="150" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/02/heartshine-218x150.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/02/heartshine-218x150.jpg 218w, https://www.rosevilletoday.com/wp-content/uploads/2022/02/heartshine-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Heartshine" title="Miss California HeartShine&#8217;s looks for Roseville Contestants" /></a></div> <a href="https://www.rosevilletoday.com/news/roseville/" class="td-post-category">Roseville News</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/miss-california-heartshine-roseville/" rel="bookmark" title="Miss California HeartShine&#8217;s looks for Roseville Contestants">Miss California HeartShine&#8217;s looks for Roseville Contestants</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/teachers-of-the-year-in-roseville/" rel="bookmark" class="td-image-wrap" title="Teachers of the Year in Roseville and more at RJUHSD" ><img width="218" height="150" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/02/rjuhsd-sm-218x150.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/02/rjuhsd-sm-218x150.jpg 218w, https://www.rosevilletoday.com/wp-content/uploads/2022/02/rjuhsd-sm-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="RJUHSD" title="Teachers of the Year in Roseville and more at RJUHSD" /></a></div> <a href="https://www.rosevilletoday.com/news/roseville/" class="td-post-category">Roseville News</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/teachers-of-the-year-in-roseville/" rel="bookmark" title="Teachers of the Year in Roseville and more at RJUHSD">Teachers of the Year in Roseville and more at RJUHSD</a></h3></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_5" data-td_block_id="tdi_5"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_5" data-td_block_id="tdi_5"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div></div></div></div><div class="td-pb-span4 td-main-sidebar" role="complementary"><div class="td-ss-main-sidebar"><aside class="widget_text td_block_template_11 widget widget_custom_html"><h4 class="td-block-title"><span>♥ our Local Sponsors</span></h4><div class="textwidget custom-html-widget"><div id='div-gpt-ad-1526924072370-0' style='width: 300px; height: 250px;'> 
<script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1526924072370-0'); });</script>
</div></div></aside><aside class="td_block_template_11 widget widget_rss"><h4 class="td-block-title"><span><a class="rsswidget rss-widget-feed" href="https://www.rosevilletoday.com/news/feed/rss2/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.rosevilletoday.com/wp-includes/images/rss.png" alt="RSS" loading="lazy" /></a> <a class="rsswidget rss-widget-title" href="https://www.rosevilletoday.com/">Recent Posts</a></span></h4><ul><li><a class='rsswidget' href='https://www.rosevilletoday.com/news/roseville/roseville-drives-placer-county/'>Roseville drives Placer County growth ranking among top in California</a></li><li><a class='rsswidget' href='https://www.rosevilletoday.com/news/auburn/free-online-job-training-placer/'>Free online job training through Placer County Library</a></li><li><a class='rsswidget' href='https://www.rosevilletoday.com/news/roseville/valentines-amador-wine-country/'>Celebrate Valentine’s in Amador Wine Country</a></li><li><a class='rsswidget' href='https://www.rosevilletoday.com/news/roseville/spring-real-estate-market-roseville/'>Spring Real Estate Market in Roseville</a></li><li><a class='rsswidget' href='https://www.rosevilletoday.com/news/roseville/2022-placer-county-fair/'>2022 Placer County Meet Me at the Fair in Roseville</a></li></ul></aside><aside class="td_block_template_11 widget widget_rss"><h4 class="td-block-title"><span><a class="rsswidget rss-widget-feed" href="https://www.rosevilletoday.com/yp/feed/rss2/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.rosevilletoday.com/wp-includes/images/rss.png" alt="RSS" loading="lazy" /></a> <a class="rsswidget rss-widget-title" href="https://www.rosevilletoday.com/yp">Business Updates</a></span></h4><ul><li><a class='rsswidget' href='https://www.rosevilletoday.com/yp/big-o-tires/'>Big O Tires</a></li><li><a class='rsswidget' href='https://www.rosevilletoday.com/yp/effectiveness-of-press-release/'>Resting Pitch Face and the Effectiveness of the Press Release</a></li><li><a class='rsswidget' href='https://www.rosevilletoday.com/yp/tommys-express-car-wash/'>Tommy’s Express Car Wash</a></li><li><a class='rsswidget' href='https://www.rosevilletoday.com/yp/amazon-fresh-roseville/'>Amazon Fresh Roseville</a></li><li><a class='rsswidget' href='https://www.rosevilletoday.com/yp/behavior-frontiers/'>Behavior Frontiers</a></li></ul></aside><aside class="widget_text td_block_template_11 widget widget_custom_html"><h4 class="td-block-title"><span>Local Business &#8211; Join Today!</span></h4><div class="textwidget custom-html-widget"><h4>Business</h4><ul><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/business/insurance-agents/">Insurance</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/business/web-design-development/">Web & Graphic Design</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/business/advertising/">Online Advertising</a></li></ul><h4>Dining</h4><ul><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/restaurants/indian/">Indian Restaurants</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/restaurants/bakeries/">Bakeries</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/restaurants/craft-beer/">Craft Brews</a></li></ul><h4>Health &amp; Fitness</h4><ul><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/health-fitness/alternative-medicine/">Alternative Medicine</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/health-fitness/dentists/">Dentists</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/health-fitness/swim-lessons/">Swim Lessons</a></li></ul><h4>Home Improvement</h4><ul><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/home-improvement/heating-air/">Heating and Air</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/home-improvement/pest-control/">Pest Control</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/home-improvement/solar-panel-cleaning/">Solar Panel Cleaning</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/business/window-cleaning/">Window Cleaning</a></li></ul><h4>Real Estate</h4><ul><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/real-estate/apartment-rentals/">Apartments</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/real-estate/real-estate-agents/">Real Estate Agents</a></li></ul></div></aside></div></div></div></article></div></div><div class="tdc-footer-wrap"><div class="td-footer-wrapper td-footer-container td-container-wrap"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span12"></div></div><div class="td-pb-row"><div class="td-pb-span4"><div class="td_block_wrap td_block_16 td_block_widget tdi_9 td-pb-border-top td_block_template_11 td-column-1 td_block_padding" data-td-block-uid="tdi_9" >
<style media="all">.td_block_template_11.widget>ul>li{margin-left:0!important}.td_block_template_11 .td-block-title{font-size:17px;font-weight:500;margin-top:2px;margin-bottom:24px;line-height:44px;padding:0;position:relative;text-align:left}.td_block_template_11 .td-block-title:before,.td_block_template_11 .td-block-title:after{content:'';width:100%;height:2px;position:absolute;left:0;background-color:#f5f5f5}.td_block_template_11 .td-block-title:after{bottom:100%}.td_block_template_11 .td-block-title:before{top:100%}.td_block_template_11 .td-block-title>*{color:#000}.td_block_template_11 .td-subcat-filter{line-height:44px;display:table}.td_block_template_11 .td-subcat-dropdown{line-height:1;position:static}.td_block_template_11 .td-subcat-dropdown .td-subcat-more{margin-bottom:0!important}.td_block_template_11 .td-subcat-dropdown ul:after{height:2px!important}.td_block_template_11 .td-related-title a{margin-right:20px}@media (max-width:767px){.td_block_template_11 .td-related-title a{font-size:15px}}.td_block_template_11 .td-related-title .td-cur-simple-item{color:#4db2ec}</style>
<script>var block_tdi_9 = new tdBlock();
block_tdi_9.id = "tdi_9";
block_tdi_9.atts = '{"custom_title":"Latest News","custom_url":"","block_template_id":"","header_text_color":"#","border_color":"#","accent_text_color":"#","mx7_tl":"","mx7_el":"","m6_tl":"","limit":"3","offset":"","el_class":"","post_ids":"","category_id":"","category_ids":"21,27","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget tdi_9","block_type":"td_block_16","separator":"","show_modified_date":"","time_ago":"","time_ago_add_txt":"ago","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","mx7f_title_font_header":"","mx7f_title_font_title":"Article title","mx7f_title_font_settings":"","mx7f_title_font_family":"","mx7f_title_font_size":"","mx7f_title_font_line_height":"","mx7f_title_font_style":"","mx7f_title_font_weight":"","mx7f_title_font_transform":"","mx7f_title_font_spacing":"","mx7f_title_":"","mx7f_cat_font_title":"Article category tag","mx7f_cat_font_settings":"","mx7f_cat_font_family":"","mx7f_cat_font_size":"","mx7f_cat_font_line_height":"","mx7f_cat_font_style":"","mx7f_cat_font_weight":"","mx7f_cat_font_transform":"","mx7f_cat_font_spacing":"","mx7f_cat_":"","mx7f_meta_font_title":"Article meta info","mx7f_meta_font_settings":"","mx7f_meta_font_family":"","mx7f_meta_font_size":"","mx7f_meta_font_line_height":"","mx7f_meta_font_style":"","mx7f_meta_font_weight":"","mx7f_meta_font_transform":"","mx7f_meta_font_spacing":"","mx7f_meta_":"","mx7f_ex_font_title":"Article excerpt","mx7f_ex_font_settings":"","mx7f_ex_font_family":"","mx7f_ex_font_size":"","mx7f_ex_font_line_height":"","mx7f_ex_font_style":"","mx7f_ex_font_weight":"","mx7f_ex_font_transform":"","mx7f_ex_font_spacing":"","mx7f_ex_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","color_preset":"","border_top":"","tdc_css_class":"tdi_9","tdc_css_class_style":"tdi_9_rand_style"}';
block_tdi_9.td_column_number = "1";
block_tdi_9.block_type = "td_block_16";
block_tdi_9.post_count = "3";
block_tdi_9.found_posts = "6731";
block_tdi_9.header_color = "";
block_tdi_9.ajax_pagination_infinite_stop = "";
block_tdi_9.max_num_pages = "2244";
tdBlocksArray.push(block_tdi_9);</script>
<div class="td-block-title-wrap"><h4 class="td-block-title"><span class="td-pulldown-size">Latest News</span></h4></div><div id=tdi_9 class="td_block_inner td-column-1"><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/roseville-drives-placer-county/" rel="bookmark" class="td-image-wrap" title="Roseville drives Placer County growth ranking among top in California" ><img width="100" height="70" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/01/roseville-news-100x70.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/01/roseville-news-100x70.jpg 100w, https://www.rosevilletoday.com/wp-content/uploads/2022/01/roseville-news-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Roseville news" title="Roseville drives Placer County growth ranking among top in California" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/roseville-drives-placer-county/" rel="bookmark" title="Roseville drives Placer County growth ranking among top in California">Roseville drives Placer County growth ranking among top in California</a></h3><div class="td-module-meta-info"></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/auburn/free-online-job-training-placer/" rel="bookmark" class="td-image-wrap" title="Free online job training through Placer County Library" ><img width="100" height="70" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/02/online-class-100x70.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/02/online-class-100x70.jpg 100w, https://www.rosevilletoday.com/wp-content/uploads/2022/02/online-class-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Online Class" title="Free online job training through Placer County Library" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/auburn/free-online-job-training-placer/" rel="bookmark" title="Free online job training through Placer County Library">Free online job training through Placer County Library</a></h3><div class="td-module-meta-info"></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/valentines-amador-wine-country/" rel="bookmark" class="td-image-wrap" title="Celebrate Valentine&#8217;s in Amador Wine Country" ><img width="100" height="70" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/02/valentines-amador-100x70.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/02/valentines-amador-100x70.jpg 100w, https://www.rosevilletoday.com/wp-content/uploads/2022/02/valentines-amador-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Valentine&#039;s in Amador Wine Country" title="Celebrate Valentine&#8217;s in Amador Wine Country" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/valentines-amador-wine-country/" rel="bookmark" title="Celebrate Valentine&#8217;s in Amador Wine Country">Celebrate Valentine&#8217;s in Amador Wine Country</a></h3><div class="td-module-meta-info"></div></div></div></div></div></div></div><div class="td-pb-span4"><div class="td_block_wrap td_block_weather td_block_widget tdi_10 td-pb-border-top td_block_template_11" data-td-block-uid="tdi_10" >
<style media="all">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</style><div class="td-block-title-wrap"></div><div id=tdi_10 class="td-weather-wrap td_block_inner td-column-1"><div class="td-weather-header"><div class="td-weather-city">Roseville</div><div class="td-weather-condition">clear sky</div> <i class="td-location-icon td-icons-location" data-block-uid="tdi_10"></i></div><div class="td-weather-set-location"><form class="td-manual-location-form" action="#" data-block-uid="tdi_10"> <input id="tdi_10" class="td-location-set-input" type="text" name="location" value=""> <label>enter location</label></form></div><div class="td-weather-temperature"><div class="td-weather-temp-wrap"><div class="td-weather-animated-icon"> <span class="td_animation_sprite-27-100-80-0-0-1 clear-sky-n td-w-today-icon" data-td-block-uid="tdi_10"></span></div><div class="td-weather-now" data-block-uid="tdi_10"> <span class="td-big-degrees">48.4</span> <span class="td-circle">&deg;</span> <span class="td-weather-unit">F</span></div><div class="td-weather-lo-hi"><div class="td-weather-degrees-wrap"> <i class="td-up-icon td-icons-arrows-up"></i> <span class="td-small-degrees td-w-high-temp">55.2</span> <span class="td-circle">&deg;</span></div><div class="td-weather-degrees-wrap"> <i class="td-down-icon td-icons-arrows-down"></i> <span class="td-small-degrees td-w-low-temp">43.4</span> <span class="td-circle">&deg;</span></div></div></div></div><div class="td-weather-info-wrap"><div class="td-weather-information"><div class="td-weather-section-1"> <i class="td-icons-drop"></i> <span class="td-weather-parameter td-w-today-humidity">66 %</span></div><div class="td-weather-section-2"> <i class="td-icons-wind"></i> <span class="td-weather-parameter td-w-today-wind-speed">0mph</span></div><div class="td-weather-section-3"> <i class="td-icons-cloud"></i> <span class="td-weather-parameter td-w-today-clouds">0 %</span></div></div><div class="td-weather-week"><div class="td-weather-days"><div class="td-day-0">Fri</div><div class="td-day-degrees"> <span class="td-degrees-0">60</span> <span class="td-circle">&deg;</span></div></div><div class="td-weather-days"><div class="td-day-1">Sat</div><div class="td-day-degrees"> <span class="td-degrees-1">60</span> <span class="td-circle">&deg;</span></div></div><div class="td-weather-days"><div class="td-day-2">Sun</div><div class="td-day-degrees"> <span class="td-degrees-2">61</span> <span class="td-circle">&deg;</span></div></div><div class="td-weather-days"><div class="td-day-3">Mon</div><div class="td-day-degrees"> <span class="td-degrees-3">62</span> <span class="td-circle">&deg;</span></div></div><div class="td-weather-days"><div class="td-day-4">Tue</div><div class="td-day-degrees"> <span class="td-degrees-4">64</span> <span class="td-circle">&deg;</span></div></div></div></div></div></div></div><div class="td-pb-span4"><div class="td_block_wrap td_block_7 td_block_widget tdi_11 td-pb-border-top td_block_template_11 td-column-1 td_block_padding" data-td-block-uid="tdi_11" >
<script>var block_tdi_11 = new tdBlock();
block_tdi_11.id = "tdi_11";
block_tdi_11.atts = '{"custom_title":"Local Real Estate","custom_url":"","block_template_id":"","header_text_color":"#","border_color":"#","accent_text_color":"#","m6_tl":"","limit":"3","offset":"","time_ago_add_txt":"ago","el_class":"","post_ids":"","category_id":"30","category_ids":"53","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget tdi_11","block_type":"td_block_7","separator":"","show_modified_date":"","time_ago":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","color_preset":"","border_top":"","tdc_css_class":"tdi_11","tdc_css_class_style":"tdi_11_rand_style"}';
block_tdi_11.td_column_number = "1";
block_tdi_11.block_type = "td_block_7";
block_tdi_11.post_count = "3";
block_tdi_11.found_posts = "193";
block_tdi_11.header_color = "";
block_tdi_11.ajax_pagination_infinite_stop = "";
block_tdi_11.max_num_pages = "65";
tdBlocksArray.push(block_tdi_11);</script>
<div class="td-block-title-wrap"><h4 class="td-block-title"><span class="td-pulldown-size">Local Real Estate</span></h4></div><div id=tdi_11 class="td_block_inner"><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/spring-real-estate-market-roseville/" rel="bookmark" class="td-image-wrap" title="Spring Real Estate Market in Roseville" ><img width="100" height="70" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/02/cherry-blossom-100x70.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/02/cherry-blossom-100x70.jpg 100w, https://www.rosevilletoday.com/wp-content/uploads/2022/02/cherry-blossom-218x150.jpg 218w, https://www.rosevilletoday.com/wp-content/uploads/2022/02/cherry-blossom-324x226.jpg 324w" sizes="(max-width: 100px) 100vw, 100px" alt="Cherry Blossoms" title="Spring Real Estate Market in Roseville" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/spring-real-estate-market-roseville/" rel="bookmark" title="Spring Real Estate Market in Roseville">Spring Real Estate Market in Roseville</a></h3><div class="td-module-meta-info"></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/columns/real-estate/poor-real-estate-offers/" rel="bookmark" class="td-image-wrap" title="Poor Real Estate Offers" ><img width="100" height="70" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/01/home-porch-100x70.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/01/home-porch-100x70.jpg 100w, https://www.rosevilletoday.com/wp-content/uploads/2022/01/home-porch-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Front porch of home" title="Poor Real Estate Offers" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/columns/real-estate/poor-real-estate-offers/" rel="bookmark" title="Poor Real Estate Offers">Poor Real Estate Offers</a></h3><div class="td-module-meta-info"></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/daunting-market-for-first-time-home-buyers/" rel="bookmark" class="td-image-wrap" title="Daunting Market for First Time Home Buyers" ><img width="100" height="70" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2021/12/couple-100x70.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2021/12/couple-100x70.jpg 100w, https://www.rosevilletoday.com/wp-content/uploads/2021/12/couple-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Daunting Market for First Time Home Buyers" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/daunting-market-for-first-time-home-buyers/" rel="bookmark" title="Daunting Market for First Time Home Buyers">Daunting Market for First Time Home Buyers</a></h3><div class="td-module-meta-info"></div></div></div></div></div></div></div></div></div><div class="td-footer-bottom-full"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="https://www.rosevilletoday.com/"><img src="https://www.rosevilletoday.com/wp-content/uploads/2020/12/roseville-today-logo.png" alt="Roseville Today logo" title="" width="272" height="90"/></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div>Business, Travel, & Entertainment. A locally owned, community supported online business since 2003. We're located in Roseville, California and proudly serve communities throughout Placer County and the entire Golden State. <br><br> <b>We have NO affiliation with print or corporate media.</b></aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/RosevilleToday" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.instagram.com/rosevilletoday/" title="Instagram"> <i class="td-icon-font td-icon-instagram"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.rosevilletoday.com/news/feed/" title="RSS"> <i class="td-icon-font td-icon-rss"></i> </a> </span></aside></div></div></div></div></div><div class="td-sub-footer-container td-container-wrap"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span td-sub-footer-menu"><div class="menu-td-demo-footer-menu-container"><ul id="menu-td-demo-footer-menu" class="td-subfooter-menu"><li id="menu-item-49285" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-49285"><a href="https://www.rosevilletoday.com/">Roseville Today</a></li><li id="menu-item-49286" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-49286"><a href="https://www.rosevilletoday.com/yp/">YP</a></li><li id="menu-item-161" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-161"><a href="/about/">About Us</a></li><li id="menu-item-160" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-160"><a href="/privacy-policy/">Privacy Policy</a></li><li id="menu-item-159" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-159"><a href="/contact/">Contact Us</a></li><li id="menu-item-162" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-162"><a href="/advertise/">Advertise</a></li></ul></div></div><div class="td-pb-span td-sub-footer-copy"> &copy; Roseville Today | 4010 Foothills Blvd. 103- #28 | Roseville, CA 95747</div></div></div></div></div></div> 
<script>( function ( body ) {
'use strict';
body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
} )( document.body );</script>
<style type="text/css" media="all">.td-post-featured-image{float:left;display:block;width:auto;margin:14px}.td-category-pulldown-filter td-wrapper-pulldown-filter{display:none}.td-pulldown-filter-display-option{display:none}.td-subcat-more{display:none}.td-icon-menu-down{display:none}.td-pulldown-filter-list{display:none}.td-pulldown-filter-item{display:none}</style> 
<script>var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"},"registration_prompt":"There is unsaved attendee information. Are you sure you want to continue?"};</script>
<script>(function () {
var c = document.body.className;
c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
document.body.className = c;
})();</script>
<style media="all">.wp-container-61fca0536d16f .alignleft{float:left;margin-right:2em}.wp-container-61fca0536d16f .alignright{float:right;margin-left:2em}</style>
<script id='jquery-deparam-js-extra'>var TribeTicketsPlus = {"ajaxurl":"https:\/\/www.rosevilletoday.com\/wp-admin\/admin-ajax.php","save_attendee_info_nonce":"6c7638781b"};</script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/event-tickets-plus/vendor/jquery.deparam/jquery.deparam.js?ver=5.3.3' id='jquery-deparam-js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/event-tickets-plus/vendor/jquery.cookie/jquery.cookie.js?ver=5.3.3' id='jquery-cookie-js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/event-tickets-plus/src/resources/js/attendees-list.min.js?ver=5.3.3' id='event-tickets-plus-attendees-list-js-js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/event-tickets-plus/src/resources/js/meta.min.js?ver=5.3.3' id='event-tickets-plus-meta-js-js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/event-tickets/src/resources/js/rsvp.min.js?ver=5.2.3' id='event-tickets-tickets-rsvp-js-js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/event-tickets/src/resources/js/ticket-details.min.js?ver=5.2.3' id='event-tickets-details-js-js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js?ver=2.7.0-wc.6.1.1' id='jquery-blockui-js'></script>
<script id='wc-add-to-cart-js-extra'>var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/www.rosevilletoday.com\/cart\/","is_cart":"","cart_redirect_after_add":"yes"};</script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart.min.js?ver=6.1.1' id='wc-add-to-cart-js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/woocommerce/assets/js/js-cookie/js.cookie.min.js?ver=2.1.4-wc.6.1.1' id='js-cookie-js'></script>
<script id='woocommerce-js-extra'>var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};</script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js?ver=6.1.1' id='woocommerce-js'></script>
<script id='wc-cart-fragments-js-extra'>var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_99652f39b82f1d3ffdbee0deb146621a","fragment_name":"wc_fragments_99652f39b82f1d3ffdbee0deb146621a","request_timeout":"5000"};</script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js?ver=6.1.1' id='wc-cart-fragments-js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=c181d64d1d8a935f19bbe229f049bcfe' id='tdb_js_posts_autoload-js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=11.4' id='td-site-min-js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-includes/js/comment-reply.min.js?ver=5.9' id='comment-reply-js'></script>
<script id='event-tickets-rsvp-js-extra'>var tribe_tickets_rsvp_strings = {"attendee":"Attendee %1$s"};</script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/event-tickets/src/resources/js/rsvp.min.js?ver=5.2.3' id='event-tickets-rsvp-js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=c181d64d1d8a935f19bbe229f049bcfe' id='tdb_js_files_for_front-js'></script>
<style id='tribe-common-full-style-inline-css' class='tec-customizer-inline-style' type='text/css' media="all">:root{--tec-color-text-events-title:#000;--tec-color-text-event-title:#000;--tec-color-link-primary:#014e9b;--tec-color-link-accent:#014e9b;--tec-color-link-accent-hover:rgba(1,78,155,0.8);--tec-color-accent-primary:#023d67;--tec-color-accent-primary-hover:rgba(2,61,103,0.8);--tec-color-accent-primary-multiday:rgba(2,61,103,0.24);--tec-color-accent-primary-multiday-hover:rgba(2,61,103,0.34);--tec-color-accent-primary-active:rgba(2,61,103,0.9);--tec-color-accent-primary-background:rgba(2,61,103,0.07);--tec-color-background-secondary-datepicker:rgba(2,61,103,0.5);--tec-color-accent-primary-background-datepicker:#023d67;--tec-color-button-primary:#023d67;--tec-color-button-primary-hover:rgba(2,61,103,0.8);--tec-color-button-primary-active:rgba(2,61,103,0.9);--tec-color-button-primary-background:rgba(2,61,103,0.07);--tec-color-day-marker-current-month:#023d67;--tec-color-day-marker-current-month-hover:rgba(2,61,103,0.8);--tec-color-day-marker-current-month-active:rgba(2,61,103,0.9);--tec-color-background-primary-multiday:rgba(2,61,103,0.24);--tec-color-background-primary-multiday-hover:rgba(2,61,103,0.34);--tec-color-background-primary-multiday-active:rgba(2,61,103,0.34);--tec-color-background-secondary-multiday:rgba(2,61,103,0.24);--tec-color-background-secondary-multiday-hover:rgba(2,61,103,0.34)}:root{--tec-color-background-events-bar-submit-button:#023d67;--tec-color-background-events-bar-submit-button-hover:rgba(2,61,103,0.8);--tec-color-background-events-bar-submit-button-active:rgba(2,61,103,0.9)}.tribe-common.event-tickets .tribe-tickets__rsvp-actions-success-going-check-icon,.tribe-common.event-tickets .tribe-common-c-btn:disabled{background-color:#023d67}.tribe-common.event-tickets .tribe-tickets__rsvp-message{background-color:rgba(2,61,103,0.07)}.tribe-common.event-tickets .tribe-tickets__rsvp-message-link{color:#023d67}.tribe-common.event-tickets .tribe-common-cta--alt,.tribe-common.event-tickets .tribe-common-cta--alt:active,.tribe-common.event-tickets .tribe-common-cta--alt:hover,.tribe-common.event-tickets .tribe-common-cta--alt:focus,.tribe-common.event-tickets .tribe-common-cta--thin-alt,.tribe-common.event-tickets .tribe-common-cta--thin-alt:active,.tribe-common.event-tickets .tribe-common-cta--thin-alt:focus,.tribe-common.event-tickets .tribe-common-cta--thin-alt:hover{border-bottom-color:#023d67}.tribe-common.event-tickets .tribe-common-cta--alt:active,.tribe-common.event-tickets .tribe-common-cta--alt:hover,.tribe-common.event-tickets .tribe-common-cta--alt:focus,.tribe-common.event-tickets .tribe-common-cta--thin-alt:active,.tribe-common.event-tickets .tribe-common-cta--thin-alt:hover,.tribe-common.event-tickets .tribe-common-cta--thin-alt:focus,.tribe-theme-twentyseventeen .tribe-common.event-tickets .tribe-common-cta--alt:hover,.tribe-theme-twentyseventeen .tribe-common.event-tickets .tribe-common-cta--alt:focus,.tribe-theme-twentyseventeen .tribe-common.event-tickets .tribe-common-cta--thin-alt:hover,.tribe-theme-twentyseventeen .tribe-common.event-tickets .tribe-common-cta--thin-alt:focus{color:#023d67}.tribe-common.event-tickets .tribe-common-c-btn,.tribe-common.event-tickets a.tribe-common-c-btn{background-color:#023d67}.tribe-common.event-tickets .tribe-common-c-btn:focus,.tribe-common.event-tickets .tribe-common-c-btn:hover,.tribe-common.event-tickets a.tribe-common-c-btn:focus,.tribe-common.event-tickets a.tribe-common-c-btn:hover{background-color:rgba(2,61,103,0.8)}.tribe-common.event-tickets .tribe-common-c-btn:active,.tribe-common.event-tickets a.tribe-common-c-btn:active{background-color:rgba(2,61,103,0.9)}.tribe-common.event-tickets .tribe-common-c-btn:disabled,.tribe-common.event-tickets a.tribe-common-c-btn:disabled{background-color:#023d67}.tribe-theme-twentytwenty .tribe-common.event-tickets .tribe-common-c-btn{background-color:#023d67}.tribe-theme-twentyseventeen .tribe-common.event-tickets .tribe-common-c-btn:hover,.tribe-theme-twentyseventeen .tribe-common.event-tickets .tribe-common-c-btn:focus,.tribe-theme-twentytwenty .tribe-common.event-tickets .tribe-common-c-btn:hover,.tribe-theme-twentytwenty .tribe-common.event-tickets .tribe-common-c-btn:focus{background-color:rgba(2,61,103,0.8)}@keyframes tribe-common-c-loader-bounce{0%{}50%{background-color:#023d67}}</style>
<script>!function(){window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[],advanced_ads_ready_queue.push=window.advanced_ads_ready;for(var d=0,a=advanced_ads_ready_queue.length;d<a;d++)advanced_ads_ready(advanced_ads_ready_queue[d])}();</script>
<script>jQuery().ready(function () {
tdWeather.addItem({"block_uid":"tdi_10","location":"5388881","api_location":"Roseville","api_language":"en","api_key":"ae6740d1cdd712b8489a62751fd67013","today_icon":"clear-sky-n","today_icon_text":"clear sky","today_temp":[9.0999999999999996,48.399999999999999],"today_humidity":66,"today_wind_speed":[0,0],"today_min":[6.4000000000000004,43.399999999999999],"today_max":[12.9,55.200000000000003],"today_clouds":0,"current_unit":1,"forecast":[{"timestamp":1643954400,"day_name":"Fri","day_temp":[15,60],"owm_day_index":0},{"timestamp":1644019200,"day_name":"Sat","day_temp":[16,60],"owm_day_index":6},{"timestamp":1644105600,"day_name":"Sun","day_temp":[16,61],"owm_day_index":14},{"timestamp":1644192000,"day_name":"Mon","day_temp":[17,62],"owm_day_index":22},{"timestamp":1644278400,"day_name":"Tue","day_temp":[18,64],"owm_day_index":30}]});
});</script>
<style media="all">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</style>
<script type='text/javascript' id='fvm-delayjs' data-cfasync='false'>
!function(k,e,x){function r(d,a,g,b){return b=(a?e.getElementById(a):t)||e.createElement(d||"SCRIPT"),a&&(b.id=a),g&&(b.onload=g),b}function u(d){f(function(a){a=[].slice.call(e.querySelectorAll(d));(function v(b,c){if(b=a.shift()){b.parentNode.removeChild(b);var l=b,m,n=void 0;var p=r(l.nodeName);var q=0;for(m=l.attributes;q<m.length;q++)"type"!=(n=m[q]).name&&p.setAttribute(n.name,n.value);(c=(p.text=l.text,p)).src&&!c.hasAttribute("async")?(c.onload=c.onerror=v,e.head.appendChild(c)):(e.head.appendChild(c),
v())}})()})}var f,t,h=[],w=/p/.test(e.readyState);Function();(f=function(d,a){w?x(d,a):h.push(d,a)}).all=u;f.js=function(d,a,g,b){f(function(c){(c=r(t,a,b)).src=d;e.head.appendChild(c)},g)};k.addEventListener("onpageshow"in k?"pageshow":"load",function(){for(w=!u();h[0];)f(h.shift(),h.shift())});k.Defer=f}(this,document,setTimeout);
const userInteractionEvents=["mouseover","keydown","touchstart","touchmove","wheel"];userInteractionEvents.forEach(function(event){window.addEventListener(event,triggerScriptLoader,{passive:!0})});function triggerScriptLoader(){fvmloadscripts();userInteractionEvents.forEach(function(event){window.removeEventListener(event,triggerScriptLoader,{passive:!0})})}function fvmloadscripts(){Defer.all('script[type="fvm-script-delay"]')};
</script>
<script type="text/javascript">(function(){window['__CF$cv$params']={r:'6d812e1b3ed05974',m:'Mrv8S96SY0RAmJrtrHYnR.P8oqzLgFsBMdI10hnx4J0-1643949198-0-AQ+lXtdYC7ktWjzBDbx3g78Kgb+5BX6SQuQBQ/VKMpR8fiy7W/rUimudoIc0vKUCi57r3x9VmaWFIIJ4Eted2q00m9Q3FnlEAQtu8qKgU7+LmdCSMPTpNYw/7Jceuu6Rw7qk/khENOgLqllRGcap2tXZAvi6HJBxrifUpxew3CQ9',s:[0xb0e22af961,0x2fd5e975d9],}})();</script><script defer src="https://static.cloudflareinsights.com/beacon.min.js/v652eace1692a40cfa3763df669d7439c1639079717194" integrity="sha512-Gi7xpJR8tSkrpF7aordPZQlW2DLtzUlZcumS8dMQjwDHEnw9I7ZLyiOj/6tZStRBGtGgN6ceN6cMH8z7etPGlw==" data-cf-beacon='{"rayId":"6d812e1b3ed05974","token":"9639abc27d734ec8b96408e75d059522","version":"2021.12.0","si":100}' crossorigin="anonymous"></script>
</body>
</html>