<!doctype html > 
<html lang="en-US"> 
<head>
<meta charset="UTF-8" />
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css4bee2385ad50086188ae4518987aa241ca35763cd2bd691c55b0facb2f6ce.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-cssfcca8e36f1309d5825434bef9e7eb66b0a04cfac98c1ee5dbfdc40c16edaa.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css199a08ebdf3278a2ab047575f492fab9bcb815d53bb558af6e5a9a7180238.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-cssd3567f55afb04cf4c9d43583b926da11ac6488051f3c7ccfee96cc1f103f0.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css4e20eec6dff1311c7774a2783b62f5df72d3407e2c35b16f7e00cf2136d11.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css46d94aafe1fda637c8183a6a8b24c9b48aa32dcf7a9dbc303832d6787d1da.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css26e41ddb5c22c8d58426ee60b834a797fa8b388ff29657c974f880f1a89c3.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css11709c3d448c8790f9f63773fc9a2b2a580bccac243e6f284df5994435dfd.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-csscbc2ed1087c91ee30ac2c036738382f879e37c7bf04141c9ac1e23f105341.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-csse286cad66585bf9cb6b59c33129f9b08661a2055d4cfa75699db02ff7d8ff.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-cssde3f7a5f9f2624ce758e2c0de305c6923a11a867063e978efe7c4f90562e4.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-cssff7ab1b1a0266f15a2c0dc5ec0d0abcef5fe430cf2536a0cda1e6ede77f2c.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css64e0c49f6ed505746578b3349d03b9b0cb216c338d8bd9873c81dff589f1b.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css98224dbb39cc578cc6fc79e1c168a74722834567d1eb7a5c63e40cdb741b1.css" as="style" media="only screen and (max-width: 768px)" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css4572ca563dd9a22bb4129e7095f809c3e734cc98e21b8c806953130a85f6b.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css7ae43c9cdc5bf2ec622068982fb5841cc359af832b5eac4a4626dc5bc3166.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css741c99c09e8199f6402e4beaf709e86d1b381b55cfd3a940b7f8d0b223bca.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-cssf4a827162918bbec99b8676abda623c8f13b8dab145481a59d460deb5a195.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-csse7fe34a6c10fb6084677c1b95df17f6b5b19b71571028ce8949e7e256b5c8.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css75c01a97269be9d83d9d6c439cdb95e42625f2b7e0e26188332990a40a5a6.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css602789e27ad6052d9d0dd386c7d2713ea1c33a8b8dd70dea272513da52358.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css5dde005ef2e2a221a4d6d5beaf9095234b4d65e47cf004671f47472ce0334.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css3a73980d33860f8ec62c721b34106591130403c017d6e2c25f475f89248c1.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css9344d0bf6c91c5b969cd8e3d8e2f47c09540fd49dd2f4c3c66452597ffb06.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-cssec83d397c6cd97277dec94dcf4baf1c2cf46f79044db16f92296974e10d7d.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css7388e348cfc7f935fbb5577d2bb48e625a8f05578ab0eadcf252a10275cd4.css" as="style" media="all" /> 
<link rel="preload" href="https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css9146ceb3f24c36412300a49b0d43d196755efca54e39efbb3d2ce5b90914b.css" as="style" media="all" />
<script data-cfasync="false">function fvmuag(){var e=navigator.userAgent;if(e.match(/x11.*ox\/54|id\s4.*us.*ome\/62|oobo|ight|tmet|eadl|ngdo|PTST/i))return!1;if(e.match(/x11.*me\/86\.0/i)){var r=screen.width;if("number"==typeof r&&1367==r)return!1}return!0}</script>
<title>Mazda CX-5 challenging class leaders - Roseville Today</title>
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<meta name="description" content="Roseville, Calif.- It&#039;s hardly a secret the Mazda CX-5 has ascended to the top echelon in its class. The numbers tell the story" />
<link rel="canonical" href="https://www.rosevilletoday.com/news/roseville/mazda-cx5-review/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Mazda CX-5 challenging class leaders" />
<meta property="og:description" content="Smartly-designed SUV ascends the ranks Roseville, Calif.- It&#039;s hardly a secret the Mazda CX-5 has ascended to the top echelon in its class. The numbers" />
<meta property="og:url" content="https://www.rosevilletoday.com/news/roseville/mazda-cx5-review/" />
<meta property="og:site_name" content="Roseville Today" />
<meta property="article:publisher" content="https://www.facebook.com/RosevilleToday" />
<meta property="article:published_time" content="2022-03-14T16:06:05+00:00" />
<meta property="article:modified_time" content="2022-03-14T16:06:06+00:00" />
<meta property="og:image" content="https://www.rosevilletoday.com/wp-content/uploads/2022/03/Mazda-CX-5.jpg" />
<meta property="og:image:width" content="655" />
<meta property="og:image:height" content="450" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@rrtoday" />
<meta name="twitter:site" content="@rrtoday" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Jeffrey Weidel - Weidel on Wheels" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="3 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.rosevilletoday.com/#organization","name":"Roseville Today","url":"https://www.rosevilletoday.com/","sameAs":["https://www.facebook.com/RosevilleToday","https://www.instagram.com/rosevilletoday/","https://twitter.com/rrtoday"],"logo":{"@type":"ImageObject","@id":"https://www.rosevilletoday.com/#logo","inLanguage":"en-US","url":"https://www.rosevilletoday.com/wp-content/uploads/2021/04/rt-logo.png","contentUrl":"https://www.rosevilletoday.com/wp-content/uploads/2021/04/rt-logo.png","width":544,"height":180,"caption":"Roseville Today"},"image":{"@id":"https://www.rosevilletoday.com/#logo"}},{"@type":"WebSite","@id":"https://www.rosevilletoday.com/#website","url":"https://www.rosevilletoday.com/","name":"Roseville Today","description":"Business, Travel and Entertainment","publisher":{"@id":"https://www.rosevilletoday.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.rosevilletoday.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.rosevilletoday.com/news/roseville/mazda-cx5-review/#primaryimage","inLanguage":"en-US","url":"https://www.rosevilletoday.com/wp-content/uploads/2022/03/Mazda-CX-5.jpg","contentUrl":"https://www.rosevilletoday.com/wp-content/uploads/2022/03/Mazda-CX-5.jpg","width":655,"height":450,"caption":"Mazda CX-5"},{"@type":"WebPage","@id":"https://www.rosevilletoday.com/news/roseville/mazda-cx5-review/#webpage","url":"https://www.rosevilletoday.com/news/roseville/mazda-cx5-review/","name":"Mazda CX-5 challenging class leaders - Roseville Today","isPartOf":{"@id":"https://www.rosevilletoday.com/#website"},"primaryImageOfPage":{"@id":"https://www.rosevilletoday.com/news/roseville/mazda-cx5-review/#primaryimage"},"datePublished":"2022-03-14T16:06:05+00:00","dateModified":"2022-03-14T16:06:06+00:00","description":"Roseville, Calif.- It's hardly a secret the Mazda CX-5 has ascended to the top echelon in its class. The numbers tell the story","breadcrumb":{"@id":"https://www.rosevilletoday.com/news/roseville/mazda-cx5-review/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.rosevilletoday.com/news/roseville/mazda-cx5-review/"]}]},{"@type":"BreadcrumbList","@id":"https://www.rosevilletoday.com/news/roseville/mazda-cx5-review/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.rosevilletoday.com/"},{"@type":"ListItem","position":2,"name":"News","item":"https://www.rosevilletoday.com/news/"},{"@type":"ListItem","position":3,"name":"Roseville News","item":"https://www.rosevilletoday.com/news/roseville/"},{"@type":"ListItem","position":4,"name":"Mazda CX-5 challenging class leaders"}]},{"@type":"Article","@id":"https://www.rosevilletoday.com/news/roseville/mazda-cx5-review/#article","isPartOf":{"@id":"https://www.rosevilletoday.com/news/roseville/mazda-cx5-review/#webpage"},"author":{"@id":"https://www.rosevilletoday.com/#/schema/person/87e01986258594780f039940c300e75b"},"headline":"Mazda CX-5 challenging class leaders","datePublished":"2022-03-14T16:06:05+00:00","dateModified":"2022-03-14T16:06:06+00:00","mainEntityOfPage":{"@id":"https://www.rosevilletoday.com/news/roseville/mazda-cx5-review/#webpage"},"wordCount":563,"publisher":{"@id":"https://www.rosevilletoday.com/#organization"},"image":{"@id":"https://www.rosevilletoday.com/news/roseville/mazda-cx5-review/#primaryimage"},"thumbnailUrl":"https://www.rosevilletoday.com/wp-content/uploads/2022/03/Mazda-CX-5.jpg","keywords":["Car Reviews"],"articleSection":["Car Reviews","Roseville News"],"inLanguage":"en-US"},{"@type":"Person","@id":"https://www.rosevilletoday.com/#/schema/person/87e01986258594780f039940c300e75b","name":"Jeffrey Weidel - Weidel on Wheels","description":"Weidel on Wheels author Jeffrey Weidel is an award-winning writer from the Sacramento region who has reviewed automobiles for more than two decades. He spent 25 years in the newspaper business and has been active freelance writer for three decades on a number of topics. He can be reached at skiweidel@gmail.com","url":"https://www.rosevilletoday.com/author/jeffrey-weidel-weidel-on-wheels/"}]}</script>
<link rel="alternate" type="application/rss+xml" title="Roseville Today &raquo; Feed" href="https://www.rosevilletoday.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Roseville Today &raquo; Comments Feed" href="https://www.rosevilletoday.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Roseville Today &raquo; iCal Feed" href="https://www.rosevilletoday.com/events/?ical=1" />
<meta name="et-api-version" content="v1">
<meta name="et-api-origin" content="https://www.rosevilletoday.com">
<meta name="tec-api-version" content="v1">
<meta name="tec-api-origin" content="https://www.rosevilletoday.com">
<script type="application/ld+json">{
"@context": "http://schema.org",
"@type": "BreadcrumbList",
"itemListElement": [
{
"@type": "ListItem",
"position": 1,
"item": {
"@type": "WebSite",
"@id": "https://www.rosevilletoday.com/",
"name": "Home"
}
},
{
"@type": "ListItem",
"position": 2,
"item": {
"@type": "WebPage",
"@id": "https://www.rosevilletoday.com/columns/",
"name": "Columns"
}
}
,{
"@type": "ListItem",
"position": 3,
"item": {
"@type": "WebPage",
"@id": "https://www.rosevilletoday.com/columns/car-reviews/",
"name": "Car Reviews"                                
}
}
,{
"@type": "ListItem",
"position": 4,
"item": {
"@type": "WebPage",
"@id": "https://www.rosevilletoday.com/news/roseville/mazda-cx5-review/",
"name": "Mazda CX-5 challenging class leaders"                                
}
}    
]
}</script>
<link rel="icon" type="image/png" href="https://www.rosevilletoday.com/wp-content/uploads/2021/12/favicon.jpg"> 
<script id="rosev-ready">
window.advanced_ads_ready=function(e,a){a=a||"complete";var d=function(e){return"interactive"===a?"loading"!==e:"complete"===e};d(document.readyState)?e():document.addEventListener("readystatechange",(function(a){d(a.target.readyState)&&e()}),{once:"interactive"===a})},window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[];		</script>
<link rel='stylesheet' id='tec-variables-full-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css4bee2385ad50086188ae4518987aa241ca35763cd2bd691c55b0facb2f6ce.css' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-cssfcca8e36f1309d5825434bef9e7eb66b0a04cfac98c1ee5dbfdc40c16edaa.css' type='text/css' media='all' />
<link rel='stylesheet' id='event-tickets-plus-tickets-css-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css199a08ebdf3278a2ab047575f492fab9bcb815d53bb558af6e5a9a7180238.css' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-pro-mini-calendar-block-styles-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-cssd3567f55afb04cf4c9d43583b926da11ac6488051f3c7ccfee96cc1f103f0.css' type='text/css' media='all' />
<link rel='stylesheet' id='event-tickets-tickets-rsvp-css-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css4e20eec6dff1311c7774a2783b62f5df72d3407e2c35b16f7e00cf2136d11.css' type='text/css' media='all' />
<link rel='stylesheet' id='tec-variables-skeleton-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css46d94aafe1fda637c8183a6a8b24c9b48aa32dcf7a9dbc303832d6787d1da.css' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-common-skeleton-style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css26e41ddb5c22c8d58426ee60b834a797fa8b388ff29657c974f880f1a89c3.css' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-common-full-style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css11709c3d448c8790f9f63773fc9a2b2a580bccac243e6f284df5994435dfd.css' type='text/css' media='all' />
<link rel='stylesheet' id='event-tickets-tickets-css-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-csscbc2ed1087c91ee30ac2c036738382f879e37c7bf04141c9ac1e23f105341.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-csse286cad66585bf9cb6b59c33129f9b08661a2055d4cfa75699db02ff7d8ff.css' type='text/css' media='all' />
<link rel='stylesheet' id='wc-blocks-vendors-style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-cssde3f7a5f9f2624ce758e2c0de305c6923a11a867063e978efe7c4f90562e4.css' type='text/css' media='all' />
<link rel='stylesheet' id='wc-blocks-style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-cssff7ab1b1a0266f15a2c0dc5ec0d0abcef5fe430cf2536a0cda1e6ede77f2c.css' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css' media="all">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</style>
<link rel='stylesheet' id='woocommerce-layout-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css64e0c49f6ed505746578b3349d03b9b0cb216c338d8bd9873c81dff589f1b.css' type='text/css' media='all' />
<link rel='stylesheet' id='woocommerce-smallscreen-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css98224dbb39cc578cc6fc79e1c168a74722834567d1eb7a5c63e40cdb741b1.css' type='text/css' media='only screen and (max-width: 768px)' />
<link rel='stylesheet' id='woocommerce-general-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css4572ca563dd9a22bb4129e7095f809c3e734cc98e21b8c806953130a85f6b.css' type='text/css' media='all' />
<style id='woocommerce-inline-inline-css' type='text/css' media="all">.woocommerce form .form-row .required{visibility:visible}</style>
<link rel='stylesheet' id='wp_automatic_gallery_style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css7ae43c9cdc5bf2ec622068982fb5841cc359af832b5eac4a4626dc5bc3166.css' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css741c99c09e8199f6402e4beaf709e86d1b381b55cfd3a940b7f8d0b223bca.css' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='google-fonts-style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-cssf4a827162918bbec99b8676abda623c8f13b8dab145481a59d460deb5a195.css' type='text/css' media='all' />
<link rel='stylesheet' id='event-tickets-rsvp-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-csse7fe34a6c10fb6084677c1b95df17f6b5b19b71571028ce8949e7e256b5c8.css' type='text/css' media='all' />
<link rel='stylesheet' id='event-tickets-tpp-css-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css75c01a97269be9d83d9d6c439cdb95e42625f2b7e0e26188332990a40a5a6.css' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css602789e27ad6052d9d0dd386c7d2713ea1c33a8b8dd70dea272513da52358.css' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css' media="all">@media (max-width:767px){.td-header-desktop-wrap{display:none}}@media (min-width:767px){.td-header-mobile-wrap{display:none}}</style>
<link rel='stylesheet' id='td-theme-woo-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css5dde005ef2e2a221a4d6d5beaf9095234b4d65e47cf004671f47472ce0334.css' type='text/css' media='all' />
<link rel='stylesheet' id='TribeEventsWooTickets-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css3a73980d33860f8ec62c721b34106591130403c017d6e2c25f475f89248c1.css' type='text/css' media='all' />
<link rel='stylesheet' id='td-legacy-framework-front-style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css9344d0bf6c91c5b969cd8e3d8e2f47c09540fd49dd2f4c3c66452597ffb06.css' type='text/css' media='all' />
<link rel='stylesheet' id='td-legacy-framework-woo-style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-cssec83d397c6cd97277dec94dcf4baf1c2cf46f79044db16f92296974e10d7d.css' type='text/css' media='all' />
<link rel='stylesheet' id='td-standard-pack-framework-front-style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css7388e348cfc7f935fbb5577d2bb48e625a8f05578ab0eadcf252a10275cd4.css' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css' href='https://www.rosevilletoday.com/wp-content/cache/fvm/min/1647116169-css9146ceb3f24c36412300a49b0d43d196755efca54e39efbb3d2ce5b90914b.css' type='text/css' media='all' /> 
<script async='async' src='https://www.rosevilletoday.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/wp-automatic/js/main-front.js?ver=5.9.2' id='wp_automatic_gallery-js'></script>
<script>window.tdb_globals = {"wpRestNonce":"c51a8efc63","wpRestUrl":"https:\/\/www.rosevilletoday.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/","globalSettings":{"tdcSavingHistory":false},"isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};</script>
<style id="tdb-global-colors" media="all">:root{--accent-color:#fff}</style> 
<script>window.tdwGlobal = {"adminUrl":"https:\/\/www.rosevilletoday.com\/wp-admin\/","wpRestNonce":"c51a8efc63","wpRestUrl":"https:\/\/www.rosevilletoday.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/"};</script>
<script>window.tdaGlobal = {"adminUrl":"https:\/\/www.rosevilletoday.com\/wp-admin\/","wpRestNonce":"c51a8efc63","wpRestUrl":"https:\/\/www.rosevilletoday.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/","postId":70304};</script>
<noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
<link rel="amphtml" href="https://www.rosevilletoday.com/news/roseville/mazda-cx5-review/?amp">
<script  src='https://www.googletagservices.com/tag/js/gpt.js' async></script>
<script>var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];</script>
<script>googletag.cmd.push(function() {
googletag.defineSlot('/1027827/300x250', [[300, 250], [336, 280]], 'div-gpt-ad-1526924072370-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});</script>
<script>var tdBlocksArray = []; //here we store all the items for the current page
//td_block class - each ajax block uses a object of this class for requests
function tdBlock() {
this.id = '';
this.block_type = 1; //block type id (1-234 etc)
this.atts = '';
this.td_column_number = '';
this.td_current_page = 1; //
this.post_count = 0; //from wp
this.found_posts = 0; //from wp
this.max_num_pages = 0; //from wp
this.td_filter_value = ''; //current live filter value
this.is_ajax_running = false;
this.td_user_action = ''; // load more or infinite loader (used by the animation)
this.header_color = '';
this.ajax_pagination_infinite_stop = ''; //show load more at page x
}
// td_js_generator - mini detector
(function(){
var htmlTag = document.getElementsByTagName("html")[0];
if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
htmlTag.className += ' ie10';
}
if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
htmlTag.className += ' ie11';
}
if ( navigator.userAgent.indexOf("Edge") > -1 ) {
htmlTag.className += ' ieEdge';
}
if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
htmlTag.className += ' td-md-is-ios';
}
var user_agent = navigator.userAgent.toLowerCase();
if ( user_agent.indexOf("android") > -1 ) {
htmlTag.className += ' td-md-is-android';
}
if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
htmlTag.className += ' td-md-is-os-x';
}
if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
htmlTag.className += ' td-md-is-chrome';
}
if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
htmlTag.className += ' td-md-is-firefox';
}
if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
htmlTag.className += ' td-md-is-safari';
}
if( -1 !== navigator.userAgent.indexOf('IEMobile') ){
htmlTag.className += ' td-md-is-iemobile';
}
})();
var tdLocalCache = {};
( function () {
"use strict";
tdLocalCache = {
data: {},
remove: function (resource_id) {
delete tdLocalCache.data[resource_id];
},
exist: function (resource_id) {
return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
},
get: function (resource_id) {
return tdLocalCache.data[resource_id];
},
set: function (resource_id, cachedData) {
tdLocalCache.remove(resource_id);
tdLocalCache.data[resource_id] = cachedData;
}
};
})();
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var tdc_is_installed="yes";
var td_ajax_url="https:\/\/www.rosevilletoday.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=11.4.2";
var td_get_template_directory_uri="https:\/\/www.rosevilletoday.com\/wp-content\/plugins\/td-composer\/legacy\/common";
var tds_snap_menu="smart_snap_always";
var tds_logo_on_sticky="show";
var tds_header_style="3";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var td_user_incorrect="Username incorrect!";
var td_email_user_empty="Email or username empty!";
var td_pass_empty="Pass empty!";
var td_pass_pattern_incorrect="Invalid Pass Pattern!";
var td_retype_pass_incorrect="Retyped Pass incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#02355a";
var tds_smart_sidebar="";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var tdBlockNonce="41d0fb5a47";
var tdDateNamesI18n={"month_names":["January","February","March","April","May","June","July","August","September","October","November","December"],"month_names_short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"day_names":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"day_names_short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]};
var td_ad_background_click_link="";
var td_ad_background_click_target="";</script>
<script data-ad-client="ca-pub-5649489283520750" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script async src="https://www.googletagmanager.com/gtag/js?id=G-1069ECQ8NK"></script>
<script>window.dataLayer = window.dataLayer || [];
function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'G-1069ECQ8NK');</script>
<style type="text/css" id="wp-custom-css" media="all">div.tribe-events-single-event-recurrence-description{visibility:hidden;display:none}.td-author-counters{display:none}td{vertical-align:top!important}#yplink li a{color:#0f4c81}.tribe-events-widget-events-list{font-size:12px;border-radius:12px;background-color:#fafaf7}.td-visible-desktop{background-color:#fff}.td-visible-tablet-landscape{background-color:#fff}.td-visible-tablet-portrait{background-color:#fff}.td-visible-phone{background-color:#b5d2f6;border-radius:6px}.sponsor-ad{padding:12px}h2.tribe-events-widget-events-list__header-title{font-weight:700;font-size:1.8em;color:#004e7e;position:relative;left:75px;left:100px}h3.tribe-events-widget-events-list__event-title{font-size:1.5em}a.yps{color:#1b2880;font-size:15px;color:#333}a.tribe-events-widget-events-list__view-more-link{padding-left:60px;font-weight:700;font-size:1.1em;position:relative;left:75px;position:relative;left:50px}.tribe-events-widget-events-list__event-datetime-wrapper{display:none}.tribe-events-widget-events-list__event-date-tag{font-weight:700;color:#343f47}.rss-widget-icon{display:none}a.rsswidget{color:#ffa128;font-weight:700;font-size:.9em;font-family:sans-serif,Arial}.rsswidget:link{color:#012e81;color:#333}.rsswidget:visited{color:#00276e}.tribe-events-notices{background-color:#ffc780;color:#000;font-weight:700;font-size:1.4em}.imgpad{padding-right:15px}#showcase{width:345px;height:auto}.tribe-events-calendar-list__event-row--featured{background-color:#e7e7e5;border-radius:8px}</style>
<style media="all">.tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,.tds-button2 .tdm-btn-text,.tds-button2 i,.tds-button5:hover .tdm-btn-text,.tds-button5:hover i,.tds-button6 .tdm-btn-text,.tds-button6 i,.tdm_block_list .tdm-list-item i,.tdm_block_pricing .tdm-pricing-feature i,body .tdm-social-item i{color:#02355a}.tds-button1,.tds-button6:after,.tds-title2 .tdm-title-line:after,.tds-title3 .tdm-title-line:after,.tdm_block_pricing.tdm-pricing-featured:before,.tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,.tds-progress-bar1 .tdm-progress-bar:after,.tds-progress-bar2 .tdm-progress-bar:after,.tds-social3 .tdm-social-item{background-color:#02355a}.tds-button2:before,.tds-button6:before,.tds-progress-bar3 .tdm-progress-bar:after{border-color:#02355a}.tdm-btn-style1{background-color:#02355a}.tdm-btn-style2:before{border-color:#02355a}.tdm-btn-style2{color:#02355a}.tdm-btn-style3{-webkit-box-shadow:0 2px 16px #02355a;-moz-box-shadow:0 2px 16px #02355a;box-shadow:0 2px 16px #02355a}.tdm-btn-style3:hover{-webkit-box-shadow:0 4px 26px #02355a;-moz-box-shadow:0 4px 26px #02355a;box-shadow:0 4px 26px #02355a}</style>
<script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head>
<body class="post-template-default single single-post postid-70304 single-format-standard theme-Newspaper td-standard-pack woocommerce-no-js tribe-no-js page-template-www-rrtoday_609-public-wp-content-themes-newspaper-page-php tribe-theme-Newspaper mazda-cx5-review global-block-template-11 td-local-news single_template_2 aa-prefix-rosev- td-boxed-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage"> <div class="td-scroll-up td-hide-scroll-up-on-mob" style="display:none;"><i class="td-icon-menu-up"></i></div><div class="td-menu-background" style="visibility:hidden"></div><div id="td-mobile-nav" style="visibility:hidden"><div class="td-mobile-container"><div class="td-menu-socials-wrap"><div class="td-menu-socials"> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/RosevilleToday" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.instagram.com/rosevilletoday/" title="Instagram"> <i class="td-icon-font td-icon-instagram"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.rosevilletoday.com/news/feed/" title="RSS"> <i class="td-icon-font td-icon-rss"></i> </a> </span></div><div class="td-mobile-close"> <a href="#" aria-label="Close"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-mobile-content"><div class="menu-td-demo-header-menu-container"><ul id="menu-td-demo-header-menu" class="td-mobile-main-menu"><li id="menu-item-168" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first menu-item-168"><a href="https://www.rosevilletoday.com/">Home</a></li><li id="menu-item-173" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-173"><a href="/news/">Local news<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-175" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-175"><a href="/news/roseville/">Roseville</a></li><li id="menu-item-174" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-174"><a href="/news/rocklin/">Rocklin</a></li><li id="menu-item-46156" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-46156"><a href="https://www.rosevilletoday.com/news/lincoln/">Lincoln</a></li><li id="menu-item-33550" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33550"><a href="https://www.rosevilletoday.com/news/auburn/">Auburn</a></li><li id="menu-item-50887" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50887"><a href="https://www.rosevilletoday.com/news/folsom/">Folsom</a></li><li id="menu-item-176" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-176"><a href="/news/sacramento/">Sacramento</a></li><li id="menu-item-48015" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48015"><a href="https://www.rosevilletoday.com/press-releases/">California News</a></li><li id="menu-item-57252" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57252"><a href="https://www.rosevilletoday.com/news/roseville/californias-10-largest-reservoirs-drought-status/">Reservoir Levels</a></li><li id="menu-item-69957" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-69957"><a href="https://www.rosevilletoday.com/news/roseville/california-snowpack-levels/">California Snowpack</a></li></ul></li><li id="menu-item-69530" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-69530"><a href="#">Why Roseville?<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-69894" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-69894"><a href="https://www.rosevilletoday.com/news/roseville/placer-county-ranks-1-in-quality-of-life-second-healthiest/">Quality of Life</a></li><li id="menu-item-69531" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-69531"><a href="https://www.rosevilletoday.com/news/roseville/roseville-only-california-city-among-moneys-best-places-to-live/">Places to Live</a></li><li id="menu-item-69534" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-69534"><a href="https://www.rosevilletoday.com/news/roseville/roseville-ranks-14th-nationally-for-younger-homebuyers/">Young Homebuyers</a></li><li id="menu-item-69533" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-69533"><a href="https://www.rosevilletoday.com/news/roseville/roseville-ranked-5th-in-nation-to-work-at-home/">Work from Home</a></li><li id="menu-item-69532" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-69532"><a href="https://www.rosevilletoday.com/news/roseville/roseville-9th-best-city-to-retire-in-united-states/">Retirement</a></li><li id="menu-item-69535" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-69535"><a href="https://www.rosevilletoday.com/travel/local-travel/top-5-reasons-we-love-roseville/">♥ Our Favorites</a></li></ul></li><li id="menu-item-17466" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-17466"><a href="https://www.rosevilletoday.com/yp/">Yellow Pages<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-54119" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54119"><a href="https://www.rosevilletoday.com/yp/business/">Business</a></li><li id="menu-item-54120" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54120"><a href="https://www.rosevilletoday.com/yp/community/">Community</a></li><li id="menu-item-54121" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54121"><a href="https://www.rosevilletoday.com/yp/health-fitness/">Health &#038; Fitness</a></li><li id="menu-item-54122" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54122"><a href="https://www.rosevilletoday.com/yp/home-improvement/">Home Improvement</a></li><li id="menu-item-54123" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54123"><a href="https://www.rosevilletoday.com/yp/real-estate/">Real Estate</a></li><li id="menu-item-54124" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54124"><a href="https://www.rosevilletoday.com/yp/restaurants/">Restaurants</a></li></ul></li><li id="menu-item-233" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-233"><a href="/travel/">Travel<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-30808" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30808"><a href="https://www.rosevilletoday.com/author/todd-schofield/">Travel Reviews</a></li><li id="menu-item-28186" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28186"><a href="https://www.rosevilletoday.com/travel/bay-area/">Bay Area</a></li><li id="menu-item-26018" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26018"><a href="https://www.rosevilletoday.com/travel/lake-tahoe/">Lake Tahoe &#8211; Reno</a></li><li id="menu-item-26019" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26019"><a href="https://www.rosevilletoday.com/travel/monterey-carmel/">Monterey and Carmel</a></li><li id="menu-item-26020" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26020"><a href="https://www.rosevilletoday.com/travel/napa-valley/">Napa Valley</a></li><li id="menu-item-26021" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26021"><a href="https://www.rosevilletoday.com/travel/sonoma/">Sonoma County</a></li><li id="menu-item-26022" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26022"><a href="https://www.rosevilletoday.com/travel/palm-springs/">Palm Springs Area</a></li><li id="menu-item-230" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-230"><a href="/travel/local-travel/">Placer / El Dorado / Sacramento</a></li></ul></li><li id="menu-item-234" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-234"><a href="/columns/">Columns<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-29512" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29512"><a href="https://www.rosevilletoday.com/news/sacramento/laws/">New Laws 2022</a></li><li id="menu-item-30989" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30989"><a href="https://www.rosevilletoday.com/author/todd-schofield/">Travel &#038; Music</a></li><li id="menu-item-235" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-235"><a href="/columns/real-estate/">Real Estate</a></li><li id="menu-item-236" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-236"><a href="/columns/natural-wellness/">Natural Medicine</a></li><li id="menu-item-47565" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47565"><a href="https://www.rosevilletoday.com/tag/roseville-city-school-district/">Roseville City School District</a></li><li id="menu-item-47564" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47564"><a href="https://www.rosevilletoday.com/tag/roseville-joint-union-high-school-district/">Roseville Joint Union HSD</a></li><li id="menu-item-3876" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3876"><a href="/columns/car-reviews/">Weidel on Wheels</a></li><li id="menu-item-48314" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48314"><a href="https://www.rosevilletoday.com/tag/roseville-safety-first/">Roseville Safety Tips</a></li><li id="menu-item-48238" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48238"><a href="https://www.rosevilletoday.com/tag/hiking/">Hiking</a></li><li id="menu-item-48207" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48207"><a href="https://www.rosevilletoday.com/tag/rocklin-history-tour/">Rocklin History Tour</a></li><li id="menu-item-6022" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6022"><a href="/columns/disabilities">Disabilities</a></li></ul></li><li id="menu-item-13241" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-13241"><a href="/events/">Events<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-26702" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26702"><a href="/events/">View All Events</a></li><li id="menu-item-26703" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26703"><a href="https://www.rosevilletoday.com/product/single-event-listing-highlight/">+ ADD Your Event</a></li></ul></li><li id="menu-item-232" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-232"><a href="/music/">Music<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-238" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-238"><a href="/music/concert-venues/">Concert Schedules</a></li><li id="menu-item-29889" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29889"><a href="https://www.rosevilletoday.com/music/festivals/">Music Festivals</a></li><li id="menu-item-240" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-240"><a href="/music/music-reviews/">Music Reviews</a></li><li id="menu-item-68750" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-68750"><a href="https://www.rosevilletoday.com/news/roseville/pandora-spotify-youtube-music-compared/">Streaming Compared</a></li><li id="menu-item-11101" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11101"><a href="/music/grateful-dead-50/">Grateful Dead- 50 Days</a></li></ul></li></ul></div></div></div></div><div class="td-search-background" style="visibility:hidden"></div><div class="td-search-wrap-mob" style="visibility:hidden"><div class="td-drop-down-search"><form method="get" class="td-search-form" action="https://www.rosevilletoday.com/"><div class="td-search-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div><div role="search" class="td-search-input"> <span>Search</span> <input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" /></div></form><div id="td-aj-search-mob" class="td-ajax-search-flex"></div></div></div><div id="td-outer-wrap" class="td-theme-wrap"><div class="tdc-header-wrap"><div class="td-header-wrap td-header-style-3"><div class="td-header-top-menu-full td-container-wrap"><div class="td-container td-header-row td-header-top-menu"><div class="top-bar-style-2"><div class="td-header-sp-top-widget"> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/RosevilleToday" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.instagram.com/rosevilletoday/" title="Instagram"> <i class="td-icon-font td-icon-instagram"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.rosevilletoday.com/news/feed/" title="RSS"> <i class="td-icon-font td-icon-rss"></i> </a> </span></div><div class="td-header-sp-top-menu"><div class="td_data_time"><div > Monday, March 14, 2022</div></div></div></div><div id="login-form" class="white-popup-block mfp-hide mfp-with-anim"><div class="td-login-wrap"> <a href="#" aria-label="Back" class="td-back-button"><i class="td-icon-modal-back"></i></a><div id="td-login-div" class="td-login-form-div td-display-block"><div class="td-login-panel-title">Sign in</div><div class="td-login-panel-descr">Welcome! Log into your account</div><div class="td_display_err"></div><form id="loginForm" action="#" method="post"><div class="td-login-inputs"><input class="td-login-input" autocomplete="username" type="text" name="login_email" id="login_email" value="" required><label for="login_email">your username</label></div><div class="td-login-inputs"><input class="td-login-input" autocomplete="current-password" type="password" name="login_pass" id="login_pass" value="" required><label for="login_pass">your password</label></div> <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login"></form><div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div><div class="td-login-info-text"><a class="privacy-policy-link" href="https://www.rosevilletoday.com/privacy-policy/">Privacy Policy</a></div></div><div id="td-forgot-pass-div" class="td-login-form-div td-display-none"><div class="td-login-panel-title">Password recovery</div><div class="td-login-panel-descr">Recover your password</div><div class="td_display_err"></div><form id="forgotpassForm" action="#" method="post"><div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label for="forgot_email">your email</label></div> <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password"></form><div class="td-login-info-text">A password will be e-mailed to you.</div></div></div></div></div></div><div class="td-banner-wrap-full td-container-wrap"><div class="td-container td-header-row td-header-header"><div class="td-header-sp-logo"> <a class="td-main-logo" href="https://www.rosevilletoday.com/"> <img class="td-retina-data" data-retina="https://www.rosevilletoday.com/wp-content/uploads/2021/03/retina-logo-blue.png" src="https://www.rosevilletoday.com/wp-content/uploads/2021/06/logo-blue2.png" alt="Rocklin & Roseville Today" width="272" height="90"/> <span class="td-visual-hidden">Roseville Today</span> </a></div><div class="td-header-sp-recs"><div class="td-header-rec-wrap"><div class="td-a-rec td-a-rec-id-header td-rec-hide-on-tp td-rec-hide-on-p tdi_1 td_block_template_11">
<style media="all">.tdi_1.td-a-rec{text-align:center}.tdi_1 .td-element-style{z-index:-1}.tdi_1.td-a-rec-img{text-align:left}.tdi_1.td-a-rec-img img{margin:0 auto 0 0}@media (max-width:767px){.tdi_1.td-a-rec-img{text-align:center}}</style><div class="td-all-devices"><a href="https://www.girlscouts.org/?ref=RosevilleToday"><img width="728" height="90" alt="Order Girl Scout Cookies Online" src="https://www.rosevilletoday.com/gs/girlscouts728.jpg?v=2"/></a></div></div></div></div></div></div><div class="td-header-menu-wrap-full td-container-wrap"><div class="td-header-menu-wrap"><div class="td-container td-header-row td-header-main-menu black-menu"><div id="td-header-menu" role="navigation"><div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div><div class="td-main-menu-logo td-logo-in-header"> <a class="td-main-logo" href="https://www.rosevilletoday.com/"> <img class="td-retina-data" data-retina="https://www.rosevilletoday.com/wp-content/uploads/2021/03/retina-logo-blue.png" src="https://www.rosevilletoday.com/wp-content/uploads/2021/06/logo-blue2.png" alt="Rocklin & Roseville Today" width="272" height="90"/> </a></div><div class="menu-td-demo-header-menu-container"><ul id="menu-td-demo-header-menu-1" class="sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-168"><a href="https://www.rosevilletoday.com/">Home</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-173"><a href="/news/">Local news</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-175"><a href="/news/roseville/">Roseville</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-174"><a href="/news/rocklin/">Rocklin</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-46156"><a href="https://www.rosevilletoday.com/news/lincoln/">Lincoln</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-33550"><a href="https://www.rosevilletoday.com/news/auburn/">Auburn</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-50887"><a href="https://www.rosevilletoday.com/news/folsom/">Folsom</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-176"><a href="/news/sacramento/">Sacramento</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-48015"><a href="https://www.rosevilletoday.com/press-releases/">California News</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-57252"><a href="https://www.rosevilletoday.com/news/roseville/californias-10-largest-reservoirs-drought-status/">Reservoir Levels</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-69957"><a href="https://www.rosevilletoday.com/news/roseville/california-snowpack-levels/">California Snowpack</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-69530"><a href="#">Why Roseville?</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-69894"><a href="https://www.rosevilletoday.com/news/roseville/placer-county-ranks-1-in-quality-of-life-second-healthiest/">Quality of Life</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-69531"><a href="https://www.rosevilletoday.com/news/roseville/roseville-only-california-city-among-moneys-best-places-to-live/">Places to Live</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-69534"><a href="https://www.rosevilletoday.com/news/roseville/roseville-ranks-14th-nationally-for-younger-homebuyers/">Young Homebuyers</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-69533"><a href="https://www.rosevilletoday.com/news/roseville/roseville-ranked-5th-in-nation-to-work-at-home/">Work from Home</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-69532"><a href="https://www.rosevilletoday.com/news/roseville/roseville-9th-best-city-to-retire-in-united-states/">Retirement</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-69535"><a href="https://www.rosevilletoday.com/travel/local-travel/top-5-reasons-we-love-roseville/">♥ Our Favorites</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-17466"><a href="https://www.rosevilletoday.com/yp/">Yellow Pages</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-54119"><a href="https://www.rosevilletoday.com/yp/business/">Business</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-54120"><a href="https://www.rosevilletoday.com/yp/community/">Community</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-54121"><a href="https://www.rosevilletoday.com/yp/health-fitness/">Health &#038; Fitness</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-54122"><a href="https://www.rosevilletoday.com/yp/home-improvement/">Home Improvement</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-54123"><a href="https://www.rosevilletoday.com/yp/real-estate/">Real Estate</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-54124"><a href="https://www.rosevilletoday.com/yp/restaurants/">Restaurants</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-233"><a href="/travel/">Travel</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-30808"><a href="https://www.rosevilletoday.com/author/todd-schofield/">Travel Reviews</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-28186"><a href="https://www.rosevilletoday.com/travel/bay-area/">Bay Area</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-26018"><a href="https://www.rosevilletoday.com/travel/lake-tahoe/">Lake Tahoe &#8211; Reno</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-26019"><a href="https://www.rosevilletoday.com/travel/monterey-carmel/">Monterey and Carmel</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-26020"><a href="https://www.rosevilletoday.com/travel/napa-valley/">Napa Valley</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-26021"><a href="https://www.rosevilletoday.com/travel/sonoma/">Sonoma County</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-26022"><a href="https://www.rosevilletoday.com/travel/palm-springs/">Palm Springs Area</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-230"><a href="/travel/local-travel/">Placer / El Dorado / Sacramento</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-234"><a href="/columns/">Columns</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-29512"><a href="https://www.rosevilletoday.com/news/sacramento/laws/">New Laws 2022</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-30989"><a href="https://www.rosevilletoday.com/author/todd-schofield/">Travel &#038; Music</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-235"><a href="/columns/real-estate/">Real Estate</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-236"><a href="/columns/natural-wellness/">Natural Medicine</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-47565"><a href="https://www.rosevilletoday.com/tag/roseville-city-school-district/">Roseville City School District</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-47564"><a href="https://www.rosevilletoday.com/tag/roseville-joint-union-high-school-district/">Roseville Joint Union HSD</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3876"><a href="/columns/car-reviews/">Weidel on Wheels</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-48314"><a href="https://www.rosevilletoday.com/tag/roseville-safety-first/">Roseville Safety Tips</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-48238"><a href="https://www.rosevilletoday.com/tag/hiking/">Hiking</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-48207"><a href="https://www.rosevilletoday.com/tag/rocklin-history-tour/">Rocklin History Tour</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6022"><a href="/columns/disabilities">Disabilities</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-13241"><a href="/events/">Events</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-26702"><a href="/events/">View All Events</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-26703"><a href="https://www.rosevilletoday.com/product/single-event-listing-highlight/">+ ADD Your Event</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-232"><a href="/music/">Music</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-238"><a href="/music/concert-venues/">Concert Schedules</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-29889"><a href="https://www.rosevilletoday.com/music/festivals/">Music Festivals</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-240"><a href="/music/music-reviews/">Music Reviews</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-68750"><a href="https://www.rosevilletoday.com/news/roseville/pandora-spotify-youtube-music-compared/">Streaming Compared</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-11101"><a href="/music/grateful-dead-50/">Grateful Dead- 50 Days</a></li></ul></li></ul></div></div><div class="header-search-wrap"><div class="td-search-btns-wrap"> <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle" data-toggle="dropdown"><i class="td-icon-search"></i></a> <a id="td-header-search-button-mob" href="#" class="dropdown-toggle" data-toggle="dropdown"><i class="td-icon-search"></i></a></div><div class="td-drop-down-search" aria-labelledby="td-header-search-button"><form method="get" class="td-search-form" action="https://www.rosevilletoday.com/"><div role="search" class="td-head-form-search-wrap"> <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" /></div></form><div id="td-aj-search"></div></div></div></div></div></div></div></div><div class="td-main-content-wrap td-container-wrap"><div class="td-container td-post-template-2"><article id="post-70304" class="post-70304 post type-post status-publish format-standard has-post-thumbnail category-car-reviews category-roseville tag-car-reviews" itemscope itemtype="https://schema.org/Article"><div class="td-pb-row"><div class="td-pb-span12"><div class="td-post-header"><div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://www.rosevilletoday.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Columns" class="entry-crumb" href="https://www.rosevilletoday.com/columns/">Columns</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Car Reviews" class="entry-crumb" href="https://www.rosevilletoday.com/columns/car-reviews/">Car Reviews</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Mazda CX-5 challenging class leaders</span></div></div><ul class="td-category"><li class="entry-category"><a style="background-color:#d44206; color:#fff; border-color:#d44206;" href="https://www.rosevilletoday.com/columns/">Columns</a></li><li class="entry-category"><a style="background-color:#03749c; color:#fff; border-color:#03749c;" href="https://www.rosevilletoday.com/columns/car-reviews/">Car Reviews</a></li><li class="entry-category"><a style="background-color:#d44206; color:#fff; border-color:#d44206;" href="https://www.rosevilletoday.com/news/">News</a></li><li class="entry-category"><a style="background-color:#03749c; color:#fff; border-color:#03749c;" href="https://www.rosevilletoday.com/news/roseville/">Roseville News</a></li></ul><header class="td-post-title"><h1 class="entry-title">Mazda CX-5 challenging class leaders</h1><div class="td-module-meta-info"><div class="td-post-author-name"><div class="td-author-by">▶</div> <a href="https://www.rosevilletoday.com/author/jeffrey-weidel-weidel-on-wheels/">Jeffrey Weidel - Weidel on Wheels</a><div class="td-author-line"> -</div></div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-03-14T09:06:05-07:00" >March 14, 2022</time></span></div></header></div></div></div><div class="td-pb-row"><div class="td-pb-span8 td-main-content" role="main"><div class="td-ss-main-content"><div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-border td-ps-border-grey td-ps-notext td-ps-icon-color td-ps-text-color td-post-sharing-style16">
<style media="all">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</style><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text"><div class="td-social-but-icon"><i class="td-icon-share"></i></div><div class="td-social-but-text">Share</div></div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.rosevilletoday.com%2Fnews%2Froseville%2Fmazda-cx5-review%2F" title="Facebook" ><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Mazda+CX-5+challenging+class+leaders&url=https%3A%2F%2Fwww.rosevilletoday.com%2Fnews%2Froseville%2Fmazda-cx5-review%2F&via=rrtoday" title="Twitter" ><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://www.rosevilletoday.com/news/roseville/mazda-cx5-review/&title=Mazda+CX-5+challenging+class+leaders" title="Linkedin" ><div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div><div class="td-social-but-text">Linkedin</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#d0efa3a5b2bab5b3a4ed9db1aab4b1f09388fde5f0b3b8b1bcbcb5beb7b9beb7f0b3bcb1a3a3f0bcb5b1b4b5a2a3f6b2bfb4a9edb8a4a4a0a3eaffffa7a7a7fea2bfa3b5a6b9bcbcb5a4bfb4b1a9feb3bfbdffbeb5a7a3ffa2bfa3b5a6b9bcbcb5ffbdb1aab4b1fdb3a8e5fda2b5a6b9b5a7ff" title="Email"><div class="td-social-but-icon"><i class="td-icon-mail"></i></div><div class="td-social-but-text">Email</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#" title="Print" ><div class="td-social-but-icon"><i class="td-icon-print"></i></div><div class="td-social-but-text">Print</div></a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top" title="More"><div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div> </a></div></div></div><div class="td-post-content tagdiv-type"><div class="td-post-featured-image"><a href="https://www.rosevilletoday.com/wp-content/uploads/2022/03/Mazda-CX-5.jpg" data-caption=""><img width="655" height="450" class="entry-thumb td-modal-image" src="https://www.rosevilletoday.com/wp-content/uploads/2022/03/Mazda-CX-5.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/03/Mazda-CX-5.jpg 655w, https://www.rosevilletoday.com/wp-content/uploads/2022/03/Mazda-CX-5-300x206.jpg 300w, https://www.rosevilletoday.com/wp-content/uploads/2022/03/Mazda-CX-5-218x150.jpg 218w, https://www.rosevilletoday.com/wp-content/uploads/2022/03/Mazda-CX-5-611x420.jpg 611w, https://www.rosevilletoday.com/wp-content/uploads/2022/03/Mazda-CX-5-100x70.jpg 100w, https://www.rosevilletoday.com/wp-content/uploads/2022/03/Mazda-CX-5-600x412.jpg 600w" sizes="(max-width: 655px) 100vw, 655px" alt="Mazda CX-5" title="Mazda-CX-5"/></a></div><div class="td-a-rec td-a-rec-id-content_top td-rec-hide-on-m td-rec-hide-on-tl td-rec-hide-on-tp td-rec-hide-on-p tdi_3 td_block_template_11">
<style media="all">.tdi_3.td-a-rec{text-align:center}.tdi_3 .td-element-style{z-index:-1}.tdi_3.td-a-rec-img{text-align:left}.tdi_3.td-a-rec-img img{margin:0 auto 0 0}@media (max-width:767px){.tdi_3.td-a-rec-img{text-align:center}}</style></div><h2>Smartly-designed SUV ascends the ranks</h2><p>Roseville, Calif.- It&#8217;s hardly a secret the <a href="https://www.mazdausa.com/vehicles/cx-5" target="_blank" rel="noreferrer noopener nofollow">Mazda CX-5</a> has ascended to the top echelon in its class.</p><p>The numbers tell the story for the compact SUV that is rising to a rung just below the class heavyweights &#8211; <a href="https://www.rosevilletoday.com/columns/car-reviews/2021-toyota-rav4-hybrid/">Toyota RAV4</a> and <a href="https://www.rosevilletoday.com/columns/car-reviews/2020-honda-crv-hybrid/">Honda CR-V</a>.</p><div class="td-a-rec td-a-rec-id-content_inline tdi_2 td_block_template_11">
<style media="all">.tdi_2.td-a-rec{text-align:center}.tdi_2 .td-element-style{z-index:-1}.tdi_2.td-a-rec-img{text-align:left}.tdi_2.td-a-rec-img img{margin:0 auto 0 0}@media (max-width:767px){.tdi_2.td-a-rec-img{text-align:center}}</style><div class="td-visible-desktop"> Roseville Today sponsor</br> <a href="https://www.girlscouts.org/en/cookies.html?ref=RosevilleToday" title="Buy Girl Scout Cookies"><img src="https://www.rosevilletoday.com/gs/girlscouts645.jpg" alt="Where to buy Girl Scout Cookies"></a></div><div class="td-visible-tablet-landscape"> Roseville Today sponsor</br> <a href="https://www.girlscouts.org/en/cookies.html?ref=RosevilleToday" title="Buy Girl Scout Cookies"><img src="https://www.rosevilletoday.com/gs/girlscouts645.jpg" width="98%" alt="Where to buy Girl Scout Cookies"></a></div><div class="td-visible-tablet-portrait"> Roseville Today sponsor</br> <a href="https://www.girlscouts.org/en/cookies.html?ref=RosevilleToday" title="Buy Girl Scout Cookies"><img src="https://www.rosevilletoday.com/gs/girlscouts340.jpg" alt="Where to buy Girl Scout Cookies"></a></div><div class="td-visible-phone"> Roseville Today sponsor</br> <a href="https://www.girlscouts.org/en/cookies.html?ref=RosevilleToday" title="Buy Girl Scout Cookies"><img src="https://www.rosevilletoday.com/gs/girlscouts340.jpg" alt="Where to buy Girl Scout Cookies"></a></div></div><p>Since arriving in 2012 with sales of 43,319, the CX-5 has seen increasing sales figures every year but one &#8211; and that was the first pandemic year (2020).</p><p>Sales of the CX-5 increased by just over 22,000 a year ago, when it reached an all-time high of 168,448. Although sales of the CX-5 remain below its major competitors, note that the RAV4 had decreased sales of approximately 22,000 a year ago.</p><p>New for 2022 is the CX-5 is getting standard all-wheel drive across all trim levels. Toyota has updated the front and rear styling,</p><p>A year ago, the Mazda CX-5 arrived with a few appealing new wrinkles. Most notable was the larger infotainment system and the debut of the Carbon Edition trim model. The latest version of the CX-5 remains part of the successful 2017 redesign.</p><h3 id="h-performance">Performance</h3><div class="wp-block-image"><figure class="alignleft size-full"><img width="340" height="251" src="https://www.rosevilletoday.com/wp-content/uploads/2022/03/CX-5-interior.jpg" alt="" class="wp-image-70306" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/03/CX-5-interior.jpg 340w, https://www.rosevilletoday.com/wp-content/uploads/2022/03/CX-5-interior-300x221.jpg 300w, https://www.rosevilletoday.com/wp-content/uploads/2022/03/CX-5-interior-80x60.jpg 80w" sizes="(max-width: 340px) 100vw, 340px" /><figcaption>Inside the CX-5</figcaption></figure></div><p>The Mazda SUV has an impressive turbocharged engine &#8211; a 2.5-liter, inline four-cylinder that generates 227 horsepower and 310 pound-feet of torque. We were totally impressed with the power-on-demand it delivered.</p><p>The turbo is the optional engine for the CX-5. It goes 0-60 mph in 6.6 seconds, but doesn&#8217;t deliver good fuel economy &#8211; 23-28 mpg.</p><p>The standard CX-5 engine is not nearly as powerful as the turbo model. It&#8217;s a 2.5-liter, inline four-cylinder that produces 187 horsepower and 186-pound feet of torque.</p><p>Freeway passing capability and climbing steep hills can be an issue for the standard CX-5 due to the underwhelming acceleration. It goes 0-60 mph in 8.7 seconds, yet is more fuel efficient than the turbo engine, getting 25-31 mpg.</p><p>The smartly-designed SUV receives high marks for its driving acumen because it handles like a well-behaved sedan. It features responsive steering, a smooth ride, and superb handling on challenging roads. It&#8217;s also quiet, with wind and tire noise only heard at highway speeds.</p><p>The safety package on all CX-5 models includes smart brake support, lane-keeping assist, lane departure warning, blind-spot monitoring, radar cruise control with stop-and-go functions, advanced smart brake support with pedestrian detection, and rear cross-traffic alert.</p><h3 id="h-at-a-glance-2022-mazda-cx-5">AT A GLANCE &#8211; 2022 MAZDA CX-5</h3><ul><li>Performance: 2.5-liter, four-cylinder, 187 horsepower; turbocharged 2.5-liter, four-cylinder, 227 horsepower</li><li>Mileage estimate: 25-31 mpg; 23-28 mpg</li><li>Price estimate: $25,900 to $ $38,700</li><li>Warranty: 3 years/36,000 miles; drivetrain 5 years/60,000 miles; roadside assistance 3 years/36,000; corrosion 5 years/unlimited</li></ul><h3 id="h-trim-models">Trim Models</h3><p>The CX-5 has eight trim models (Base, Select, Preferred, Carbon Edition, Premium, Premium Plus, Turbo, Turbo Signature). The Carbon Edition is painted gray, has red-leather seats and 19-inch black alloy wheels.</p><h3 id="h-interior">Interior</h3><p>The interior gets mostly good mark, thanks to its upscale design and using quality materials. The new 10.25-inch display screen is fairly easy to use. The cabin is suited well for the driver, who has all controls within an easy reach. Both Apple CarPlay and Android Auto are standard features.</p><p>While the CX-5 is spacious up front, the three rear passengers can feel very cramped, especially if it&#8217;s three adults. The cargo area is adequate, offering 30.9 cubic feet of space that expands to 59.3 cubes with the second row down.</p><p>For a variety of reasons, the 2022 Mazda CX-5 is a smart buy. It has inched its way up to being among the top small SUVs.</p><div class="td-a-rec td-a-rec-id-content_bottom tdi_4 td_block_template_11">
<style media="all">.tdi_4.td-a-rec{text-align:center}.tdi_4 .td-element-style{z-index:-1}.tdi_4.td-a-rec-img{text-align:left}.tdi_4.td-a-rec-img img{margin:0 auto 0 0}@media (max-width:767px){.tdi_4.td-a-rec-img{text-align:center}}</style></div></div><footer><div class="td-post-source-tags"><ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://www.rosevilletoday.com/tag/car-reviews/">Car Reviews</a></li></ul></div><div class="td-post-sharing-bottom"><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-border td-ps-border-grey td-ps-rounded td-ps-padding td-ps-icon-color td-post-sharing-style18"><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.rosevilletoday.com%2Fnews%2Froseville%2Fmazda-cx5-review%2F" title="Facebook" ><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Mazda+CX-5+challenging+class+leaders&url=https%3A%2F%2Fwww.rosevilletoday.com%2Fnews%2Froseville%2Fmazda-cx5-review%2F&via=rrtoday" title="Twitter" ><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://www.rosevilletoday.com/news/roseville/mazda-cx5-review/&title=Mazda+CX-5+challenging+class+leaders" title="Linkedin" ><div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div><div class="td-social-but-text">Linkedin</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#7e410d0b1c141b1d0a43331f041a1f5e3d26534b5e1d161f12121b10191710195e1d121f0d0d5e121b1f1a1b0c0d581c111a0743160a0a0e0d445151090909500c110d1b081712121b0a111a1f07501d111351101b090d510c110d1b081712121b51131f041a1f531d064b530c1b08171b0951" title="Email"><div class="td-social-but-icon"><i class="td-icon-mail"></i></div><div class="td-social-but-text">Email</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#" title="Print" ><div class="td-social-but-icon"><i class="td-icon-print"></i></div><div class="td-social-but-text">Print</div></a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom" title="More"><div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div> </a></div></div></div><div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://www.rosevilletoday.com/news/roseville/electricity-consumption-increases-with-auto-pay/">Electricity Consumption Increases with Automatic Bill Payment</a></div></div><div class="td-next-prev-separator"></div></div><div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://www.rosevilletoday.com/author/jeffrey-weidel-weidel-on-wheels/">Jeffrey Weidel - Weidel on Wheels</a></span></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person">
<meta itemprop="name" content="Jeffrey Weidel - Weidel on Wheels">
<meta itemprop="url" content="https://www.rosevilletoday.com/author/jeffrey-weidel-weidel-on-wheels/"></span>
<meta itemprop="datePublished" content="2022-03-14T09:06:05-07:00">
<meta itemprop="dateModified" content="2022-03-14T09:06:06-07:00">
<meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.rosevilletoday.com/news/roseville/mazda-cx5-review/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
<meta itemprop="url" content="https://www.rosevilletoday.com/wp-content/uploads/2021/06/logo-blue2.png"></span>
<meta itemprop="name" content="Roseville Today"></span>
<meta itemprop="headline " content="Mazda CX-5 challenging class leaders"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
<meta itemprop="url" content="https://www.rosevilletoday.com/wp-content/uploads/2022/03/Mazda-CX-5.jpg">
<meta itemprop="width" content="655">
<meta itemprop="height" content="450"></span></footer><div class="td_block_wrap td_block_related_posts tdi_5 td_with_ajax_pagination td-pb-border-top td_block_template_11" data-td-block-uid="tdi_5" >
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>var block_tdi_5 = new tdBlock();
block_tdi_5.id = "tdi_5";
block_tdi_5.atts = '{"limit":6,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"tdi_5","td_column_number":3,"block_type":"td_block_related_posts","live_filter_cur_post_id":70304,"live_filter_cur_post_author":"4","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_5","tdc_css_class_style":"tdi_5_rand_style"}';
block_tdi_5.td_column_number = "3";
block_tdi_5.block_type = "td_block_related_posts";
block_tdi_5.post_count = "6";
block_tdi_5.found_posts = "2289";
block_tdi_5.header_color = "";
block_tdi_5.ajax_pagination_infinite_stop = "";
block_tdi_5.max_num_pages = "382";
tdBlocksArray.push(block_tdi_5);</script>
<h4 class="td-related-title td-block-title"><a id="tdi_6" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_5" href="#">▶ Related</a><a id="tdi_7" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_5" href="#">▶ More from Author</a></h4><div id=tdi_5 class="td_block_inner"><div class="td-related-row"><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/electricity-consumption-increases-with-auto-pay/" rel="bookmark" class="td-image-wrap" title="Electricity Consumption Increases with Automatic Bill Payment" ><img width="218" height="150" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2021/03/electricity-218x150.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2021/03/electricity-218x150.jpg 218w, https://www.rosevilletoday.com/wp-content/uploads/2021/03/electricity-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Electric" title="Electricity Consumption Increases with Automatic Bill Payment" /></a></div> <a href="https://www.rosevilletoday.com/news/lincoln/" class="td-post-category">Lincoln CA News</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/electricity-consumption-increases-with-auto-pay/" rel="bookmark" title="Electricity Consumption Increases with Automatic Bill Payment">Electricity Consumption Increases with Automatic Bill Payment</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/7-tips-changing-landscaping/" rel="bookmark" class="td-image-wrap" title="7 Tips To Consider for Changing Your Landscaping" ><img width="218" height="150" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2015/04/succulents-218x150.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2015/04/succulents-218x150.jpg 218w, https://www.rosevilletoday.com/wp-content/uploads/2015/04/succulents-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Succulents" title="7 Tips To Consider for Changing Your Landscaping" /></a></div> <a href="https://www.rosevilletoday.com/news/rocklin/" class="td-post-category">Rocklin News</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/7-tips-changing-landscaping/" rel="bookmark" title="7 Tips To Consider for Changing Your Landscaping">7 Tips To Consider for Changing Your Landscaping</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/roseville-adopt-a-creek-event/" rel="bookmark" class="td-image-wrap" title="Roseville Adopt-A-Creek this Saturday Kaseberg Creek at Mahany" ><img width="218" height="150" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/03/creek-218x150.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/03/creek-218x150.jpg 218w, https://www.rosevilletoday.com/wp-content/uploads/2022/03/creek-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Roseville Creek" title="Roseville Adopt-A-Creek this Saturday Kaseberg Creek at Mahany" /></a></div> <a href="https://www.rosevilletoday.com/news/roseville/" class="td-post-category">Roseville News</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/roseville-adopt-a-creek-event/" rel="bookmark" title="Roseville Adopt-A-Creek this Saturday Kaseberg Creek at Mahany">Roseville Adopt-A-Creek this Saturday Kaseberg Creek at Mahany</a></h3></div></div></div></div><div class="td-related-row"><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/8-tips-tax-against-return-fraud/" rel="bookmark" class="td-image-wrap" title="8 Tips to Protect Yourself from Tax Return Fraud" ><img width="218" height="150" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2015/04/fraud-218x150.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2015/04/fraud-218x150.jpg 218w, https://www.rosevilletoday.com/wp-content/uploads/2015/04/fraud-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Tax Return Fraud" title="8 Tips to Protect Yourself from Tax Return Fraud" /></a></div> <a href="https://www.rosevilletoday.com/news/roseville/" class="td-post-category">Roseville News</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/8-tips-tax-against-return-fraud/" rel="bookmark" title="8 Tips to Protect Yourself from Tax Return Fraud">8 Tips to Protect Yourself from Tax Return Fraud</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/guide-to-roseville-golf-courses/" rel="bookmark" class="td-image-wrap" title="Quick Guide to Roseville Golf Courses" ><img width="218" height="150" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2021/06/roseville-golf-courses-1-218x150.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2021/06/roseville-golf-courses-1-218x150.jpg 218w, https://www.rosevilletoday.com/wp-content/uploads/2021/06/roseville-golf-courses-1-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Roseville Golf Course" title="Quick Guide to Roseville Golf Courses" /></a></div> <a href="https://www.rosevilletoday.com/news/roseville/" class="td-post-category">Roseville News</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/guide-to-roseville-golf-courses/" rel="bookmark" title="Quick Guide to Roseville Golf Courses">Quick Guide to Roseville Golf Courses</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/placer-county-camping-ordinance-approved/" rel="bookmark" class="td-image-wrap" title="Placer County approves new camping ordinance seeking to address challenges of homelessness" ><img width="218" height="150" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2021/07/homeless-camp-218x150.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2021/07/homeless-camp-218x150.jpg 218w, https://www.rosevilletoday.com/wp-content/uploads/2021/07/homeless-camp-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Homeless camp" title="Placer County approves new camping ordinance seeking to address challenges of homelessness" /></a></div> <a href="https://www.rosevilletoday.com/news/auburn/" class="td-post-category">Auburn</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/placer-county-camping-ordinance-approved/" rel="bookmark" title="Placer County approves new camping ordinance seeking to address challenges of homelessness">Placer County approves new camping ordinance seeking to address challenges of homelessness</a></h3></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_5" data-td_block_id="tdi_5"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_5" data-td_block_id="tdi_5"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div></div></div></div><div class="td-pb-span4 td-main-sidebar" role="complementary"><div class="td-ss-main-sidebar"><aside id="custom_html-26" class="widget_text td_block_template_11 widget custom_html-26 widget_custom_html"><h4 class="td-block-title"><span>♥ Local Girl Scout Cookies ♥</span></h4><div class="textwidget custom-html-widget"><a href="https://www.girlscouts.org/en/cookies.html?ref=RosevilleToday" title="Buy Girl Scout Cookies"><img src="https://www.rosevilletoday.com/gs/girlscouts300.jpg" width="300" height="250" alt="Where to buy Girl Scout Cookies"></a></div></aside><aside id="rss-4" class="td_block_template_11 widget rss-4 widget_rss"><h4 class="td-block-title"><span><a class="rsswidget rss-widget-feed" href="https://www.rosevilletoday.com/yp/feed/rss2/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.rosevilletoday.com/wp-includes/images/rss.png" alt="RSS" loading="lazy" /></a> <a class="rsswidget rss-widget-title" href="https://www.rosevilletoday.com/yp">Business Updates</a></span></h4><ul><li><a class='rsswidget' href='https://www.rosevilletoday.com/yp/adora-luxury-townhomes/'>Adora Luxury Townhomes</a></li><li><a class='rsswidget' href='https://www.rosevilletoday.com/yp/primo-pizza-rocklin/'>Primo Pizza</a></li><li><a class='rsswidget' href='https://www.rosevilletoday.com/yp/terraces-at-stanford-ranch/'>The Terraces at Stanford Ranch</a></li><li><a class='rsswidget' href='https://www.rosevilletoday.com/yp/izumi-japanese-restaurant/'>Izumi Japanese Restaurant</a></li><li><a class='rsswidget' href='https://www.rosevilletoday.com/yp/brighton-apartments-rocklin/'>The Brighton Apartments</a></li></ul></aside><aside id="custom_html-18" class="widget_text td_block_template_11 widget custom_html-18 widget_custom_html"><h4 class="td-block-title"><span>♥ our Local Sponsors</span></h4><div class="textwidget custom-html-widget"><div id='div-gpt-ad-1526924072370-0' style='width: 300px; height: 250px;'> 
<script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1526924072370-0'); });</script>
</div></div></aside><aside id="custom_html-24" class="widget_text td_block_template_11 widget custom_html-24 widget_custom_html"><h4 class="td-block-title"><span>Local Business &#8211; Join Today!</span></h4><div class="textwidget custom-html-widget"><h4>Dining</h4><ul><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/restaurants/indian/">Indian Restaurants</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/restaurants/bakeries/">Bakeries</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/restaurants/craft-beer/">Craft Brews</a></li></ul><h4>Health &amp; Fitness</h4><ul><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/health-fitness/alternative-medicine/">Alternative Medicine</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/health-fitness/dentists/">Dentists</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/health-fitness/swim-lessons/">Swim Lessons</a></li></ul><h4>Home Improvement</h4><ul><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/home-improvement/heating-air/">Heating and Air</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/home-improvement/pest-control/">Pest Control</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/home-improvement/solar-panel-cleaning/">Solar Panel Cleaning</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/business/window-cleaning/">Window Cleaning</a></li></ul><h4>Real Estate</h4><ul><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/real-estate/apartment-rentals/">Apartments</a></li><li class="yp"><a class="yps" href="https://www.rosevilletoday.com/yp/real-estate/real-estate-agents/">Real Estate Agents</a></li></ul></div></aside></div></div></div></article></div></div><div class="tdc-footer-wrap"><div class="td-footer-wrapper td-footer-container td-container-wrap"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span12"></div></div><div class="td-pb-row"><div class="td-pb-span4"><div class="td_block_wrap td_block_16 td_block_widget tdi_9 td-pb-border-top td_block_template_11 td-column-1 td_block_padding" data-td-block-uid="tdi_9" >
<style media="all">.td_block_template_11.widget>ul>li{margin-left:0!important}.td_block_template_11 .td-block-title{font-size:17px;font-weight:500;margin-top:2px;margin-bottom:24px;line-height:44px;padding:0;position:relative;text-align:left}.td_block_template_11 .td-block-title:before,.td_block_template_11 .td-block-title:after{content:'';width:100%;height:2px;position:absolute;left:0;background-color:#f5f5f5}.td_block_template_11 .td-block-title:after{bottom:100%}.td_block_template_11 .td-block-title:before{top:100%}.td_block_template_11 .td-block-title>*{color:#000}.td_block_template_11 .td-subcat-filter{line-height:44px;display:table}.td_block_template_11 .td-subcat-dropdown{line-height:1;position:static}.td_block_template_11 .td-subcat-dropdown .td-subcat-more{margin-bottom:0!important}.td_block_template_11 .td-subcat-dropdown ul:after{height:2px!important}.td_block_template_11 .td-related-title a{margin-right:20px}@media (max-width:767px){.td_block_template_11 .td-related-title a{font-size:15px}}.td_block_template_11 .td-related-title .td-cur-simple-item{color:#4db2ec}</style>
<script>var block_tdi_9 = new tdBlock();
block_tdi_9.id = "tdi_9";
block_tdi_9.atts = '{"custom_title":"Latest News","custom_url":"","block_template_id":"","header_text_color":"#","border_color":"#","accent_text_color":"#","mx7_tl":"","mx7_el":"","m6_tl":"","limit":"3","offset":"","el_class":"","post_ids":"-70304","category_id":"","category_ids":"21,27","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget tdi_9","block_type":"td_block_16","separator":"","show_modified_date":"","time_ago":"","time_ago_add_txt":"ago","time_ago_txt_pos":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","mx7f_title_font_header":"","mx7f_title_font_title":"Article title","mx7f_title_font_settings":"","mx7f_title_font_family":"","mx7f_title_font_size":"","mx7f_title_font_line_height":"","mx7f_title_font_style":"","mx7f_title_font_weight":"","mx7f_title_font_transform":"","mx7f_title_font_spacing":"","mx7f_title_":"","mx7f_cat_font_title":"Article category tag","mx7f_cat_font_settings":"","mx7f_cat_font_family":"","mx7f_cat_font_size":"","mx7f_cat_font_line_height":"","mx7f_cat_font_style":"","mx7f_cat_font_weight":"","mx7f_cat_font_transform":"","mx7f_cat_font_spacing":"","mx7f_cat_":"","mx7f_meta_font_title":"Article meta info","mx7f_meta_font_settings":"","mx7f_meta_font_family":"","mx7f_meta_font_size":"","mx7f_meta_font_line_height":"","mx7f_meta_font_style":"","mx7f_meta_font_weight":"","mx7f_meta_font_transform":"","mx7f_meta_font_spacing":"","mx7f_meta_":"","mx7f_ex_font_title":"Article excerpt","mx7f_ex_font_settings":"","mx7f_ex_font_family":"","mx7f_ex_font_size":"","mx7f_ex_font_line_height":"","mx7f_ex_font_style":"","mx7f_ex_font_weight":"","mx7f_ex_font_transform":"","mx7f_ex_font_spacing":"","mx7f_ex_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","color_preset":"","border_top":"","tdc_css_class":"tdi_9","tdc_css_class_style":"tdi_9_rand_style"}';
block_tdi_9.td_column_number = "1";
block_tdi_9.block_type = "td_block_16";
block_tdi_9.post_count = "3";
block_tdi_9.found_posts = "6710";
block_tdi_9.header_color = "";
block_tdi_9.ajax_pagination_infinite_stop = "";
block_tdi_9.max_num_pages = "2237";
tdBlocksArray.push(block_tdi_9);</script>
<div class="td-block-title-wrap"><h4 class="td-block-title"><span class="td-pulldown-size">Latest News</span></h4></div><div id=tdi_9 class="td_block_inner td-column-1"><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/electricity-consumption-increases-with-auto-pay/" rel="bookmark" class="td-image-wrap" title="Electricity Consumption Increases with Automatic Bill Payment" ><img width="100" height="70" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2021/03/electricity-100x70.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2021/03/electricity-100x70.jpg 100w, https://www.rosevilletoday.com/wp-content/uploads/2021/03/electricity-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Electric" title="Electricity Consumption Increases with Automatic Bill Payment" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/electricity-consumption-increases-with-auto-pay/" rel="bookmark" title="Electricity Consumption Increases with Automatic Bill Payment">Electricity Consumption Increases with Automatic Bill Payment</a></h3><div class="td-module-meta-info"></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/7-tips-changing-landscaping/" rel="bookmark" class="td-image-wrap" title="7 Tips To Consider for Changing Your Landscaping" ><img width="100" height="70" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2015/04/succulents-100x70.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2015/04/succulents-100x70.jpg 100w, https://www.rosevilletoday.com/wp-content/uploads/2015/04/succulents-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Succulents" title="7 Tips To Consider for Changing Your Landscaping" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/7-tips-changing-landscaping/" rel="bookmark" title="7 Tips To Consider for Changing Your Landscaping">7 Tips To Consider for Changing Your Landscaping</a></h3><div class="td-module-meta-info"></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/rocklin/taste-of-excellence-sierra-college-foundation/" rel="bookmark" class="td-image-wrap" title="The Taste of Excellence presented by Sierra College Foundation" ><img width="100" height="70" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2016/03/news-100x70.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2016/03/news-100x70.jpg 100w, https://www.rosevilletoday.com/wp-content/uploads/2016/03/news-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="News" title="The Taste of Excellence presented by Sierra College Foundation" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/rocklin/taste-of-excellence-sierra-college-foundation/" rel="bookmark" title="The Taste of Excellence presented by Sierra College Foundation">The Taste of Excellence presented by Sierra College Foundation</a></h3><div class="td-module-meta-info"></div></div></div></div></div></div></div><div class="td-pb-span4"><div class="td_block_wrap td_block_weather td_block_widget tdi_10 td-pb-border-top td_block_template_11" data-td-block-uid="tdi_10" >
<style media="all">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</style><div class="td-block-title-wrap"></div><div id=tdi_10 class="td-weather-wrap td_block_inner td-column-1"><div class="td-weather-header"><div class="td-weather-city">Roseville</div><div class="td-weather-condition">clear sky</div> <i class="td-location-icon td-icons-location" data-block-uid="tdi_10"></i></div><div class="td-weather-set-location"><form class="td-manual-location-form" action="#" data-block-uid="tdi_10"> <input id="tdi_10" class="td-location-set-input" type="text" name="location" value=""> <label>enter location</label></form></div><div class="td-weather-temperature"><div class="td-weather-temp-wrap"><div class="td-weather-animated-icon"> <span class="td_animation_sprite-27-100-80-0-0-1 clear-sky-d td-w-today-icon" data-td-block-uid="tdi_10"></span></div><div class="td-weather-now" data-block-uid="tdi_10"> <span class="td-big-degrees">49.7</span> <span class="td-circle">&deg;</span> <span class="td-weather-unit">F</span></div><div class="td-weather-lo-hi"><div class="td-weather-degrees-wrap"> <i class="td-up-icon td-icons-arrows-up"></i> <span class="td-small-degrees td-w-high-temp">57.6</span> <span class="td-circle">&deg;</span></div><div class="td-weather-degrees-wrap"> <i class="td-down-icon td-icons-arrows-down"></i> <span class="td-small-degrees td-w-low-temp">42.9</span> <span class="td-circle">&deg;</span></div></div></div></div><div class="td-weather-info-wrap"><div class="td-weather-information"><div class="td-weather-section-1"> <i class="td-icons-drop"></i> <span class="td-weather-parameter td-w-today-humidity">74 %</span></div><div class="td-weather-section-2"> <i class="td-icons-wind"></i> <span class="td-weather-parameter td-w-today-wind-speed">1.3mph</span></div><div class="td-weather-section-3"> <i class="td-icons-cloud"></i> <span class="td-weather-parameter td-w-today-clouds">0 %</span></div></div><div class="td-weather-week"><div class="td-weather-days"><div class="td-day-0">Mon</div><div class="td-day-degrees"> <span class="td-degrees-0">68</span> <span class="td-circle">&deg;</span></div></div><div class="td-weather-days"><div class="td-day-1">Tue</div><div class="td-day-degrees"> <span class="td-degrees-1">68</span> <span class="td-circle">&deg;</span></div></div><div class="td-weather-days"><div class="td-day-2">Wed</div><div class="td-day-degrees"> <span class="td-degrees-2">65</span> <span class="td-circle">&deg;</span></div></div><div class="td-weather-days"><div class="td-day-3">Thu</div><div class="td-day-degrees"> <span class="td-degrees-3">66</span> <span class="td-circle">&deg;</span></div></div><div class="td-weather-days"><div class="td-day-4">Fri</div><div class="td-day-degrees"> <span class="td-degrees-4">67</span> <span class="td-circle">&deg;</span></div></div></div></div></div></div></div><div class="td-pb-span4"><div class="td_block_wrap td_block_7 td_block_widget tdi_11 td-pb-border-top td_block_template_11 td-column-1 td_block_padding" data-td-block-uid="tdi_11" >
<script>var block_tdi_11 = new tdBlock();
block_tdi_11.id = "tdi_11";
block_tdi_11.atts = '{"custom_title":"Local Real Estate","custom_url":"","block_template_id":"","header_text_color":"#","border_color":"#","accent_text_color":"#","m6_tl":"","limit":"3","offset":"","time_ago_add_txt":"ago","el_class":"","post_ids":"-70304","category_id":"30","category_ids":"53","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget tdi_11","block_type":"td_block_7","separator":"","show_modified_date":"","time_ago":"","time_ago_txt_pos":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","color_preset":"","border_top":"","tdc_css_class":"tdi_11","tdc_css_class_style":"tdi_11_rand_style"}';
block_tdi_11.td_column_number = "1";
block_tdi_11.block_type = "td_block_7";
block_tdi_11.post_count = "3";
block_tdi_11.found_posts = "194";
block_tdi_11.header_color = "";
block_tdi_11.ajax_pagination_infinite_stop = "";
block_tdi_11.max_num_pages = "65";
tdBlocksArray.push(block_tdi_11);</script>
<div class="td-block-title-wrap"><h4 class="td-block-title"><span class="td-pulldown-size">Local Real Estate</span></h4></div><div id=tdi_11 class="td_block_inner"><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/is-housing-market-going-to-crash/" rel="bookmark" class="td-image-wrap" title="Is the Housing Market going to Crash?" ><img width="100" height="70" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/02/housing-market-100x70.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/02/housing-market-100x70.jpg 100w, https://www.rosevilletoday.com/wp-content/uploads/2022/02/housing-market-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Housing Market" title="Is the Housing Market going to Crash?" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/is-housing-market-going-to-crash/" rel="bookmark" title="Is the Housing Market going to Crash?">Is the Housing Market going to Crash?</a></h3><div class="td-module-meta-info"></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/news/roseville/spring-real-estate-market-roseville/" rel="bookmark" class="td-image-wrap" title="Spring Real Estate Market in Roseville" ><img width="100" height="70" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/02/cherry-blossom-100x70.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/02/cherry-blossom-100x70.jpg 100w, https://www.rosevilletoday.com/wp-content/uploads/2022/02/cherry-blossom-218x150.jpg 218w, https://www.rosevilletoday.com/wp-content/uploads/2022/02/cherry-blossom-324x226.jpg 324w" sizes="(max-width: 100px) 100vw, 100px" alt="Cherry Blossoms" title="Spring Real Estate Market in Roseville" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/news/roseville/spring-real-estate-market-roseville/" rel="bookmark" title="Spring Real Estate Market in Roseville">Spring Real Estate Market in Roseville</a></h3><div class="td-module-meta-info"></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide"><div class="td-module-thumb"><a href="https://www.rosevilletoday.com/columns/real-estate/poor-real-estate-offers/" rel="bookmark" class="td-image-wrap" title="Poor Real Estate Offers" ><img width="100" height="70" class="entry-thumb" src="https://www.rosevilletoday.com/wp-content/uploads/2022/01/home-porch-100x70.jpg" srcset="https://www.rosevilletoday.com/wp-content/uploads/2022/01/home-porch-100x70.jpg 100w, https://www.rosevilletoday.com/wp-content/uploads/2022/01/home-porch-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Front porch of home" title="Poor Real Estate Offers" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.rosevilletoday.com/columns/real-estate/poor-real-estate-offers/" rel="bookmark" title="Poor Real Estate Offers">Poor Real Estate Offers</a></h3><div class="td-module-meta-info"></div></div></div></div></div></div></div></div></div><div class="td-footer-bottom-full"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="https://www.rosevilletoday.com/"><img src="https://www.rosevilletoday.com/wp-content/uploads/2020/12/roseville-today-logo.png" alt="Roseville Today logo" title="" width="272" height="90"/></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div>Business, Travel, & Entertainment. A locally owned, community supported online business since 2003. We're located in Roseville, California and proudly serve communities throughout Placer County and the entire Golden State. <br><br> <b>We have NO affiliation with print or corporate media.</b></aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/RosevilleToday" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.instagram.com/rosevilletoday/" title="Instagram"> <i class="td-icon-font td-icon-instagram"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.rosevilletoday.com/news/feed/" title="RSS"> <i class="td-icon-font td-icon-rss"></i> </a> </span></aside></div></div></div></div></div><div class="td-sub-footer-container td-container-wrap"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span td-sub-footer-menu"><div class="menu-td-demo-footer-menu-container"><ul id="menu-td-demo-footer-menu" class="td-subfooter-menu"><li id="menu-item-49285" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-49285"><a href="https://www.rosevilletoday.com/">Roseville Today</a></li><li id="menu-item-49286" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-49286"><a href="https://www.rosevilletoday.com/yp/">YP</a></li><li id="menu-item-161" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-161"><a href="/about/">About Us</a></li><li id="menu-item-160" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-160"><a href="/privacy-policy/">Privacy Policy</a></li><li id="menu-item-159" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-159"><a href="/contact/">Contact Us</a></li><li id="menu-item-162" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-162"><a href="/advertise/">Advertise</a></li></ul></div></div><div class="td-pb-span td-sub-footer-copy"> &copy; Roseville Today | 4010 Foothills Blvd. 103- #28 | Roseville, CA 95747</div></div></div></div></div></div> 
<script>( function ( body ) {
'use strict';
body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
} )( document.body );</script>
<style type="text/css" media="all">.td-post-featured-image{float:left;display:block;width:auto;margin:14px}.td-category-pulldown-filter td-wrapper-pulldown-filter{display:none}.td-pulldown-filter-display-option{display:none}.td-subcat-more{display:none}.td-icon-menu-down{display:none}.td-pulldown-filter-list{display:none}.td-pulldown-filter-item{display:none}</style> 
<script>var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"},"registration_prompt":"There is unsaved attendee information. Are you sure you want to continue?"};</script>
<script>(function () {
var c = document.body.className;
c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
document.body.className = c;
})();</script>
<script id='jquery-deparam-js-extra'>var TribeTicketsPlus = {"ajaxurl":"https:\/\/www.rosevilletoday.com\/wp-admin\/admin-ajax.php","save_attendee_info_nonce":"fe0779f1af"};</script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/event-tickets-plus/vendor/jquery.deparam/jquery.deparam.js?ver=5.4.0' id='jquery-deparam-js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/event-tickets-plus/vendor/jquery.cookie/jquery.cookie.js?ver=5.4.0' id='jquery-cookie-js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/event-tickets-plus/src/resources/js/attendees-list.min.js?ver=5.4.0' id='event-tickets-plus-attendees-list-js-js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/event-tickets-plus/src/resources/js/meta.min.js?ver=5.4.0' id='event-tickets-plus-meta-js-js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/event-tickets/src/resources/js/ticket-details.min.js?ver=5.3.0.1' id='event-tickets-details-js-js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/event-tickets/src/resources/js/rsvp.min.js?ver=5.3.0.1' id='event-tickets-tickets-rsvp-js-js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js?ver=2.7.0-wc.6.3.1' id='jquery-blockui-js'></script>
<script id='wc-add-to-cart-js-extra'>var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/www.rosevilletoday.com\/cart\/","is_cart":"","cart_redirect_after_add":"yes"};</script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart.min.js?ver=6.3.1' id='wc-add-to-cart-js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/woocommerce/assets/js/js-cookie/js.cookie.min.js?ver=2.1.4-wc.6.3.1' id='js-cookie-js'></script>
<script id='woocommerce-js-extra'>var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};</script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js?ver=6.3.1' id='woocommerce-js'></script>
<script id='wc-cart-fragments-js-extra'>var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_99652f39b82f1d3ffdbee0deb146621a","fragment_name":"wc_fragments_99652f39b82f1d3ffdbee0deb146621a","request_timeout":"5000"};</script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js?ver=6.3.1' id='wc-cart-fragments-js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/event-tickets/common/src/resources/js/underscore-before.js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-includes/js/underscore.min.js?ver=1.13.1' id='underscore-js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/event-tickets/common/src/resources/js/underscore-after.js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=173ee1f64e1c2648598d8860d0189118' id='tdb_js_posts_autoload-js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=11.4.2' id='td-site-min-js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-includes/js/comment-reply.min.js?ver=5.9.2' id='comment-reply-js'></script>
<script id='event-tickets-rsvp-js-extra'>var tribe_tickets_rsvp_strings = {"attendee":"Attendee %1$s"};</script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/event-tickets/src/resources/js/rsvp.min.js?ver=5.3.0.1' id='event-tickets-rsvp-js'></script>
<script async='async' src='https://www.rosevilletoday.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=173ee1f64e1c2648598d8860d0189118' id='tdb_js_files_for_front-js'></script>
<style id='tribe-common-full-style-inline-css' class='tec-customizer-inline-style' type='text/css' media="all">:root{--tec-color-text-events-title:#000;--tec-color-text-event-title:#000;--tec-color-link-primary:#014e9b;--tec-color-link-accent:#014e9b;--tec-color-link-accent-hover:rgba(1,78,155,0.8);--tec-color-accent-primary:#023d67;--tec-color-accent-primary-hover:rgba(2,61,103,0.8);--tec-color-accent-primary-multiday:rgba(2,61,103,0.24);--tec-color-accent-primary-multiday-hover:rgba(2,61,103,0.34);--tec-color-accent-primary-active:rgba(2,61,103,0.9);--tec-color-accent-primary-background:rgba(2,61,103,0.07);--tec-color-background-secondary-datepicker:rgba(2,61,103,0.5);--tec-color-accent-primary-background-datepicker:#023d67;--tec-color-button-primary:#023d67;--tec-color-button-primary-hover:rgba(2,61,103,0.8);--tec-color-button-primary-active:rgba(2,61,103,0.9);--tec-color-button-primary-background:rgba(2,61,103,0.07);--tec-color-day-marker-current-month:#023d67;--tec-color-day-marker-current-month-hover:rgba(2,61,103,0.8);--tec-color-day-marker-current-month-active:rgba(2,61,103,0.9);--tec-color-background-primary-multiday:rgba(2,61,103,0.24);--tec-color-background-primary-multiday-hover:rgba(2,61,103,0.34);--tec-color-background-primary-multiday-active:rgba(2,61,103,0.34);--tec-color-background-secondary-multiday:rgba(2,61,103,0.24);--tec-color-background-secondary-multiday-hover:rgba(2,61,103,0.34)}:root{--tec-color-background-events-bar-submit-button:#023d67;--tec-color-background-events-bar-submit-button-hover:rgba(2,61,103,0.8);--tec-color-background-events-bar-submit-button-active:rgba(2,61,103,0.9)}.tribe-common.event-tickets .tribe-tickets__rsvp-actions-success-going-check-icon,.tribe-common.event-tickets .tribe-common-c-btn:disabled{background-color:#023d67}.tribe-common.event-tickets .tribe-tickets__rsvp-message{background-color:rgba(2,61,103,0.07)}.tribe-common.event-tickets .tribe-tickets__rsvp-message-link{color:#023d67}.tribe-common.event-tickets .tribe-common-cta--alt,.tribe-common.event-tickets .tribe-common-cta--alt:active,.tribe-common.event-tickets .tribe-common-cta--alt:hover,.tribe-common.event-tickets .tribe-common-cta--alt:focus,.tribe-common.event-tickets .tribe-common-cta--thin-alt,.tribe-common.event-tickets .tribe-common-cta--thin-alt:active,.tribe-common.event-tickets .tribe-common-cta--thin-alt:focus,.tribe-common.event-tickets .tribe-common-cta--thin-alt:hover{border-bottom-color:#023d67}.tribe-common.event-tickets .tribe-common-cta--alt:active,.tribe-common.event-tickets .tribe-common-cta--alt:hover,.tribe-common.event-tickets .tribe-common-cta--alt:focus,.tribe-common.event-tickets .tribe-common-cta--thin-alt:active,.tribe-common.event-tickets .tribe-common-cta--thin-alt:hover,.tribe-common.event-tickets .tribe-common-cta--thin-alt:focus,.tribe-theme-twentyseventeen .tribe-common.event-tickets .tribe-common-cta--alt:hover,.tribe-theme-twentyseventeen .tribe-common.event-tickets .tribe-common-cta--alt:focus,.tribe-theme-twentyseventeen .tribe-common.event-tickets .tribe-common-cta--thin-alt:hover,.tribe-theme-twentyseventeen .tribe-common.event-tickets .tribe-common-cta--thin-alt:focus{color:#023d67}.tribe-common.event-tickets .tribe-common-c-btn,.tribe-common.event-tickets a.tribe-common-c-btn{background-color:#023d67}.tribe-common.event-tickets .tribe-common-c-btn:focus,.tribe-common.event-tickets .tribe-common-c-btn:hover,.tribe-common.event-tickets a.tribe-common-c-btn:focus,.tribe-common.event-tickets a.tribe-common-c-btn:hover{background-color:rgba(2,61,103,0.8)}.tribe-common.event-tickets .tribe-common-c-btn:active,.tribe-common.event-tickets a.tribe-common-c-btn:active{background-color:rgba(2,61,103,0.9)}.tribe-common.event-tickets .tribe-common-c-btn:disabled,.tribe-common.event-tickets a.tribe-common-c-btn:disabled{background-color:#023d67}.tribe-theme-twentytwenty .tribe-common.event-tickets .tribe-common-c-btn{background-color:#023d67}.tribe-theme-twentyseventeen .tribe-common.event-tickets .tribe-common-c-btn:hover,.tribe-theme-twentyseventeen .tribe-common.event-tickets .tribe-common-c-btn:focus,.tribe-theme-twentytwenty .tribe-common.event-tickets .tribe-common-c-btn:hover,.tribe-theme-twentytwenty .tribe-common.event-tickets .tribe-common-c-btn:focus{background-color:rgba(2,61,103,0.8)}@keyframes tribe-common-c-loader-bounce{0%{}50%{background-color:#023d67}}</style>
<script>!function(){window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[],advanced_ads_ready_queue.push=window.advanced_ads_ready;for(var d=0,a=advanced_ads_ready_queue.length;d<a;d++)advanced_ads_ready(advanced_ads_ready_queue[d])}();</script>
<script>jQuery().ready(function () {
tdWeather.addItem({"block_uid":"tdi_10","location":"5388881","api_location":"Roseville","api_language":"en","api_key":"ae6740d1cdd712b8489a62751fd67013","today_icon":"clear-sky-d","today_icon_text":"clear sky","today_temp":[9.9000000000000004,49.700000000000003],"today_humidity":74,"today_wind_speed":[2.1000000000000001,1.3],"today_min":[6.0999999999999996,42.899999999999999],"today_max":[14.199999999999999,57.600000000000001],"today_clouds":0,"current_unit":1,"forecast":[{"timestamp":1647280800,"day_name":"Mon","day_temp":[20,68],"owm_day_index":0},{"timestamp":1647302400,"day_name":"Tue","day_temp":[20,68],"owm_day_index":2},{"timestamp":1647388800,"day_name":"Wed","day_temp":[19,65],"owm_day_index":10},{"timestamp":1647475200,"day_name":"Thu","day_temp":[19,66],"owm_day_index":18},{"timestamp":1647561600,"day_name":"Fri","day_temp":[20,67],"owm_day_index":26},{"timestamp":1647648000,"day_name":"Sat","day_temp":[20,68],"owm_day_index":34}]});
});</script>
<style media="all">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</style>
<script type='text/javascript' id='fvm-delayjs' data-cfasync='false'>
!function(k,e,x){function r(d,a,g,b){return b=(a?e.getElementById(a):t)||e.createElement(d||"SCRIPT"),a&&(b.id=a),g&&(b.onload=g),b}function u(d){f(function(a){a=[].slice.call(e.querySelectorAll(d));(function v(b,c){if(b=a.shift()){b.parentNode.removeChild(b);var l=b,m,n=void 0;var p=r(l.nodeName);var q=0;for(m=l.attributes;q<m.length;q++)"type"!=(n=m[q]).name&&p.setAttribute(n.name,n.value);(c=(p.text=l.text,p)).src&&!c.hasAttribute("async")?(c.onload=c.onerror=v,e.head.appendChild(c)):(e.head.appendChild(c),
v())}})()})}var f,t,h=[],w=/p/.test(e.readyState);Function();(f=function(d,a){w?x(d,a):h.push(d,a)}).all=u;f.js=function(d,a,g,b){f(function(c){(c=r(t,a,b)).src=d;e.head.appendChild(c)},g)};k.addEventListener("onpageshow"in k?"pageshow":"load",function(){for(w=!u();h[0];)f(h.shift(),h.shift())});k.Defer=f}(this,document,setTimeout);
const userInteractionEvents=["mouseover","keydown","touchstart","touchmove","wheel"];userInteractionEvents.forEach(function(event){window.addEventListener(event,triggerScriptLoader,{passive:!0})});function triggerScriptLoader(){fvmloadscripts();userInteractionEvents.forEach(function(event){window.removeEventListener(event,triggerScriptLoader,{passive:!0})})}function fvmloadscripts(){Defer.all('script[type="fvm-script-delay"]')};
</script>
<script type="text/javascript">(function(){window['__CF$cv$params']={r:'6ebebd12eb8681eb',m:'nhc3z_rCLsX4i73V7dcN8hiTBox.HiQdOVbyEUHL9T8-1647279040-0-Ac7YDnMydELlK4LMGxW5KoiIovW5MWEHkzVMADjUTMZ8AzwCE22GjJF3t8URq6wYfTxtGLUhaLrEePc9rE8WNJT5QTARSPZs0aGMRpWbA9TwPVIiARiBoD3hZiYKga/i0K5/2wgO1P0IZjzFALIxNYxaPLhJs4MhOQlj2+xlRhGJ',s:[0x7f49ab9910,0x741fbe85ee],}})();</script><script defer src="https://static.cloudflareinsights.com/beacon.min.js/v652eace1692a40cfa3763df669d7439c1639079717194" integrity="sha512-Gi7xpJR8tSkrpF7aordPZQlW2DLtzUlZcumS8dMQjwDHEnw9I7ZLyiOj/6tZStRBGtGgN6ceN6cMH8z7etPGlw==" data-cf-beacon='{"rayId":"6ebebd12eb8681eb","token":"9639abc27d734ec8b96408e75d059522","version":"2021.12.0","si":100}' crossorigin="anonymous"></script>
</body>
</html>